LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 05-05-2005, 09:24 PM   #1
abefroman
Senior Member
 
Registered: Feb 2004
Location: Chicago
Distribution: CentOS
Posts: 1,266

Rep: Reputation: 53
Unable to install ethereal, I get the error: 'pkg-config --modversion glib-2.0' retur


Unable to install ethereal, I get the error:
*** 'pkg-config --modversion glib-2.0' returned 2.6.0, but GLIB (2.2.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.5.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

How do I fix this?

My LD_LIBRARY_PATH is not set:
# echo $LD_LIBRARY_PATH

#

And Im not sure what i am suppose to put in /etc/ld.so.conf:
# cat /etc/ld.so.conf
/usr/kerberos/lib
/usr/X11R6/lib
#

# locate libglib
/root/glib-2.6.0/glib/.libs/libglib-2.0.exp
/root/glib-2.6.0/glib/.libs/libglib-2.0.ver
/root/glib-2.6.0/glib/.libs/libglib-2.0.so.0.600.0
/root/glib-2.6.0/glib/.libs/libglib-2.0.so.0
/root/glib-2.6.0/glib/.libs/libglib-2.0.so
/root/glib-2.6.0/glib/.libs/libglib-2.0.lai
/root/glib-2.6.0/glib/.libs/libglib-2.0.la
/root/glib-2.6.0/glib/libglib-2.0.la
/root/pkgconfig-0.15.0/glib-1.2.8/.libs/libglib.al
/root/pkgconfig-0.15.0/glib-1.2.8/.libs/libglib.la
/root/pkgconfig-0.15.0/glib-1.2.8/libglib.la
/usr/lib/libglib-1.2.so.0.0.10
/usr/lib/libglib-1.2.so.0
/usr/lib/libglib-2.0.so.0.200.3
/usr/lib/libglib-2.0.so.0
/usr/local/lib/libglib-2.0.so.0.600.0
/usr/local/lib/libglib-2.0.so.0
/usr/local/lib/libglib-2.0.so
/usr/local/lib/libglib-2.0.la


Got any tips?
 
Old 05-06-2005, 07:11 AM   #2
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hi,

try:
Code:
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/root
and retry the configure step
 
Old 06-09-2005, 12:24 AM   #3
aniljacob
LQ Newbie
 
Registered: May 2005
Location: india
Distribution: debian
Posts: 10

Rep: Reputation: 0
hi..i

you can modify the library directory by setting the
LD_LIBRARY_PATH =/user/local/lib
export LD_LIBRARY_PATH
for instance if u have installed it in /usr/local/lib ..Do it and try once again

Last edited by aniljacob; 06-09-2005 at 12:27 AM.
 
Old 07-09-2007, 03:50 AM   #4
Abhilasha
LQ Newbie
 
Registered: Apr 2007
Posts: 4

Rep: Reputation: 0
Unable to install Linux

Quote:
Originally Posted by aniljacob
hi..i

you can modify the library directory by setting the
LD_LIBRARY_PATH =/user/local/lib
export LD_LIBRARY_PATH
for instance if u have installed it in /usr/local/lib ..Do it and try once again

Hi..
I am unable to install Linux on redhat enterprise linux... Got following errors:

rpm -i ethereal-0.8.6-1.i386.rpm
warning: ethereal-0.8.6-1.i386.rpm: V3 RSA/MD5 signature: NOKEY, key ID 697ecedd
error: Failed dependencies:
ucd-snmp is needed by ethereal-0.8.6-1
libsnmp.so.0 is needed by ethereal-0.8.6-1

Please help me to get it work ..Thanks..

Last edited by Abhilasha; 07-09-2007 at 03:53 AM.
 
Old 07-09-2007, 09:45 AM   #5
aniljacob
LQ Newbie
 
Registered: May 2005
Location: india
Distribution: debian
Posts: 10

Rep: Reputation: 0
ethereal installation problem

Hi abhilasha,
The problem from your log seems like mismatch of versions of the
supporting libraries or non availability of particular libraries. You can manually check out the availability of these libraries ucd-snmp and libsnmp.so.0 in your system, you can use either 'slocate' or 'locate' command for finding the corresponding libraries and to ensure that they are present. If found check out whether their version is updated to suit to the ethereal-0.8.6-1.i386.rpm version. Check for the version dependencies and get the corresponding rpms for ucd-snmp and libsnmp.so.0 install it and continue the installation of ethereal-0.8.6-1.i386.rpm. I guess this will do the trick...

Regards,
Anil Jacob

UNIX is simple; it just takes a genius to understand its simplicity!!!
 
Old 07-09-2007, 11:09 AM   #6
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
@ Abhilasha: Please start your own new thread instead of reviving someone's else's two year old thread. I recommend the Linux - Software forum, as it's the one that most pertains to your question, which is NOT a security issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
pkg-config and glib: Uninstalling Old and Installing New CooManChu Linux - Software 6 09-06-2005 03:35 PM
pkg-config error hotstyle765 Linux - Software 6 01-31-2005 03:46 PM
Installing Glib, ATK, GTK, Pkg Config, and Pango! LinuZ Linux - Newbie 9 10-26-2003 02:58 PM
pkg-config error. eye Linux - Software 2 08-29-2003 10:01 AM


All times are GMT -5. The time now is 06:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration