LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 05-14-2002, 03:13 AM   #1
robeb
Member
 
Registered: May 2002
Posts: 113

Rep: Reputation: 15
Turn Off KDM


I'm running Red Hat 7.2 and KDM was turned on by default. I don't know how to turn it off. Can anyone tell me how?

- Thanks
 
Old 05-14-2002, 02:50 PM   #2
tyler_durden
Member
 
Registered: May 2001
Posts: 125

Rep: Reputation: 15
its part of the xwindows login. to disable it you need to change your run-level. run level 5 is X, 3 is no-X. The default is listed in /etc/inittab.

you can just firewall it if you plan on using X.
 
Old 05-14-2002, 04:46 PM   #3
robeb
Member
 
Registered: May 2002
Posts: 113

Original Poster
Rep: Reputation: 15
In my /etc/inittab file I have "id:3:initdefault:" Is this the line to change? Although, it looks like it is already set to run-level 3.
 
Old 05-15-2002, 07:12 AM   #4
Thymox
Senior Member
 
Registered: Apr 2001
Location: Cornwall, England.
Distribution: Debian + Ubuntu
Posts: 4,345

Rep: Reputation: 57
OK, so what exactly happens when you boot?

If your default runlevel is set to 3, then you will boot to a text-login, unless something really screwy had happened to your init scripts.
 
Old 05-15-2002, 12:45 PM   #5
robeb
Member
 
Registered: May 2002
Posts: 113

Original Poster
Rep: Reputation: 15
I boot to text login. I didn't install any GUI interface on my box. That's the weird thing.
 
Old 05-15-2002, 01:46 PM   #6
sewer_monkey
Member
 
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 624

Rep: Reputation: 31
Quote:
Originally posted by robeb
I boot to text login. I didn't install any GUI interface on my box. That's the weird thing.
Cool! I love weird stuff. Would you mind posting the output of "ls /etc/rc3.d/" (do not forget the trailing slash, or you'll get a nice symlink)?
 
Old 05-15-2002, 01:59 PM   #7
robeb
Member
 
Registered: May 2002
Posts: 113

Original Poster
Rep: Reputation: 15
Here you go...

K03rhnsd K34yppasswdd K74ypxfrd S12syslog S26apmd S80qmail S99local K20nfs K45arpwatch S05kudzu S13portmap S28autofs S85gpm
K20rstatd K46radvd S08ipchains S14nfslock S55sshd S90crond K20rusersd K50snmpd S08iptables S17keytable S56rawdevices S90xfs K20rwalld K65identd S09isdn S20random S56xinetd S95anacron
K20rwhod K74ypserv S10network S25netfs S60lpd S95atd
 
Old 05-15-2002, 10:09 PM   #8
sewer_monkey
Member
 
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 624

Rep: Reputation: 31
LOL, this is weird... So let me get this straight, during install you turned off X-Windows, right?

Another thing you may want to look at is this line in /etc/inittab (should be in the end):

x:5:respawn:/etc/X11/prefdm -nodaemon

If you have anything else instead of the 5 in the second column, then X will start in these runlevels. For example:

x:0123456:respawn:/etc/X11/prefdm -nodaemon

will run X-Windows in every runlevel.

Finally make sure you have your "initdefault" line set to:

id:3:initdefault:

And not to:

id:5:initdefault:

Another file to check is /etc/rc.local, X may be forced to start there...

Here's something you can do to check if the problem is in /etc/inittab... Try killing X with Ctrl+Alt+Backspace, and if it pops up again, then it's definitely /etc/inittab.

Good luck!
 
Old 05-16-2002, 12:20 AM   #9
robeb
Member
 
Registered: May 2002
Posts: 113

Original Poster
Rep: Reputation: 15
Here what I got in my in /etc/inittab...

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:3:initdefault:

-----------------------------------------------------------

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
# xdm is now a separate service
x:5:respawn:/etc/X11/prefdm -nodaemon

SV:123456:respawn:/command/svscanboot

Didn't see anything in rc.local. Maybe I should just reinstall. Anyways, thanks for your help!

Last edited by robeb; 05-16-2002 at 12:25 AM.
 
Old 05-17-2002, 12:47 PM   #10
TruckStuff
Member
 
Registered: Apr 2002
Posts: 498

Rep: Reputation: 30
I had the same problem. I think its actually the mouse driver that appears even in text mode. Its one of the startup scripts, but I can't remember exactly which one I killed to get rid of it. Its one of the following:
portmap
nfslock
netfs
ntpd
alsa
sound
partmon
gpm <-- I *THINK* it was this one

Good luck.
 
Old 05-17-2002, 12:59 PM   #11
sewer_monkey
Member
 
Registered: May 2002
Location: Toronto, ON, Canada
Distribution: Ubuntu, Debian, RedHat/CentOS
Posts: 624

Rep: Reputation: 31
That's weird... gpm has nothing to do with X... X has its own mouse driver. gpm is for console (text mode) mouse operations.

One more thing... I have RH7.2 and I don't have the "SV:123456:respawn:/command/svscanboot" line... I am not sure what SV stands for, but in any case, you may want to check out the file /command/svscanboot. I have a RH7.2 installation (several boxes, actually) and I don't even have the /command directory/partition.
 
Old 05-17-2002, 01:49 PM   #12
robeb
Member
 
Registered: May 2002
Posts: 113

Original Poster
Rep: Reputation: 15
I've managed to shutdown KDM but it was more blind luck then anything else. Stopping nsflock did the trick. I'm not sure what nfslock does or did. Maybe someone can shed some light on that. However, NFS is Network Filesystem, which uses sunrpc (port 111), which coincidently was also tunred on by default. I'm gonna go out on a limb here and say KDM was turned to allow other computers w/ GUI's file share via sunrpc. BTW, the "sun" in sunrpc" comes from Sun Micosystem, who developed NFS. Just some useless information for ya.

As for the svscanboot script, I did find a path to /usr/X11R6, which I believe runs X windows, which brings us back to KDM. Do I sound like I know what I'm talking about. I hope so. Anyways, a big thank you to everyone for sticking through long thread. The mystery that is KDM has been solved...for now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 10:39 AM
Adding kdm to init.d so LFS boots to kdm StevePhM Linux From Scratch 4 08-08-2005 10:49 PM
making numlock turn on at kdm startup nafan Mandriva 2 08-23-2004 01:12 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 09:05 AM
Need help configuring KDM on MDK10C so that it is like KDM on 9.2 bhtooefr Mandriva 0 05-06-2004 02:19 PM


All times are GMT -5. The time now is 02:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration