LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 07-14-2003, 10:18 AM   #1
renjithgopal
LQ Newbie
 
Registered: Jul 2003
Location: Bangalore, INdia
Distribution: Redhat Linux
Posts: 9

Rep: Reputation: 0
Question tftp - "Destination Unreachable" due to "Port Unreachable"


I am trying to connect my Redhat Linux 8.0 PC to a BDI2000 (Hardware Debugger) there i have to do some init work and then then BDI2000 will read a config file using tftp. i am able to do the init work and connect do BDI2000 using telnet but when the file request comes from bdi2000 using tftp protocol , its telling that file is not found
but when i captured the packet data using ethereal and analysed i found that the connection to port 69 cannot be established and due to that its timing out the operation
i tried to disable the firewall using lokkit, but its not saving the setting (again when i am going there security level is high)

what should i do for that my BDI2000 will connect to the tftp port 69
 
Old 07-14-2003, 02:00 PM   #2
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
RH8 has a "bug" that no matter what level you set the lokkit firewall at, the firewall GUI will always say "high". If you change the level, it will indeed change the firewall settings, but the GUI will still say high. That being said, just turn iptables off using the command line:

su -
<enter root password>
service iptables stop

you might also need to put the ip address of the client in /etc/hosts.allow . Put an entry in like:
FTPD: 111.222.333.444 <- where this is the BDI2000

If iptables is indeed the problem, you'll need to write a rule to punch the BDI2000 through the firewall and then restart your firewall otherwise you'll be wide open.
HTH
 
Old 07-15-2003, 12:05 PM   #3
renjithgopal
LQ Newbie
 
Registered: Jul 2003
Location: Bangalore, INdia
Distribution: Redhat Linux
Posts: 9

Original Poster
Rep: Reputation: 0
Red face didnt work-- need more help

it didnt work
can you help me in punching through the firewall
i got some documents regarding frewall and
it confusing where to start with
 
Old 07-17-2003, 09:52 PM   #4
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
If it still doesn't work after turning off iptables, then the problem is not with the firewall. It is likely that the TFTP daemon isn't on or isn't configured properly. Try the following commands on the TFTP server:

netstat -lan

If the TFTP daemon is on (and listening properly) you should see an entry for port 69. If you don't see an entry then the TFTP daemon isn't listening, so try and restart it. Also verify iptables is off using:

service iptables status

It should respond: iptables [OFF]
 
Old 07-23-2003, 12:55 PM   #5
renjithgopal
LQ Newbie
 
Registered: Jul 2003
Location: Bangalore, INdia
Distribution: Redhat Linux
Posts: 9

Original Poster
Rep: Reputation: 0
Thumbs up IT WORKED!!!!

when i installed the previous time i had not installed tftp server by default
then i tried installing it by double clicking the rpm package..
may be something would have gone wrong

And since this was my only major work in this PC i reinstalled linux with no firewall option and i selected the tftp server while installing linux.. and after bringing up the linux i disabled iptables using ntsysv and rebooted the system

Then IT WORKED FINE

Thanks a lot Captain Caveman
 
Old 07-24-2003, 10:36 AM   #6
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
Glad you got it to work!

Just don't forget to re-activate the iptables firewall, or your box will be an easy target for hackers. If you feel comfortable with iptables, you can write a firewall script yourself. If you like the GUI better, use the lokkit firewall program to build your iptables rules for you. Just make sure to make a custom rule that allows incoming tFTP traffic (port 69).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SiS900 Ethernet Problem "Network is unreachable" mertos Linux - Networking 7 04-04-2005 09:01 AM
Getting message "connect: Network is unreachable" trying to access the Internet denver1980 Linux - Networking 5 12-29-2004 05:22 PM
MA-311 on eth0 inaccessible via Linux, "Network Unreachable" error, no localhost ping LGMike Linux - Networking 14 09-21-2003 11:11 PM
Again with the "Destination Host Unreachable", more precise radupastia Linux - Networking 3 08-14-2003 06:36 AM
"Destination Host Unreachable" on local network radupastia Linux - Networking 0 08-13-2003 09:46 AM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration