LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 09-10-2005, 01:22 PM   #1
brainlesspinkey
Member
 
Registered: Jul 2004
Distribution: Debian Unstable
Posts: 66

Rep: Reputation: 15
sudo not setting defaults


I am having a wierd probem with sudo:
I am trying to make the passwd time out for sudo. The default is set to infinate. I try to reset this with:
Defaults passwd_timeout=1
but, there is no difference.

What is going on? Is this a bug? I'm using debian unstable.

thanks,
-p
 
Old 09-10-2005, 01:58 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
According to the sudoers man page, the default is 5 minutes. Your syntax appears correct to me. What occurs when you attempt to use sudo with this?
 
Old 09-10-2005, 02:59 PM   #3
brainlesspinkey
Member
 
Registered: Jul 2004
Distribution: Debian Unstable
Posts: 66

Original Poster
Rep: Reputation: 15
My man file says the default for passwd_timout is: "the default is 0, set this to 0 for no password timeout"

When I use sudo without trying to set the passwd_timeout, it doesn't timeout, like the man page says. When I try to set the timeout to 1 min, with the code in my first post, the behavior doesn't seem to change
eg:
I use sudo, and it prompts for the password. Then I wait 10 minutes. I use sudo again, and it won't prompt for any password. Happens on both settings.

Here is the rest of my sudoers file, if that helps:

Code:
Defaults   passwd_timeout=1
root ALL=ALL
pinkey   ALL = (root)ALL
Thanks for the help so far.
 
Old 09-11-2005, 01:56 AM   #4
brainlesspinkey
Member
 
Registered: Jul 2004
Distribution: Debian Unstable
Posts: 66

Original Poster
Rep: Reputation: 15
I figured it out... The proper setting I should use to get the behaviour I wanted is "timestamp_timeout"
urg, I'm such a noob.
 
Old 09-11-2005, 12:34 PM   #5
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Interesting. I don't think you're such a noob as I missed it in the man page myself when looking at passwd_timeout.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Restricting Editing in Sudo (Advanced Sudo Question) LinuxGeek Linux - Software 4 11-04-2006 04:20 PM
Setting printer defaults in OpenOffice.org mikieboy Linux - Software 0 10-03-2004 06:04 PM
Setting default browser (and other defaults?) ToothlessRebel Linux - Newbie 2 07-22-2004 07:20 PM
Question re: Setting Gabber defaults Seventh Linux - Software 0 01-06-2004 08:28 AM
setting up alsa defaults LinFreak! Linux - General 10 10-01-2003 01:13 PM


All times are GMT -5. The time now is 12:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration