LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Security (http://www.linuxquestions.org/questions/linux-security-4/)
-   -   SSH authentication (http://www.linuxquestions.org/questions/linux-security-4/ssh-authentication-272337/)

blmack44 12-31-2004 11:05 AM

SSH authentication
 
Having trouble getting public key authentication going between a couple of RH linux servers. Nothing complains but I get prompted for a pw always.

Following is the -v from an scp attempt:

rsa key is copied to ~./.ssh/authentication_keys on the target system but we don't seem to authenticate. No passphrase used. Attempt with dsa key is similar result.

OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090701f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Rhosts Authentication disabled, originating port will not be trusted.
debug1: Connecting to 192.168.0.100 [192.168.0.100] port 22.
debug1: Connection established.
debug1: identity file /home/testuser/.ssh/identity type -1
debug1: identity file /home/testuser/.ssh/id_rsa type 1
debug1: identity file /home/testuser/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.6.1p2
debug1: match: OpenSSH_3.6.1p2 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_3.6.1p2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '192.168.0.100' is known and matches the RSA host key.
debug1: Found key in /home/testuser/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /home/testuser/.ssh/identity
debug1: Offering public key: /home/testuser/.ssh/id_rsa
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Trying private key: /home/testuser/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: password

testuser@192.168.0.100's password:

Any thoughts appreciated!

blmack44 12-31-2004 02:13 PM

Finally located the sshd log and indicated the following message:

Authentication refused: bad ownership or modes for directory /home/testuser

Changing permissions to 755 on the /home/testuser directory solved the problem.

Thanks,


All times are GMT -5. The time now is 10:00 PM.