LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 03-11-2002, 10:28 AM   #1
thecrab
LQ Newbie
 
Registered: Feb 2002
Location: Quebec, Canada
Distribution: RedHat and Mandrake
Posts: 9

Rep: Reputation: 0
Unhappy Snort - Demarc - MySQL - ERROR


Hello....
I run a RedHad 7.2. I try to configure snort on it. With the demarc.org tool. But when I try to start it. This is what I got....???
Any idea??? It's look like my problem is in the database??
Please HELP!!!!! My sensor need to work before the end of the week. =o(
I'm totally confused. I'm a newbie with Snort and MySQL.
Thank you!

__________________________________________________

[root@localhost bin]# ./demarcd -I
THIS WILL ATTEMPT TO INSTALL A NEW SNORT SENSOR

Continue ? [Yn] Y
Database Username snort should use [snort]: root
Database Password snort should use: myDBpassword
Database Host snort should connect to (please use IP address, even 127.0.0.1 for localhost) [127.0.0.1]: 127.0.0.1
Database name snort should use [snort]: snort
Name of this sensor (should contain no spaces): snort


About to start snort so that it registers with the database, press Ctrl-C to exit...

Issuing: /usr/local/bin/snort -q -c /usr/local/demarc/conf/snort.conf
database: mysql_error: Table 'snort.sensor' doesn't exist
database: mysql_error: Table 'snort.sensor' doesn't exist
SQL=INSERT INTO sensor (hostname, interface, detail, encoding) VALUES ('snort','eth0','1','0')
database: mysql_error: Table 'snort.sensor' doesn't exist
database: Problem obtaining SENSOR ID (sid) from mysql->snort->sensor

When this plugin starts, a SELECT query is run to find the sensor id for the
currently running sensor. If the sensor id is not found, the plugin will run
an INSERT query to insert the proper data and generate a new sensor id. Then a
SELECT query is run to get the newly allocated sensor id. If that fails then
this error message is generated.

Some possible causes for this error are:
* the user does not have proper INSERT or SELECT privileges
* the sensor table does not exist

If you are _absolutly_ certain that you have the proper privileges set and
that your database structure is built properly please let me know if you
continue to get this error. You can contact me at (jed@pickel.net).

Fatal Error, Quitting..
snort: no process killed


Checking to see if it registered correctly...
/usr/bin/perl: error while loading shared libraries: /usr/lib/perl5/site_perl/5.6.0/i386-linux/auto/DBD/mysql/mysql.so: undefined symbol: mysql_init

______________________________________________

You Need more details???
 
Old 03-11-2002, 02:33 PM   #2
thecrab
LQ Newbie
 
Registered: Feb 2002
Location: Quebec, Canada
Distribution: RedHat and Mandrake
Posts: 9

Original Poster
Rep: Reputation: 0
Talking I found the solution....

Thank you everyone!
With a good MySQL book and a lot of patience I found the solution.
The problem was in my DB.
So now my demarc sensor almost work... Only have to install SSL.


 
Old 03-12-2002, 11:47 AM   #3
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,261
Blog Entries: 54

Rep: Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841Reputation: 2841
As reference to other users:
/* What IMO he ment to say was re-installing the perl (cpan) DB module (*DB/mysql/mysql.so) fixed the shared lib thing. This is a question for the installation forum, not security. */
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. Dannux Linux - Software 3 03-24-2006 08:44 AM
snort and mysql lord-fu *BSD 1 11-20-2005 09:11 PM
Error when starting up snort: bash:!/bin/sh/usr/local/bin/snort :Eent not found cynthia_thomas Linux - Software 1 11-11-2005 02:59 PM
snort failed: snort: symbol lookup error: undefined symbol: usmAES192PrivProtocol Emmanuel_uk Linux - Security 1 07-10-2005 10:29 AM
snort and mysql ilnli Linux - General 1 03-28-2005 02:20 PM


All times are GMT -5. The time now is 04:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration