LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 03-15-2005, 03:58 AM   #1
jimwillsher
LQ Newbie
 
Registered: Jan 2004
Location: Dunblane, Central Scotland
Distribution: Redhat 9
Posts: 27

Rep: Reputation: 15
Sendmail won't work with SELinux enabled?


Hi all,

CentOs 4.0 i386, clean install, running as a server (no GUI).

I can't seem to get sendmail to send out stuff from anything "local" such as PHP or Squirrelmail, when SELinux is enabled. When I send from squrrelmail I get the following in /var/log/messages:

Mar 15 09:49:41 orca kernel: audit(1110880181.204:0): avc: denied { read } for pid=19321 exe=/usr/sbin/sendmail.sendmail name=urandom dev=tmpfs ino=435 scontext=user_u:system_r:system_mail_t tcontext=system_ubject_r:urandom_device_t tclass=chr_file

Mar 15 09:49:41 orca kernel: audit(1110880181.204:0): avc: denied { read } for pid=19321 exe=/usr/sbin/sendmail.sendmail name=random dev=tmpfs ino=433 scontext=user_u:system_r:system_mail_t tcontext=system_ubject_r:random_device_t tclass=chr_file


If I disable SEL via:

echo "0" >/selinux/enforce

the messages are sent without issue.

I've used chcon to enable SEL on /var/www/html for wesbites, and that all works fine, but I don't know what to run fro sendmail.

I've had to switch off SEL until I can get this resolved. Does anyone have any suggestions?


Many thanks,


Jim
 
Old 03-15-2005, 08:16 AM   #2
jimwillsher
LQ Newbie
 
Registered: Jan 2004
Location: Dunblane, Central Scotland
Distribution: Redhat 9
Posts: 27

Original Poster
Rep: Reputation: 15
I've done some further digging. I have TLS enabled for sendmail - could it be that sendmail cannot access the random number generator for TLS functionality? If so, any ideas what I would "chcon" to get that to work?

Many thanks,


Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some games don't work with audio enabled Googly Linux - General 1 01-02-2005 10:11 PM
APM wont work with ACPI enabled slackwarefan Slackware 2 04-10-2004 10:47 PM
wireless card (wpc11) won't work when WEP is enabled once here Linux - Wireless Networking 7 11-29-2003 10:04 PM
Sendmail Does Not Work! edhan Linux - General 3 10-15-2003 10:08 PM
I really need help getting sendmail to work right. Please help! WorldBuilder Linux - Networking 28 05-15-2003 08:00 PM


All times are GMT -5. The time now is 07:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration