LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 01-15-2004, 09:38 AM   #1
rajamp
LQ Newbie
 
Registered: Nov 2003
Posts: 12

Rep: Reputation: 0
rsh:permission denied linux Advanced server 2.1


Hi,

I am not able to rsh to linux AS2.1 from remote hosts.
I edit the /.rhosts with + +(all users,all hosts) entries.
Firewall also disable still no luck.

Could any one help me for work around?

Thanks!
 
Old 01-15-2004, 03:14 PM   #2
tarballedtux
Member
 
Registered: Aug 2001
Location: Off the coast of Madadascar
Posts: 498

Rep: Reputation: 30
OK, unless it is crucial to use rsh(Why?), investigate OpenSSH. Its secure and not hard you setup and use. http://www.openssh.org"

--tarballedtux
 
Old 01-16-2004, 01:13 AM   #3
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Well most likely you're not executing rsh with root privilages. I believe rsh uses port 1023 and that's a "low port" which requires root to open. Maybe I'm getting confused with rlogin...

Any way, don't use rsh, it's highly insecure. As tarballedtux mentions, you should be using OpenSSH.
 
Old 02-10-2004, 06:50 AM   #4
uerden
LQ Newbie
 
Registered: Jan 2004
Posts: 12

Rep: Reputation: 0
maybe you should modify your "hosts" and "hosts.allow" files.
 
Old 02-11-2004, 12:33 PM   #5
Blinker_Fluid
Member
 
Registered: Jul 2003
Location: Clinging to my guns and religion.
Posts: 682

Rep: Reputation: 63
Re: rsh:permission denied linux Advanced server 2.1

Quote:
Originally posted by rajamp
Hi,

I am not able to rsh to linux AS2.1 from remote hosts.
I edit the /.rhosts with + +(all users,all hosts) entries.
Firewall also disable still no luck.

Could any one help me for work around?

Thanks!
First off it's probably easier to use SSH (and more secure). now that's out of the way...

Have you installed rsh-server how about xinetd?
Is rlogin, rsh, rexec on?
(unless AS2.1 changed it from old redhat)
chkconfig --list
look for rsh, rlogin and rexec make sure they are on
Other stuff:
/etc/hosts.equiv (put in the trusted hosts)
I think if you are root you also have to add rsh, rlogin, rexec to the bottom of /etc/securetty if you want to rsh in as root. (not required for normal users)

There you have it just remember that rsh is not secure and don't if you get hacked...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Permission Denied" with rsh hansnueski Linux - Networking 2 07-07-2005 07:34 PM
rsh permission denied eozcan Linux - Security 2 12-07-2004 09:26 AM
"permission denied" when doing rsh/rcp ayeletr Linux - General 1 01-22-2004 09:45 AM
Permission Denied on a RSH Connection Eluminator Linux - Software 4 11-08-2002 03:06 AM
rsh. Permission denied pedroem Linux - Networking 2 10-09-2002 02:17 AM


All times are GMT -5. The time now is 06:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration