LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 06-03-2010, 12:59 AM   #1
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Lubuntu, Slackware
Posts: 575

Rep: Reputation: 64
Public Wifi concerns


I am planning a trip for a few days and I will be staying at an inn with Wifi access. All the guests are allowed to use it. A friend of mine has been there, he told me there are several other private spots around the house, i.e. lots of other people using Wifi. My friend told me the inn uses WEP, so who knows how many times their access point has been hacked and accessed without permission...

My concern is that I will be there for a few days with my notebook, I will have to work once in a while, connected to the Internet. Is there some precaution I should take to protect my notebook from intruders? Is it advisable to install a firewall in my notebook (iptables?) or am I just overreacting? Is it possible for one of the guests or neighbors to break into my notebook?
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 06-03-2010, 01:18 AM   #2
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,155

Rep: Reputation: 134Reputation: 134
It's highly unlikely.
Enabled Filesharing offen allow others to access your files on networks.
I beleave most wifi attackers would use wifi for free net, anonimity and in worst case spying on other people activitys.
 
2 members found this post helpful.
Old 06-03-2010, 01:23 AM   #3
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643Reputation: 643
Personally, I always have iptables on, no matter what network I'm connected to, no matter how unlikely the chances of being targeted. Worms and malware don't care where you are or whether you're only connecting for 10 minutes - if its not on, its not on

Also.. try not to do any internet banking if you're on a public connection, it's pretty easy to provide fake dns responses ...

Last edited by kbp; 06-03-2010 at 01:25 AM.
 
2 members found this post helpful.
Old 06-03-2010, 02:00 AM   #4
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 281

Rep: Reputation: 54
Or just leave an ssh server running on your home computer and use ssh tunneling to browse over an encrypted connection ie:

Quote:
ssh -D 8080 user@myserver.com
-> set up the browser to use sock proxy server on port 8080 at local host (127.0.0.1)

For extra security with Firefox tunnel dns requests over the secure tunnel. Open the about:config page. Change network.proxy.socks_remote_dns to true.

Other ssh options:

-f move the ssh to background
-N do not execute remote command
-q be quiet
-T do not allocate a pseudo tty
-n redirect standard input to /dev/null
-C enable compression


Regards,
Stefan

Last edited by propofol; 06-03-2010 at 02:08 AM.
 
2 members found this post helpful.
Old 06-03-2010, 02:30 AM   #5
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
I too would highly recommend not only that you use a firewall, but also that you set up a secure tunnel to a less-risky location, such as your home perhaps (you need to worry about your traffic as well, not just your computer).

Last edited by win32sux; 06-03-2010 at 02:33 AM.
 
2 members found this post helpful.
Old 06-03-2010, 06:04 PM   #6
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Lubuntu, Slackware
Posts: 575

Original Poster
Rep: Reputation: 64
Quote:
Originally Posted by propofol View Post
Or just leave an ssh server running on your home computer and use ssh tunneling to browse over an encrypted connection ie:

-> set up the browser to use sock proxy server on port 8080 at local host (127.0.0.1)

For extra security with Firefox tunnel dns requests over the secure tunnel. Open the about:config page. Change network.proxy.socks_remote_dns to true.
That didn't work for me. Firefox can no longer load any pages at all with that configuration. I used 127.0.1 and the same port as the -D parameter for SSH. I used the remote server that hosts my website and has SSHD running all the time. What did I do wrong?

Also, is it possible to make Kmail send and receive mail through an SSH tunnel? I couldn't find anything that seemed remotely relevant in the many Kmail configuration options, but maybe there is some clever trick I don't know...
 
Old 06-03-2010, 06:45 PM   #7
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
See the attached screen shot for an example of a working setup. You may need to change 127.0.0.1 to localhost in the socks proxy section.

I also assume you issued the SSH connection first. Try ssh -CND 8080 user@domain. You shouldn't see any response from the SSH server in your terminal.
Attached Images
File Type: jpg Screenshot.jpg (169.6 KB, 12 views)
 
2 members found this post helpful.
Old 06-03-2010, 09:01 PM   #8
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Lubuntu, Slackware
Posts: 575

Original Poster
Rep: Reputation: 64
Thumbs up It works!

Your screenshot really helped. I had filled in HTTP Proxy instead of SOCKS Host. Doh!

Force of habit, for I used HTTP Proxy for Privoxy for several years. I just went ahead and typed stuff into the first empty field I came across.

Now if only I could check and answer my mail through that tunnel, that would be copacetic.

Last edited by lucmove; 06-03-2010 at 09:02 PM.
 
Old 06-03-2010, 09:53 PM   #9
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Lubuntu, Slackware
Posts: 575

Original Poster
Rep: Reputation: 64
OK, tunneling is easier than I thought. All my public Wifi woes are gone. Many thanks, everyone!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IP expiration for public WiFi tataco20 Linux - Networking 3 08-04-2009 05:35 AM
can't access public wifi BUT wifi works on my router at home rob.rice Linux - Networking 4 05-15-2009 01:59 AM
LXer: Common Public Licence superseded by Eclipse Public Licence LXer Syndicated Linux News 0 04-18-2009 03:10 AM
LXer: A Public Market for Public Music LXer Syndicated Linux News 0 03-30-2007 07:16 AM
LXer: Public Venture, Public Content LXer Syndicated Linux News 0 06-22-2006 08:54 PM


All times are GMT -5. The time now is 03:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration