LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 03-04-2005, 11:30 AM   #1
bkankur
LQ Newbie
 
Registered: Feb 2005
Posts: 22

Rep: Reputation: 15
Problems after IPsec tunnel establishment


Hello friends,

I am currently doing my development on VPN. And i am using openswan as a tool for the same. In implemention of secure tunnel i am using certification method and also uses PSK i.e., PreShared Key method for tunnel establishment.

Now when ever i create a tunnel, it establish successfully , And the tunnel connection can be checked or verify using ping or ssh on one side and on the remote machine simaltaneouly using tcp dump or ethereal which captures the encrypted packets.

I am using kernel 2.6-10 and fedora core 3 . The problem with me is that any time i capture the packets on the remote host i received two packets
--> One is encrypted message as it has to be but i also receive another packet from the same host with the same protocol which is a usual packet.
-
For example, consider tunnel which is already established between machine A and machine B .

when i ping from machine A to machine B. I also capture packets on machine B using ethereal .
I received out put at B as:-

machine A mac. B esp(.....)
mach A mac. B ping echo request
machine A mac. B esp(.....)
mach A mac. B ping echo request
machine A mac. B esp(.....)
mach A mac. B ping echo request
and so on.............


So WHY SUCH THING HAPPENS ? AS PER THE TUNNEL ESTABLISHED , ONLY ENCRYPTED MESSAGE SHOULD BE SENDED .

I WANT URGENT REPLY............

THANX FOR ANSWER IN ADVANCE...

GOOD DAY AND HAVE A NICE TIME
BYE....
ANKUR.
 
Old 03-24-2005, 06:42 AM   #2
jbneu
LQ Newbie
 
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
Hi, maybe I have a solution for you.
Are you sure that both packet are send ? If you configure you ethereal to listen to the interface "any" it is normal that you see both packet.
The only solution to be sure is to used a passive third computer which you will put in middle and listen to passing packets. If you still seeing the packets I'm sorry I can not help you because I do not use the same solution.

I hope it is the solution for your problem.

Good luck for your future development.


JB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPsec fails to open tunnel KaMakani Linux - Networking 0 10-13-2005 12:54 AM
IPSec tunnel over multiple interfaces tylerl Linux - Networking 0 07-21-2005 06:07 PM
Configuring IPSEC Tunnel on FC3 kernel 2.6 asndp Linux - Security 0 01-08-2005 07:17 AM
IPSEC Tunnel behind NAT pssst_yeah_you Linux - Networking 0 06-23-2004 05:54 PM
2.6 IPSEC Tunnel mode gateway mhiggins Linux - Networking 1 02-28-2004 02:50 PM


All times are GMT -5. The time now is 05:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration