LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 05-20-2008, 03:20 AM   #1
i_nomad
Member
 
Registered: Mar 2008
Distribution: RedHatES4
Posts: 144

Rep: Reputation: 15
Question Postfix TLS and SMTP


Hi Guys

I hope you dont mind me jumping on this thread.

I am having some issues with TLS and SMTP. Basically if in Postfix "mynetworks" I set some networks I have no problems with the server starting "STARTTLS" and exchanging certificates etc, however when I have clients that route through a "protected" POP environment I cannot get the server to STARTTLS from the client. Now my inkling has been that some ports in the POP must be causing some issue, however from traces at the client and general reading TLS seems to ride on port 25.

"blacky_5251" I note you mention that 'Outlook needs to use port 465 for sending emails..' are you sure TLS uses port 465??

I will be getting traces from the POP but any solid info on this would help me.

Regards

Last edited by i_nomad; 05-20-2008 at 03:27 AM.
 
Old 05-20-2008, 05:58 AM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Your question is totally separate from what was being asked in the thread you posted, so I've moved it into a new thread of its own.
 
Old 05-20-2008, 07:28 AM   #3
blacky_5251
Member
 
Registered: Oct 2004
Location: Adelaide Hills, South Australia
Distribution: RHEL 4&5, Fedora 10, CentOS 5.4, IPCop
Posts: 569

Rep: Reputation: 55
The change I made to master.cf is to tell Postfix to listen on port 465 as well as 25. I was successfully using port 25 and TLS with Thunderbird, but I needed to open port 465 for Outlook with different authentication rules - specifically removing noplaintext from the smtpd_sasl_security_options - because Outlook will only work with SSL - not TLS. SSL likes to use plaintext, which isn't a problem really because the link is encrypted anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
opensuse 10.3 and sending smtp via SSL/TLS newbuyer17 Linux - Server 1 02-27-2008 02:26 AM
Postfix to relay through my ISPs SMTP with no tls problem icebrian Linux - Software 10 01-18-2007 06:45 PM
Postfix SMTP AUTH (and TLS) HOWTO tommytomato Linux - General 2 05-24-2006 10:00 AM
Postfix With SMTP-AUTH And TLS carlainz Linux - Software 0 05-21-2006 03:13 AM
Debian Exim4 SMTP Auth TLS? shaun_bakker Linux - Software 1 06-30-2005 11:04 AM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration