LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 01-06-2004, 06:47 AM   #1
kinchj
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Rep: Reputation: 0
Question Port 8080 access


Okay Okay I have seen a lot of message about iptables and I'm sorry if this is a bit of a re-post but here goes .....

I'm running Redhat 9 and have the network security set on high (via the gui) but customised to allow ssh and http. The only problem is that this must allow access on http over port 80, I would also like to allow access over port 8080. I have switched off the security via the gui and can acess my web page over port 8080 so I know that this is where the problem lies.

Does anyone know how I make a perminate change to allow http port 8080?

Thanks in advance,

Jamie
 
Old 01-06-2004, 07:18 AM   #2
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
enable/allow https (via gui) or do the classic
Code:
iptables -A INPUT -i eth0 -p tcp --dport 8080 -j ACCEPT
 
Old 01-06-2004, 07:26 AM   #3
kinchj
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks Ciccio

I have given that command a go but it has not resolved the problem, any other ideas?

Thanks again,
Jamie
 
Old 01-06-2004, 09:03 AM   #4
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
port 8080 is used by https, so if you enable the service via GUI (I-m not at my computer right now, but once I get home I'll give the gui a try and let you know) you should be able to access it. Also, make sure you are giving the right parameters to iptables, for example, the interface -i should be eth0 or eth1, depending on your confioguration.
 
Old 01-06-2004, 09:03 AM   #5
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
Oh, also you should make sure you are using tcp and not udp, if so you should use -t udp instead of -t tcp
 
Old 01-06-2004, 09:22 AM   #6
kinchj
LQ Newbie
 
Registered: Jan 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks again.

'-t' did you mean '-p' ?

I gave this command a go just in case but it did not make a difference:

iptables -A INPUT -i eth0 -p udp --dport 8080 -j ACCEPT

I also checked my ifconfig to confirm that I am using eth0 which I am.
 
Old 01-06-2004, 10:38 AM   #7
Ciccio
Member
 
Registered: Nov 2002
Location: Paraguay
Distribution: Mandrake 10
Posts: 573

Rep: Reputation: 30
yes, -p. sorry.

Oh, well... it was worth the shot. I'll get back to you on this a bit later today.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Port 80-->8080?? flamesrock Linux - Software 4 08-01-2004 01:40 AM
problem in IM with the 8080 port dred Linux - Networking 0 06-06-2004 03:21 AM
What command changes port 8080 to 80? TSynergy Linux - Newbie 4 09-17-2003 05:18 AM
firewall.rc.config says :"open port 8080" but nmap says port is closed saavik Linux - Security 2 02-14-2002 12:16 PM
HTTP on port 8080 cauchy Linux - Networking 3 08-09-2001 07:29 PM


All times are GMT -5. The time now is 07:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration