LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 07-23-2003, 06:02 PM   #1
bfdlinux
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
OpenSSL Apache 2 RedHat 8


Hello!

I am running RH 8.0 with Apache 2.0.xxx. The default config files were working just fine when I did the following: I created a new place for site content rather than the default one and it is working. Then I entered the basic info into the ssl.conf and the HTTPs is not working. When I do a nmap, it shows only two ports open: 22 & 80, and the 443 is closed, which should not be (I want only 3 ports open: 22, 80, and 443).

Anybody can help me with this? Thanks!
 
Old 07-24-2003, 11:33 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,675
Blog Entries: 54

Rep: Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954Reputation: 2954
Did you do a syntax check with Apache (see commandline switches)?
 
Old 07-25-2003, 10:18 AM   #3
bfdlinux
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Original Poster
Rep: Reputation: 0
OpenSSL Apache 2 RedHat 8

unpsawn:

I did syntax check. The problem was with the closed 443 port. I had to open port 443 in the fireewall config. It seems that if you use a different folder for site contnet and move the secure folder to a different location, apache 2 closes port 443.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache 2.0.55 & openssl 0.9.8 error? ziggie216 Linux - Software 4 11-27-2005 09:37 PM
OpenSSL + Apache certificate, how? The_Nerd Linux - Software 2 12-26-2004 10:18 PM
apache + mod_ssl without openssl , will it run ? kernelvn Linux - Security 1 10-02-2004 12:47 AM
Apache Openssl compile fails rioguia Linux - Software 2 11-07-2003 09:13 AM
Openssl and apache huno Linux - General 1 04-21-2003 03:06 PM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration