LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 08-01-2007, 11:35 PM   #1
dolreich_c
LQ Newbie
 
Registered: Apr 2005
Posts: 5

Rep: Reputation: 0
not allowing users to access internet using port 80 through squid proxy


hi ,
i have a squid linux server with authentication . whenever a user needs to browse an authentication login opens up . my default squid proxy port is 3128 . but when i change d port to 80 the browser opens up without any authentication and user is able to browse the internet . is there a way to block port 80 . i tried removing acl line in squid.conf file acl Safe_ports port 80 # http . but the problem persists.
can any 1 help me with this problem.

thanks regrds dolreich
 
Old 08-02-2007, 02:28 AM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Originally Posted by dolreich_c
when i change d port to 80
You mean like configuring the client as if though the proxy was actually running on port 80 instead of 3128? Wierd.

Quote:
user is able to browse the internet
But when this happens, is it happening through Squid? Or is there indications that they are getting routed through with SNAT? You can check by typing an invalid URL and seeing if you get a Squid error page.

Quote:
is there a way to block port 80
The thing is, unless you're doing some kind of routing, there really isn't any need to. A side-effect of having routing disabled and having the proxy listening only on one internal port is that changing the port number on the client would keep them offline. I'm starting to get the impression that perhaps you are indeed doing SNAT, and the clients are able to bypass the proxy by simply choosing not to use it - is that the case? Your "when I change the port to 80" comment makes it sound otherwise.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid help require - allowing internet access klmn1 Linux - Server 1 04-12-2007 06:34 AM
download restriction over internet access using squid (proxy server) pankajkarde Linux - Server 4 03-21-2007 01:04 AM
Squid not allowing port 99 jocast Linux - Software 6 05-24-2006 01:14 PM
Allowing Mails thru Squid Proxy? krishvij Linux - Newbie 3 04-07-2005 04:12 AM
Secure Proxy Configuration(squid) for a LAN to access Internet pune_abhishek Linux - Networking 5 11-30-2003 01:33 PM


All times are GMT -5. The time now is 09:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration