LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 01-23-2003, 04:03 AM   #1
Xgates
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 7

Rep: Reputation: 0
Question -nolisten tcp


I'm running Slackware 8.1, and I'm not sure if the configuration is different from distro to distro on this, but which file do you add in '-nolisten tcp' to have X not listen in on port 6000 ? I use to think you added in that line into
'startx' in /usr/X11R6/bin/startx, but that didn't help, and someone also told me you can add it into your $Home .xinitrc, but no luck on that either. ? Thanks in advance for any help someone can give. :-)
 
Old 01-23-2003, 04:21 AM   #2
Xgates
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Wink Ok I figured it out only 10mins after Posting :-)

OK I got the answer in /usr/X11R6/bin/startx
on the serverargs="" line add in like this:

serverargs="-nolisten tcp" (Ola Good buy Port 6000)

By the way I'm no NoOb to Slack or Linux can we PLEASE do something about that 'Newbie' under my name ? Ahhhh I think I'm going to puke

LMAO
 
Old 01-23-2003, 04:27 AM   #3
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,285
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
4 possibilities. It's a server arg, so on the cmdline it comes after the double dash: "startx -- -nolisten-tcp" or put it in /usr/X11R6/bin/startx as serverargs="-nolisten tcp" or put it in your ~/.xserverargs or make it a shell alias.
Btw, you could have found the answer searching LQ.
 
Old 01-23-2003, 04:30 AM   #4
Xgates
LQ Newbie
 
Registered: Jan 2003
Distribution: Slackware
Posts: 7

Original Poster
Rep: Reputation: 0
Well as you can see I did get it :-)

unSpawn Thx anyways I was one step ahead of you :-)
 
Old 01-23-2003, 04:48 AM   #5
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,285
Blog Entries: 54

Rep: Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854Reputation: 2854
np.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
--nolisten tcp glock19 Linux - General 11 02-05-2013 03:45 PM
-nolisten tcp for X ferreter Fedora 3 07-19-2004 02:38 PM
SuSE 9.1 eliminating -nolisten tcp jdeisenberg Linux - Software 1 06-04-2004 04:38 PM
X server - how to disable the -nolisten tcp startx default? lugoteehalt Debian 3 05-04-2004 07:12 AM
startx -nolisten tcp shanenin Slackware 2 11-12-2003 04:00 PM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration