LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 01-16-2008, 09:54 AM   #1
freeindy
Member
 
Registered: Nov 2002
Posts: 205

Rep: Reputation: 30
nis user login failure from remote host (ssh,sshd)


Hi,

I have the following Ubuntu 7.10 distribution on LOCAL machine.
On the REMOTE machine, I'm unsure but some recent flavour is installed.

I have a one user (USER_1) account on LOCAL machine.
I have also a NIS account (USER_NIS) which is logged in on the LOCAL machine.

From the REMOTE machine:
When I log in as USER_1 using ssh, it works just fine.
BUt, when I log in as user USER_NIS, it fails (after 3 attempts) with the following msg:

Code:
Permission denied (publickey,password).
I used sshd -d debug mode om the LOCAL machine and i get the following output:
Code:
debug1: sshd version OpenSSH_4.6p1 Debian-5ubuntu0.1
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-d'
debug1: Bind to port 22 on ::.
Server listening on :: port 22.
debug1: Bind to port 22 on 0.0.0.0.
Bind to port 22 on 0.0.0.0 failed: Address already in use.
debug1: Server will not fork when running in debugging mode.
debug1: rexec start in 4 out 4 newsock 4 pipe -1 sock 7
debug1: inetd sockets after dupping: 3, 3
Connection from 172.16.230.20 port 48372
debug1: Client protocol version 2.0; client software version OpenSSH_3.6.1p2
debug1: match: OpenSSH_3.6.1p2 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.6p1 Debian-5ubuntu0.1
debug1: permanently_set_uid: 111/65534
debug1: list_hostkey_types: ssh-rsa,ssh-dss
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST received
debug1: SSH2_MSG_KEX_DH_GEX_GROUP sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_INIT
debug1: SSH2_MSG_KEX_DH_GEX_REPLY sent
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: KEX done
debug1: userauth-request for user insi service ssh-connection method none
debug1: attempt 0 failures 0
User insi not allowed because shell /usr/OSE/bash does not exist
input_userauth_request: invalid user insi
debug1: PAM: initializing for "insi"
debug1: PAM: setting PAM_RHOST to "viper"
debug1: PAM: setting PAM_TTY to "ssh"
Failed none for invalid user insi from 172.16.230.20 port 48372 ssh2
debug1: userauth-request for user insi service ssh-connection method password
debug1: attempt 1 failures 1
debug1: PAM: password authentication failed for an illegal user: Authentication failure
Failed password for invalid user insi from 172.16.230.20 port 48372 ssh2
debug1: userauth-request for user insi service ssh-connection method password
debug1: attempt 2 failures 2
debug1: PAM: password authentication failed for an illegal user: Authentication failure
Failed password for invalid user insi from 172.16.230.20 port 48372 ssh2
debug1: userauth-request for user insi service ssh-connection method password
debug1: attempt 3 failures 3
debug1: PAM: password authentication failed for an illegal user: Have exhausted maximum number of retries for service
Failed password for invalid user insi from 172.16.230.20 port 48372 ssh2
Connection closed by 172.16.230.20
debug1: do_cleanup
debug1: do_cleanup
Anyone knows why?

Thanks,
Indy
 
Old 01-17-2008, 04:21 PM   #2
Bobism
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Rep: Reputation: 0
good log

This line in your log looks mighty suspect;

User insi not allowed because shell /usr/OSE/bash does not exist

I'm no expert, just browsing and saw it. Maybe you could put a link on the target machine so it finds bash there, and see if its happy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't SSH to remote machine: Connection closed by remote host Avatar Linux - Networking 34 05-24-2013 10:28 AM
Remote login with SSH, but display on remote computer. brodin Linux - Software 3 09-09-2007 04:01 AM
SSHD not allowing remote login c0mputerking Red Hat 3 07-29-2007 04:13 PM
can't login to a Slack machine using a NIS account through ssh nIMBVS Slackware 2 07-15-2004 03:15 AM
NIS client: user authentication failure mahasona Linux - Networking 0 12-05-2003 04:13 PM


All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration