LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Reply
 
Search this Thread
Old 08-01-2003, 01:51 PM   #1
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 591

Rep: Reputation: 31
iptables doesn't run correctly


hi,
I have a strange problem, I installed iptables on redhat 7.3,
the service is running, ( with service iptables start)

when I want to add rules or when I list iptables -L, it gives the following error:

/lib/modules/....../..../ip_tables.o: init_module device or resource busy

/lib/modules/.............../insmod /lib/modules/................/ip_tables.o failed
ipvtables cannot initialise iptables table 'filter'

The installation is doing by default with the rpm package.

I desinstalled iptables and reinstall it again , I have the same problem.
ipchains runs correctly!!

thank for help
bela
 
Old 08-02-2003, 01:14 AM   #2
Robert0380
Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
iptables is a kernel thing. you may have to run through the steps for recompiling he kernel. in he config stage, make sure all he netfilter stuff is compiled as modules (that works for me anyway)
 
Old 08-02-2003, 11:20 AM   #3
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
check whether you have ipchains installed too

rpm -q ipchains

remove ipchains if it is installed and start iptables.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting KPPP to run correctly azebuski Linux - Software 7 10-02-2004 12:38 PM
Can't run vdr or kvdr correctly bruno buys Linux - Software 1 09-18-2004 06:31 PM
Volume control is unable to run correctly hamish Linux - Software 0 09-28-2003 08:55 AM
neither cbq nor htb run correctly! saturn_vk Linux - Networking 0 04-27-2003 07:50 AM
iptables doesn't work correctly themorph Linux - Networking 1 02-20-2002 09:33 PM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration