LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 12-23-2003, 04:42 AM   #1
Lindy
Member
 
Registered: Nov 2001
Location: Manistique, MI
Distribution: SUSE 12.1
Posts: 136

Rep: Reputation: 15
Firestarter and iptables not playing nice


First off my system, 1.2Ghz celeron, 256mb ram ,80gig HD, running redhat 7.3
with kernel v 2.4.20-24.7. The system is used as a stand alone workstation with a dialup internet connection.
I installed firestarter, ran the firewall wizard then I rebooted to wintendo for a bit of gaming. When I booted back to linux it complained loudly, /var/log/messages shows: localhost iptables: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
localhost iptables: You may find more information in syslog or the output from dmesg
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o failed
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
localhost iptables: iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
localhost iptables: Perhaps iptables or your kernel needs to be upgraded.
localhost firestarter: Flushing all current rules and user defined chains: failed
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o:
localhost iptables: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
localhost iptables: You may find more information in syslog or the output from dmesg
localhost iptables: init_module: Device or resource busy
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o failed
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
localhost iptables: iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
localhost iptables: Perhaps iptables or your kernel needs to be upgraded.
localhost firestarter: Clearing all current rules and user defined chains: failed
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o:
localhost iptables: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
localhost iptables: You may find more information in syslog or the output from dmesg
localhost iptables: init_module: Device or resource busy
localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o failed localhost iptables: /lib/modules/2.4.20-24.7/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
localhost iptables: iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
localhost iptables: Perhaps iptables or your kernel needs to be upgraded.
localhost firestarter: Zeroing all current rules: failed

Where do I start working the problem?
 
Old 12-24-2003, 02:51 PM   #2
Lindy
Member
 
Registered: Nov 2001
Location: Manistique, MI
Distribution: SUSE 12.1
Posts: 136

Original Poster
Rep: Reputation: 15
O.K. I figgured it out... Uninstalled the RPM and then downloaded and installed from source. Now it works, no runs , nohits, no ERRORS! If your thinking about installing this program stay away from the RPM unless you like things going fubar on you. Why is it I get suckered in by RPMs? They look soooo easy, and then cause me soooo much pain.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu and XP not playing nice. kojima Linux - Distributions 8 10-13-2004 06:29 PM
Grub and XP not playing nice kojima Linux - Software 1 10-13-2004 10:07 AM
Gmplayer Not Playing Nice With Fluxbox 0.9.7 Crashed_Again Linux - Software 3 01-13-2004 01:50 PM
My Linux box is not playing nice warlord07 Linux - Networking 3 09-20-2003 02:41 PM
Windows not playing nice.... absolute0net Linux - Networking 0 07-07-2003 09:03 AM


All times are GMT -5. The time now is 07:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration