LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Closed Thread
 
Search this Thread
Old 06-18-2009, 07:03 PM   #1
Biggen
Member
 
Registered: Sep 2004
Location: Panama City Beach FL
Distribution: Slackware 12.2
Posts: 199

Rep: Reputation: 31
Fail2Ban not working properly with Slackware


Having some problems getting fail2ban to actually properly ban ip's that fail authentication when trying to SSH. Fail2ban client is up and running properly. I am feeding it the correct log file for slackware (/var/log/messages). I made sure to "enable" sshd-iptables in the jail.conf file. Here is a "status" to make sure fail2ban is running:

Code:
bash-3.1# fail2ban-client status
Status
|- Number of jail:	1
`- Jail list:		ssh-iptables
Then, I'l attempt to log on incorrectly to ssh and fail2ban will recognize the incorrect attempts. It will then ban that IP causing the failure. Here is proof that fail2ban is TRYING to work properly:

Code:
bash-3.1# fail2ban-client status ssh-iptables
Status for the jail: ssh-iptables
|- filter
|  |- File list:	/var/log/messages 
|  |- Currently failed:	1
|  `- Total failed:	9
`- action
   |- Currently banned:	1
   |  `- IP list:	192.168.1.3 
   `- Total banned:	1
As you can see, it banned 192.168.1.3. At least it thought it did... However, I can still connect to my server (192.168.1.2) with no problems. I can still ssh to it, check mail, etc... That address is NOT banned. I have already verified iptables is working by doing a:

"iptables -I INPUT -s 192.168.1.3 -j DROP"

I dunno what is up. Any one else have any problems?
 
Old 06-19-2009, 11:59 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 27,456
Blog Entries: 54

Rep: Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897Reputation: 2897
FUP to http://www.linuxquestions.org/questi...0/#post3579812
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fail2ban, is it working? SuperDude123 Linux - Security 7 02-17-2009 09:09 PM
opengl is not working properly PinRojas Debian 7 07-05-2005 12:19 PM
Cd Player Not Working Properly imakiller Linux - Newbie 8 03-24-2005 06:16 AM
X not working properly. MylesCLin Linux - Software 1 09-15-2004 10:46 AM


All times are GMT -5. The time now is 05:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration