LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 05-30-2005, 05:55 AM   #1
ssharma_02
LQ Newbie
 
Registered: Aug 2004
Location: Kanpur
Distribution: SuSE
Posts: 12

Rep: Reputation: 0
Does not prompt for password


I recently installed SuSE 9.2 on my machine, when i log on to it it does not prompt for the password and logs on to a non root login directly. How do i make it wait so that it may wait for the user to enter the account and the password
 
Old 05-30-2005, 06:05 AM   #2
bramhastra
Member
 
Registered: May 2005
Location: India
Distribution: RHEL 4.0
Posts: 136

Rep: Reputation: 15
have u checked ur passwords and user file entry
 
Old 05-30-2005, 06:18 AM   #3
ssharma_02
LQ Newbie
 
Registered: Aug 2004
Location: Kanpur
Distribution: SuSE
Posts: 12

Original Poster
Rep: Reputation: 0
Yes, the problem of prompt only occurs when KDE starts up, as of console it always does the expected , even when i run commands like su or yast passwd is asked for
 
Old 05-30-2005, 06:27 AM   #4
bramhastra
Member
 
Registered: May 2005
Location: India
Distribution: RHEL 4.0
Posts: 136

Rep: Reputation: 15
so this happens in GUI why dont u checkup /etc/securtty file
or try and reconfigure your bootloader
 
Old 05-30-2005, 04:11 PM   #5
Izmo
LQ Newbie
 
Registered: May 2005
Posts: 3

Rep: Reputation: 0
I recently installed SuSe 9.2 on my parents' machine and during the install, during the account setup phase I noticed a checkbox that said (something like) "Log in automatically". It was checked by default, and I left it at that hoping that it would do the exact same thing you wished to avoid. (My parents don't need that kind of security.) If you've recently installed the OS, I suggest you try it again, and uncheck the box.

Hope this helps.
 
Old 05-30-2005, 04:26 PM   #6
zackarya
Member
 
Registered: Jul 2003
Distribution: OpenSuse 10, Debian
Posts: 152

Rep: Reputation: 30
Hi ssharma_02, what you need to do is :
Click the KDE start button(lower left),
go to CONTROL CENTER,
go to SYSTEM ADMINISTRATION,
go to LOGIN MANAGER,
at the bottom is a button that says Administrator Mode(click it if your not the admin(which you should not be))
Type in the root password and click the tab up top that says Convenience.
Uncheck the box that says autologin.
That should be it. Hope that helps.

Zack
 
Old 06-02-2005, 02:51 AM   #7
ssharma_02
LQ Newbie
 
Registered: Aug 2004
Location: Kanpur
Distribution: SuSE
Posts: 12

Original Poster
Rep: Reputation: 0
Hi,
Thank You your suggestion worked out and i am happy to inform that the system now prompts for the passwd.
also while i was looking into control center i saw options to manage the start up screen , fonts , images etc.. any idea if how this configuration can be managed from console ie nt via control center.
I wish to know which files need to be changed rather which files hold the conf. information for kde start up etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why prompt for changing password? gogo Linux - General 1 03-10-2005 10:47 AM
scp, don't prompt password!! dlublink Linux - Networking 1 01-03-2005 01:54 PM
password prompt ? wr3ck3d Linux - General 5 03-20-2003 09:54 PM
No Password Prompt hockeydude Linux - General 3 04-18-2001 05:29 AM
no password prompt stroh78 Linux - General 3 01-02-2001 10:22 AM


All times are GMT -5. The time now is 07:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration