-   Linux - Security (
-   -   Can't add local system user - useradd keeps saying user already exists (

ADeluiz 08-22-2007 10:44 AM

Can't add local system user - useradd keeps saying user already exists
Hi all,

I'm trying to add a local user to a linux system. Although the user is not created in this system, when I run useradd it keeps saying that the user already exists.
I've already checked passwd, shadow and group files. Also took a look at files attributes (lsattr command).

Taking a look at /etc/nsswitch.conf, I saw that winbind is also a authentication method for this system against a Win2003 server.

passwd: compat winbind
group: compat winbind
shadow: compat winbind

Then I took a look at winbind log file and saw that, even if I want to add a local system user with the command "useradd -g users mytestuser", our Win2003 server is contacted by winbind to check if user already exists. And it does exist in Win2003 domain. But I need to create it as a local user.

In some other unix systems commands for adding user have a flag to indicate where to check/add users (LDAP, NIS, Local Base). But useradd command in linux doesn't have this documented.

Does anyone know how to do that without having to change temporarily nsswitch.conf file ? I want to add a user if it does not exist in local database (passwd, shadow) and even if it exists in Win2003 AD.

Thanks in advance.



WAJEDUR REHMAN 08-25-2007 11:23 AM

Try adding user manually

ADeluiz 08-27-2007 01:17 PM


Originally Posted by WAJEDUR REHMAN (Post 2870245)
Try adding user manually

I can do this at any time, but I think it's not the right way.
The problem will still exist if I need to add another user.


Julix 08-27-2007 10:44 PM

Hi ADeluiz,

Did you try to perform the command adduser instead of useradd?

WAJEDUR REHMAN 08-28-2007 06:38 AM

Try using single user mode console

wmodes 07-26-2013 03:17 PM

I found this thread, because I'm having the same problem.

The solutions offered are:
  • Try adding user manually
  • Try using single user mode console

Srsly? No attempt to actually solve the underlying problem?

If this is the quality of the answers here, I guess I'll stick to

All times are GMT -5. The time now is 12:17 AM.