LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices



Reply
 
Search this Thread
Old 10-13-2005, 11:47 AM   #1
xudingding
LQ Newbie
 
Registered: Oct 2005
Location: Lexington, KY
Distribution: Redhat Enterprise 4.0
Posts: 8

Rep: Reputation: 0
can not start my iptables


I change the user as root and go to the /etc/rc.d/init.d and type command
./iptables start
Then ./iptables status
it shows that Firwall is stopped
I am using RedHat Linux Enterprise v4.0

What is wrong?

Thank you.
 
Old 10-13-2005, 11:55 AM   #2
Nickj
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora 4
Posts: 27

Rep: Reputation: 15
Try 'service iptables start' instead?
 
Old 10-13-2005, 01:52 PM   #3
xudingding
LQ Newbie
 
Registered: Oct 2005
Location: Lexington, KY
Distribution: Redhat Enterprise 4.0
Posts: 8

Original Poster
Rep: Reputation: 0
I tried services iptables start and got the
message : permission denied. I logged in as a root.
 
Old 10-13-2005, 01:59 PM   #4
doublejoon
Member
 
Registered: Oct 2003
Location: King George, VA
Distribution: RHEL/CentOS/Scientific/Fedora, LinuxMint
Posts: 366

Rep: Reputation: 44
Is Selinux enabled? Might want to check there as well redhat-config-securitylevel
 
Old 10-13-2005, 02:31 PM   #5
xudingding
LQ Newbie
 
Registered: Oct 2005
Location: Lexington, KY
Distribution: Redhat Enterprise 4.0
Posts: 8

Original Poster
Rep: Reputation: 0
Could you give me the hint on how to check whether Selinux is enabled?

Thanks
 
Old 10-13-2005, 02:37 PM   #6
doublejoon
Member
 
Registered: Oct 2003
Location: King George, VA
Distribution: RHEL/CentOS/Scientific/Fedora, LinuxMint
Posts: 366

Rep: Reputation: 44
type "system-config-securitylevel". There is a Selinux tab there to check and see if its enabled or not
 
Old 10-13-2005, 03:30 PM   #7
xudingding
LQ Newbie
 
Registered: Oct 2005
Location: Lexington, KY
Distribution: Redhat Enterprise 4.0
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you very much!

I disable the Selinux and enable the firewall. and now I can change the iptables status.

many thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Iptables ate start-up martincho Linux - Networking 1 09-28-2005 03:14 PM
problem with iptables start ganesh_bhai Linux - Security 4 05-04-2005 05:12 AM
Configuring iptables at start up gezzam Mandriva 2 03-24-2005 02:12 AM
iptables coont start in the beginning dominant Linux - Newbie 4 02-25-2004 08:37 AM
iptables start doesn't work in slack 9 phishintrip Linux - Newbie 4 06-25-2003 02:15 PM


All times are GMT -5. The time now is 03:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration