Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 04-27-2010, 09:59 AM   #1
Registered: May 2007
Posts: 146

Rep: Reputation: 18
can't decrypt using openssl

Hi i need to decrypt things with my privatekey using openssl:
As an example this is the command i'm using to try and decrypt things that were encrypted with my public key:

#openssl rsautl -decrypt -in encrypted.txt -out result.txt -inkey privatekey.pem
and this is the result that i get:

RSA operation error
17812:error:0406506C:rsa routines:RSA_EAY_PRIVATE_DECRYPT:data greater than mod len:/on10/build-nd/G10U4B0/usr/src/common/openssl/crypto/rsa/rsa_eay.c:393:
The private key is in my PATH.The results are the same on solaris and linux.What am i doing wrong?.How should i decrypt files with my privatekey(which is pem format and is the right value)
Thankyou for your time
regards mathodtwo
Old 04-27-2010, 03:34 PM   #2
Senior Member
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora
Posts: 3,935
Blog Entries: 5

Rep: Reputation: Disabled
Well, perhaps the encrypted file or the key (or both) are corrupted.

Try encrypting and then decrypting a new, arbitrary file. Does that work?
Old 04-28-2010, 04:37 PM   #3
Senior Member
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778Reputation: 778
Please see my response to your thread on this forum:


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't decrypt anything with GPG Jorophose Linux - Security 2 12-06-2007 05:57 PM
oops openssl-0.9.8e over openssl-0.9.8d bad install now 2 copies? rcorkum Slackware 4 06-29-2007 02:58 AM
Decrypt SSL ajaye1971 Linux - Security 1 08-30-2006 05:06 PM
Kremlyn Decrypt? Alexo Linux - Software 1 05-24-2005 11:25 PM
decrypt pdf Daniel Han Linux - General 8 01-27-2004 04:34 AM

All times are GMT -5. The time now is 06:19 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration