LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Security
User Name
Password
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.

Notices

Closed Thread
 
LinkBack Search this Thread
Old 09-03-2003, 12:21 PM   #1
JGarcia
LQ Newbie
 
Registered: Aug 2003
Posts: 2

Rep: Reputation: 0
Angry can't authenticate in apache using PAM


hi everybody , i have been trying to use PAM authentication in my apache web server since two Weeks i have been trying, i really need some help.
that's what i have been done so far:

1) download mod_auth_Pam.tar.gz for apache 2.0.xx
2)tar -xzf mod_auth_pam.tar.gz
3)cd to the directory
4)make
5)make install
everything compiled without errors
6)in httpd.conf i had the following lines:
LoadMolude auth_pam_module modules/pam_auth_module.so
<directory /var/www/html/family/>
AuthPAM_Enabled on
AllowOverride none
AuthName "Family Secrets"
AuthType basic
Require valid-user
</directory>
7)cd /etc/pam.d
my configuration files look like this

login:

account required /lib/security/pam_unix.so
auth requisite /lib/security/pam_nologin.so
auth required /lib/security/pam_unix.so
session required /lib/security/pam_unix.so

passwd:

password required /lib/security/pam_unix.so

other:

account required /lib/security/pam_deny.so
auth required /lib/security/pam_deny.so
auth required /lib/security/pam_warn.so
password required /lib/security/pam_deny.so
password required /lib/security/pam_warn.so
session required /lib/security/pam_deny.so

8)service httpd start
starting httpd: OK

then i go to my browser an type my URL
and when i enter in the directory family
i get a prompt box asking me user name and password
i put my user name (one of the local user names) and i get the same box again and again and again ....
i check the error log and he says :

[Wed Sep 03 17:58:49 2003] [error] [client my ip address] PAM: user 'my user' - not authenticated: Authentication failure, referer: http//my ip address/

i think until now i have tried everything and i don't know what else can i do.
i really appreciate if anyone could help me

regards

JGarcia

 
Old 09-03-2003, 12:36 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,518
Blog Entries: 51

Rep: Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598
//moderator.note: Closed. Please don't crosspost.
FUP to first thread: http://www.linuxquestions.org/questi...threadid=86983
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Authenticate samba users against PAM yapp Linux - Networking 0 11-24-2005 05:59 AM
apache authenticate to Active Directory zuessh Linux - Software 1 07-08-2005 03:29 PM
Cannot Authenticate Via SSH Sivel Linux - Software 10 07-03-2005 10:13 AM
authenticate against AD paul_mat Linux - Networking 5 05-28-2005 08:34 AM
vsftpd + pam + virtual users - Pam cannot load database file. mdkelly069 Linux - Networking 3 09-22-2004 11:07 PM


All times are GMT -5. The time now is 05:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration