LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop > Linux - Screenshots
User Name
Password
Linux - Screenshots This forum is for the discussion and display of Linux Desktop screenshots. Please remember that many members browse LQ from work, so NSFW screenshots are not appropriate.

Notices

Reply
 
Search this Thread
Old 05-17-2012, 08:42 PM   #1
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Rep: Reputation: Disabled
Unhappy errors with the X window


hi,guys,just yesterday i installed the gnome desktop on my centos6.2(x64),i used this command "yum -y groupinstall X Windown System",it finished properly right,then i run "startx",it returns some errors,then run "init 5",this time it stays here,what's wrong?
 
Old 05-18-2012, 02:06 AM   #2
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Original Poster
Rep: Reputation: Disabled
i really have no idea.......
 
Old 05-18-2012, 02:34 AM   #3
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,478

Rep: Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220
I have no any idea too. But maybe you can post those error messages. Or how do you think?
 
Old 05-20-2012, 06:53 AM   #4
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
I have no any idea too. But maybe you can post those error messages. Or how do you think?
i wondered if differrnt machine has different results,i did all the above on another machine,but it had a totally different result,I made it!here is the error image i made:
Attached Images
File Type: jpg error.jpg (139.9 KB, 11 views)
 
Old 05-20-2012, 07:11 AM   #5
pan64
Senior Member
 
Registered: Mar 2012
Location: Hungary
Distribution: debian i686 (solaris)
Posts: 4,478

Rep: Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220Reputation: 1220
it looks for /dev/fb0, which should be the framebuffer device. But it does not exist in your system. So maybe you need to install it also (but it also depends on your config)
try this, maybe helps: https://bbs.archlinux.org/viewtopic.php?id=121533

Last edited by pan64; 05-20-2012 at 07:13 AM.
 
Old 05-20-2012, 09:09 AM   #6
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pan64 View Post
it looks for /dev/fb0, which should be the framebuffer device. But it does not exist in your system. So maybe you need to install it also (but it also depends on your config)
try this, maybe helps: https://bbs.archlinux.org/viewtopic.php?id=121533
maybe his solution dosen't fit my centos6.2,mine doesn't has ~/.xinitrc,and i try rm the /root/.Xauthority ,then run startx,but now i has more problems.......
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
xauth: creating new authority file /root/.serverauth.3069


X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: c6b5 2.6.32-44.2.el6.x86_64
Current Operating System: Linux dragon.org 2.6.32-220.el6.x86_64 #1 SMP Tue Dec 6 19:48:22 GMT 2011 x86_64
Kernel command line: ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap SYSFONT=latarcyrheb-sun16 rhgb quiet rd_LVM_LV=VolGroup/lv_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM
Build Date: 25 February 2012 04:11:35PM
Build ID: xorg-x11-server 1.10.4-6.el6_2.1.0.1.centos
Current version of pixman: 0.18.4
Before reporting problems, check http://wiki.centos.org/Documentation
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun May 20 21:58:52 2012
(==) Using default built-in configuration (30 lines)
(EE) open /dev/fb0: No such device
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
expected keysym, got XF86TouchpadOn: line 120 of inet
expected keysym, got XF86TouchpadOff: line 121 of inet
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
expected keysym, got XF86TouchpadOn: line 120 of inet
expected keysym, got XF86TouchpadOff: line 121 of inet
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

waiting for X server to shut down error setting MTRR (base = 0xe0000000, size = 0x00c00000, type = 1) Invalid argument (22)

Last edited by lonelyman; 05-20-2012 at 09:11 AM.
 
Old 07-28-2012, 05:30 PM   #7
Karl Godt
Member
 
Registered: Mar 2010
Location: Kiel , Germany
Distribution: once:SuSE6.2,Debian3.1, aurox9.2+3,Mandrake?,DSL? then:W7st,WVHB, #!8.10.02,PUPPY4.3.1 now:Macpup
Posts: 308

Rep: Reputation: 45
Code:
mknod /dev/fb0 c 29 0
should create /dev/fb0
 
Old 07-29-2012, 01:08 AM   #8
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Original Poster
Rep: Reputation: Disabled
thanks for your help,i had it reinstalled,and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating a Fixed Window Size in a Window Manager (Odd Question) Stupac Programming 3 06-30-2011 04:04 AM
Awesome Window manager ~ resize window key bindings do not work. bubnoff Linux - Desktop 0 12-23-2010 01:08 PM
Errors, Errors, and more Errors (KDE 3.4.x GUI Errors) Dralnu Linux - Software 2 05-13-2006 08:30 AM
why mandriva 10.2 gnome2.8 system freezes upon resizing/opening window/new window skaramanger Mandriva 2 08-15-2005 04:38 PM
Bad window errors lestoil Slackware 2 06-21-2005 03:26 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration