LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-26-2011, 06:33 PM   #1
kwreed
LQ Newbie
 
Registered: Jul 2011
Posts: 3

Rep: Reputation: Disabled
zoneminder keeps hanging up , iceweasel // localhost/zm watch


Hi,

I hope someone can help me. I'm running a Debian installation from which I installed zomeminder using Synaptic Package manager. I fixed several issues with deprecated functions and other miscellaneous stuff. Finally have it working fairly well.

However, not quite....

zoneminder keeps hanging up as a review the captures in iceweasel. I click on the id field in the table and the event view shows up. After I review several, clicking the delete button on each to move forward Iceweasel hang up with the pinwheel spinning. If I completely close out iceweasel I can then start reviewing again.

The following error message appears in the apache2/error.log.

[Tue Jul 26 18:59:36 2011] [error] [client 127.0.0.1] socket_sendto( /tmp/zms-644018s.sock ) failed: No such file or directory, referer: http://localhost/zm/?view=watch&mid=1
[Tue Jul 26 18:59:36 2011] [error] [client 127.0.0.1] array (\n 0 => \n array (\n 'file' => '/usr/share/zoneminder/ajax/stream.php',\n 'line' => 56,\n 'function' => 'ajaxError',\n 'args' => \n array (\n 0 => 'socket_sendto( /tmp/zms-644018s.sock ) failed: No such file or directory',\n ),\n ),\n 1 => \n array (\n 'file' => '/usr/share/zoneminder/index.php',\n 'line' => 116,\n 'args' => \n array (\n 0 => '/usr/share/zoneminder/ajax/stream.php',\n ),\n 'function' => 'require_once',\n ),\n), referer: http://localhost/zm/?view=watch&mid=1

I checked the socket path and .sock 's do appear at that location.

Any ideas, anyone ?

Thanks,
Ken
 
Old 07-26-2011, 10:38 PM   #2
argon99
Member
 
Registered: Mar 2009
Posts: 37

Rep: Reputation: 16
If I was you I would give google chrome a try. This will maybe work and tell you if the problem is in firefox/iceweazle or zoneminder. I was going to build a security system with zone minder. What kind of cameras are you using and do they work at night?
 
Old 07-27-2011, 05:28 PM   #3
kwreed
LQ Newbie
 
Registered: Jul 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
I've tried three browsers

Haven't tried Google Chrome lately. When last installed it broke other things on my Vista machine.

I've tried internet explorer, 2 machines - different problems, won't show video, java errors, without installing cambozola (or some such thing). Also can't rename events in the 'view' window.

I've also tried epiphany, lightest cpu load on my aging zonemaster platform. But,no video feed appears. - haven't troubleshot yet ( if ever ).

Iceweasel problem as described.

I have two older cameras, a cheap Lorex, comensurate results. Also a X10, poor quality and often loses sync, probably because it's transmitting on 2.4GHz ( same freq as wifi 802.11.B ). Neither one works well in the dark.

Won't invest any more in cameras until I believe zonemaster will solve my problem.
 
Old 07-28-2011, 09:16 PM   #4
argon99
Member
 
Registered: Mar 2009
Posts: 37

Rep: Reputation: 16
Quote:
Originally Posted by kwreed View Post
Haven't tried Google Chrome lately. When last installed it broke other things on my Vista machine.

I've tried internet explorer, 2 machines - different problems, won't show video, java errors, without installing cambozola (or some such thing). Also can't rename events in the 'view' window.

I've also tried epiphany, lightest cpu load on my aging zonemaster platform. But,no video feed appears. - haven't troubleshot yet ( if ever ).

Iceweasel problem as described.

I have two older cameras, a cheap Lorex, comensurate results. Also a X10, poor quality and often loses sync, probably because it's transmitting on 2.4GHz ( same freq as wifi 802.11.B ). Neither one works well in the dark.

Won't invest any more in cameras until I believe zonemaster will solve my problem.

I don't know if the browser is an issue or not but I would like to isolate the problem. Is it in zoneminder or in the browser. I assume that you have a linux box for this. So install google chrome on the linux box and see how zoneminder runs. It doesn't have to cure all problems but if it breaks some other way it will be a good indicator that the problem is in the browser and not zoneminder.

It doesn't surprise me that vista was a problem. I haven't heard anybody liking vista, well at least anybody that has to make them it right.
 
Old 08-03-2011, 06:43 AM   #5
kwreed
LQ Newbie
 
Registered: Jul 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
I installed Firefox on the box that is running zoneminder. That seemed more complicated than necessary. Anyways, It does seem to run better on Firefox, I had to remove Iceweasel to get Firefox in. However, it still hangs ("waiting for localhost") after reviewing and deleting a number of events as video streams. The only way I've been able to get it going again, when it hangs is to shut the browser down and open up the http::localhost/zm again.
No errors reported in /var/log/syslog.
tail /var/log/apache2/errors.log looks like this:
[Wed Aug 03 07:02:35 2011] [error] [client 192.168.53.218] socket_sendto( /tmp/zms-468978s.sock ) failed: No such file or directory, referer: http://192.168.53.201/zm/?view=event...&val1=1&page=1
[Wed Aug 03 07:02:35 2011] [error] [client 192.168.53.218] array (\n 0 => \n array (\n 'file' => '/usr/share/zoneminder/ajax/stream.php',\n 'line' => 55,\n 'function' => 'ajaxError',\n 'args' => \n array (\n 0 => 'socket_sendto( /tmp/zms-468978s.sock ) failed: No such file or directory',\n ),\n ),\n 1 => \n array (\n 'file' => '/usr/share/zoneminder/index.php',\n 'line' => 116,\n 'args' => \n array (\n 0 => '/usr/share/zoneminder/ajax/stream.php',\n ),\n 'function' => 'require_once',\n ),\n), referer: http://192.168.53.201/zm/?view=event...&val1=1&page=1
[Wed Aug 03 07:02:37 2011] [error] [client 192.168.53.218] File does not exist: /usr/share/zoneminder/cambozola.jar
[Wed Aug 03 07:02:37 2011] [error] [client 192.168.53.218] File does not exist: /usr/share/zoneminder/cambozola.jar
[Wed Aug 03 07:02:37 2011] [error] [client 192.168.53.218] File does not exist: /usr/share/zoneminder/cambozola.jar
[Wed Aug 03 07:02:37 2011] [error] [client 192.168.53.218] File does not exist: /usr/share/zoneminder/cambozola.jar
[Wed Aug 03 07:02:37 2011] [error] [client 192.168.53.218] File does not exist: /usr/share/zoneminder/com
[Wed Aug 03 07:02:37 2011] [error] [client 192.168.53.218] File does not exist: /usr/share/zoneminder/com
[Wed Aug 03 07:03:50 2011] [error] [client 192.168.53.218] File does not exist: /var/www/favicon.ico

Oh, by the way. My .wav file doesn't play on Alarm anymore.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: If you’re running Iceweasel 4.0.1 from mozilla.debian.net, change your sources to Iceweasel 5. LXer Syndicated Linux News 0 06-23-2011 01:40 AM
The open with dialog in iceweasel is not opening iceweasel! ck_at_work Linux - General 6 11-09-2010 01:49 AM
LXer: Uh Oh. Another Smooth Move from Microsoft: Watch out, Ruby. Watch out OSI. LXer Syndicated Linux News 0 07-30-2007 11:46 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration