LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2002, 02:55 AM   #1
wallawonder
LQ Newbie
 
Registered: May 2002
Distribution: SuSE 8.0
Posts: 5

Rep: Reputation: 0
Exclamation ZIP won't mount after CDRW install


Recently got and installed a Yamaha CRW2200EZ CD burner. I physically moved my ZIP drive from being a slave on IDE2 to being a slave on IDE1. I put the Yamaha where the ZIP used to be, a slave on IDE2. When I booted into linux for the first time, it detected the CD burner and ZIP fine during the boot message. When the KDE 3 desktop came up, two things happened (or didn't), no icon or way to use the cd burner, and now my ZIP drive (previously installed and working) won't mount. I get the error message,

Could not mount device.
The reported error was:
mount: /dev/hdd4: unknown device

I ran siga, and in the /var/log/boot.msg file, it's giving the ZIP drive a device name of, hdb, but in /etc/fstab, it says the ZIP is hdd4. The Yamaha was assigned as, hdd in the boot.msg and doesn't exist in fstab.
QUESTION: Suspect this is because I changed the hardware configuration in my box so how do I make these two match up? And is this related to the ZIP link on my desktop not working?

I'm quite a newbie and just don't know where to begin or even where to look for info on how to make the correction. Would just like to get the ZIP working and then tackle the cd burner after I do some more reading about them.

Thanks in advance for your help!

......................
Hardware:

Before installation of CDRW:
IDE1 - Master: Hard Drive
IDE2 - Master: CD-ROM Drive Slave: ZIP

After installation of CDRW:
IDE1 - Master: Hard Drive Slave: ZIP
IDE2 - Master: CD-ROM Drive Slave: Yamaha CDRW

Software:

SuSE 8.0
Kernel: 2.4.18
 
Old 06-16-2002, 09:07 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Okey Dokey, I think I gotcha

You will want to edit your fstab to update the resulting changes

If you type 'mount' it will show you what you have mounted and where.

Just a little go by for ya:
Before install of CDRW
IDE1 = /dev/hda
IDE2 = /dev/hdb0:/dev/hdb1 (I am guessing on the hd part for the zip drive, but it should be 0 and 1 if they are the same device type ie. hd, if not it will be 0 and 0)
AFTER install:
IDE1 = /dev/hda0:/dev/hda1
IDE2 = /dev/hdb0:/dev/scd0 (or poss /dev/hdb1)

I think anyway, someone correct me if I am wrong here.

Anyway, if I am right, then you would (check /mnt first to see if there is already an entry, if not then...) open up a term and type:
Code:
mkdir /mnt/ZIP &&
mount -t FAT (or whatever filesystemyou used to write the files onto it with) /dev/hda1  /mnt/ZIP &&
cd /mnt/ZIP
At least that is how I would attempt it. I am probably WAYY wrong, but it's worth a shot.

Good luck

<edit>
But before doing that, you need to update your FSTAB (/etc/fstab.conf) to reflect the changes. So do 2 things, first open fstab and copy and paste the contents into here so we can see what's up. Second, type mount and copy and paste those results here too so we can see what's up there too. Then some can give you the lines to edit in your FSTAB. I hope anyway.
</edit>

Last edited by MasterC; 06-16-2002 at 09:10 AM.
 
Old 06-16-2002, 12:35 PM   #3
wallawonder
LQ Newbie
 
Registered: May 2002
Distribution: SuSE 8.0
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you MasterC. Wow what a quick reply! Thanks so much.

Here's the contents of /etc/fstab.conf:
...........................
/dev/hda3 / reiserfs defaults 1 2
/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
devpts /dev/pts devpts defaults 0 0
/dev/hda4 /home reiserfs defaults 1 2
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
proc /proc proc defaults 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
/dev/hda1 /windows/C vfat noauto,user 0 0
/dev/hdd4 /media/zip auto noauto,user 0 0
/dev/hda2 swap swap pri=42 0 0
............................

Yea, I'm afraid I still haven't totally rid myself of WinME...someday it'll happen. ;-)

Here's the contents of mount:
...................................
/dev/hda3 on / type reiserfs (rw)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw)
/dev/hda4 on /home type reiserfs (rw)
shmfs on /dev/shm type shm (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
...................................

Will wait to hear back before trying anything.

THANK YOU!
 
Old 06-16-2002, 10:47 PM   #4
rootman147
Member
 
Registered: May 2002
Location: Hangon...find / -name location
Distribution: Slackware
Posts: 46

Rep: Reputation: 15
sounds like when you moved the zip to a new cable it changed from /dev/hdd4 to something else...as for the cdburner...no a clue
 
Old 06-17-2002, 12:18 AM   #5
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
For the zip drive, try changing this line:

/dev/hdd4 /media/zip auto noauto,user 0 0

To this:

/dev/hdb4 /media/zip auto noauto,user 0 0

For the cdrom drive, run this command:

ln -sf /dev/hdd /dev/cdrom
 
Old 06-18-2002, 08:43 AM   #6
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
OK, I think I see what's happening here (correct me if I'm wrong).

You added a new device to your machine and moved your ZIP drive to a new channel?

OK, lets see, you originally had:
hda = Harddisk
hdb =
hdc = CD Rom
hdd = Zip

After the installation of new CDRW:
hda = Harddrive
hdb = Zip
hdc = CD Rom
hdd = CDRW

So far so good?

Now, there will probably be a couple of things needing changing:
You should first check your /etc/lilo.conf file. The reason being that Zip drives will normally need some parameters passed to the kernel. I would hazard a guess that the 'append=' section of the Linux entry in your lilo.conf file has this: hdd=ide-floppy (or it might be ide-scsi). If this is the case, then you'll first need to make the relevant changes:

Certainly Mandy used to pass hdx=ide-floppy for Zip drives, but now passes hdx=ide-scsi, which seems to work much better, so I'd do this. Edit your lilo.conf file and change the append section to include the following:

hdb=ide-scsi hdd=ide-scsi

You need to use SCSI emulation in order to burn CDs within Linux.

Now, once that's done, run /sbin/lilo to put the changes in effect, and then reboot your machine. When it comes back up, you can edit your fstab to suit.

You should have an entry for the following:
/dev/sda4 /media/zip auto noauto,user 0 0
/dev/scd0 /media/cdrw auto noauto,user 0 0
/dev/hdc /media/cdrom auto noaudo,user 0 0

Your zip will be recognised as a scsi harddisk, hence the sda4, and your CDRW as a scsi CDRW, hence the scd0, and your ordinary CD rom will be recognised as a normal IDE device, hence the hdc.

Hope this helps.

Post back if you're still having probs.
 
Old 06-19-2002, 11:55 PM   #7
wallawonder
LQ Newbie
 
Registered: May 2002
Distribution: SuSE 8.0
Posts: 5

Original Poster
Rep: Reputation: 0
ZIP Drive works!

Thank you all so much for your help! I would be utterly lost without a forum like this since I know no one personally who is a linux expert let alone another user.

I followed your instructions, to the letter, and they were right-on. There were however two other things I had to do before the desktop link would work. I wanted to include these items in this thread just in case another newbie has the same problem.

First, SuSE had a web help page (http://sdb.suse.de/en/sdb/html/tbraza_ide_brenner.html) that pretty much followed the instructions above except it included one more addition to the
/etc/init.d/boot.local
file; that being the line, /sbin/modprobe ide-scsi
Don't know if it's SuSE specific and I'm not sure if the ZIP would have worked without it but I made the change and the ZIP worked great.

Second, in order for the link on the desktop to work, I had to right-mouse click, select properties, click the "Device" tab, and change the device to the newly named ZIP drive, /dev/sda4.

Now that the ZIP is working, I get to tackle the CDRW, wahoo! Will post a new thread if I hit a brick wall.

Thanks all!
 
Old 08-08-2002, 01:35 AM   #8
HuFlungDung
LQ Newbie
 
Registered: Aug 2002
Location: Canada
Distribution: SuSe 8
Posts: 4

Rep: Reputation: 0
I think the information in this thread may solve my similar problem, but when I check my /etc/lilo/conf, I don't see any entries in there at all for:
/dev/hdb4
which I am sure is the correct address of my zip drive, as slave on the first IDE channel

My question : can one of you post your lilo.conf file so I can see what else should be written up about the hdb4 besides the append statement?

Also, I see nothing in there about my regular 3.5" floppy disk. Should there be something?

My file may not have been configured ordinarily because for whatever reason, I had to run the initial installation with "safe settings" to get past the boot screens.

Thanks so much if you can help.
 
Old 08-08-2002, 08:58 AM   #9
fatpig
Member
 
Registered: Dec 2001
Distribution: mandrake
Posts: 87

Rep: Reputation: 15
yeah as i thought these guys are basically sayin that yo config files been fucked up

gotta update where da fuck yo zipdrive is located so dat linux can mount tha bitch


just kidding.
yeah just update your config file.
(honestly forgot which one... something fstab maybe?)

linux thugz 4 L|f3
 
Old 08-08-2002, 10:45 AM   #10
HuFlungDung
LQ Newbie
 
Registered: Aug 2002
Location: Canada
Distribution: SuSe 8
Posts: 4

Rep: Reputation: 0
I've checked my fstab.conf settings and they seem to be perfectly correct and this drive should mount, but the lilo.conf doesn't jive with what these guys are saying it should.
 
Old 08-08-2002, 06:42 PM   #11
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Could you post the contents of both your lilo.conf file, and you fstab file? That's help us to help you much more efficiently.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i mount a usb cdrw? munkeevegetable Linux - Newbie 6 11-05-2004 02:13 AM
Have to mount zip drive twice to get it to mount. frodriguez Linux - Hardware 2 06-11-2004 03:09 PM
scsi emulation with removeable zip and cdrw dibblethewrecke Linux - Hardware 1 05-21-2004 12:27 PM
re: how do I mount my cdrom-which is a cdrw ergo_sum Linux - Hardware 10 11-01-2003 05:37 AM
I cant mount my CDRW morphyn Linux - Hardware 7 08-11-2003 12:54 PM


All times are GMT -5. The time now is 12:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration