LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-01-2011, 06:26 AM   #1
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,668

Rep: Reputation: 46
yum won't install updates, dependency problem?


I tried to do a yum update on one of my RHEL servers, and it didn't seem to do anything. Here's the end of the long list of output. What should I try doing to fix this?



--> Processing Dependency: xen-libs = 3.0.3-64.el5_2.1 for package: xen
---> Package xen-libs.i386 0:3.0.3-120.el5_6.1 set to be updated
--> Processing Dependency: liblzma.so.0 for package: xen-libs
--> Processing Dependency: libext4fs.so.2 for package: xen-libs
---> Package xulrunner.i386 0:1.9.2.15-2.el5_6 set to be updated
--> Running transaction check
---> Package bitstream-vera-fonts.noarch 0:1.10-7 set to be updated
---> Package e4fsprogs-libs.i386 0:1.41.12-2.el5 set to be updated
---> Package fipscheck-lib.i386 0:1.2.0-1.el5 set to be updated
--> Processing Dependency: /usr/bin/fipscheck for package: fipscheck-lib
---> Package hmaccalc.i386 0:0.9.6-3.el5 set to be updated
---> Package iscsi-initiator-utils.i386 0:6.2.0.872-6.el5 set to be updated
---> Package libgomp.i386 0:4.4.4-13.el5 set to be updated
---> Package libselinux-utils.i386 0:1.33.4-5.7.el5 set to be updated
---> Package python-libs.i386 0:2.4.3-43.el5 set to be updated
--> Processing Dependency: xen-libs = 3.0.3-64.el5_2.1 for package: xen
---> Package xorg-x11-fonts-Type1.noarch 0:7.1-2.1.el5 set to be updated
---> Package xz-libs.i386 0:4.999.9-0.3.beta.20091007git.el5 set to be updated
--> Running transaction check
---> Package fipscheck.i386 0:1.2.0-1.el5 set to be updated
--> Processing Dependency: xen-libs = 3.0.3-64.el5_2.1 for package: xen
--> Finished Dependency Resolution
xen-3.0.3-64.el5_2.1.i386 from installed has depsolving problems
--> Missing Dependency: xen-libs = 3.0.3-64.el5_2.1 is needed by package xen-3.0.3-64.el5_2.1.i386 (installed)
--> Running transaction check
---> Package kernel.i686 0:2.6.18-92.el5 set to be erased
---> Package kernel-xen.i686 0:2.6.18-92.el5 set to be erased
--> Processing Dependency: xen-libs = 3.0.3-64.el5_2.1 for package: xen
--> Finished Dependency Resolution
xen-3.0.3-64.el5_2.1.i386 from installed has depsolving problems
--> Missing Dependency: xen-libs = 3.0.3-64.el5_2.1 is needed by package xen-3.0.3-64.el5_2.1.i386 (installed)
Error: Missing Dependency: xen-libs = 3.0.3-64.el5_2.1 is needed by package xen-3.0.3-64.el5_2.1.i386 (installed)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
 
Old 04-01-2011, 09:02 AM   #2
spoovy
Member
 
Registered: Feb 2010
Location: London, UK
Distribution: Slackware 14; CentOS; Vyatta
Posts: 372

Rep: Reputation: 33
Looks like xen-libs (or a new enough version of xen-libs at least) isn't available in the available repos. Try "yum --enablerepo=\* list *xen-libs*" to see what is available.
 
Old 04-01-2011, 09:06 AM   #3
rjo98
Senior Member
 
Registered: Jun 2009
Location: US
Distribution: RHEL, CentOS
Posts: 1,668

Original Poster
Rep: Reputation: 46
oh, so there's nothing actually wrong with my server, it just can't find that one file in the repositories it knows about?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum client package/updates installation and updates through local Yum Server gautamnarayan Linux - Server 1 03-11-2010 02:51 AM
Disallow an unwanted dependency: yum install... Seemoi Fedora 3 11-24-2009 10:50 AM
FC6 - yum ndiswrapper install has old kernel dependency mrjogo Linux - Wireless Networking 7 01-04-2007 06:48 AM
yum install kino - Missing Dependency: libavutil.so schlough Linux - Software 5 01-13-2006 10:07 PM
Yum dependency problem lucifer623 Fedora 4 10-09-2005 02:51 PM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration