LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-10-2013, 02:29 AM   #1
RAJAROOPAN
LQ Newbie
 
Registered: Jan 2013
Posts: 1

Rep: Reputation: Disabled
Unhappy YUM Update in Oracle Enterprise Linux


I am not able to sort this out, please suggest

[root@l1614 yum]# yum update
Loaded plugins: security
Excluding Packages from software repo - OEL5 - x86_64
Finished
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package net-snmp-libs.x86_64 1:5.3.2.2-5.el5_3.2 set to be updated
---> Package bind-libs.x86_64 30:9.3.4-10.P1.el5_3.3 set to be updated
---> Package net-snmp.x86_64 1:5.3.2.2-5.el5_3.2 set to be updated
---> Package nscd.x86_64 0:2.5-34.el5_3.1 set to be updated
---> Package nspr.i386 0:4.7.4-1.el5_3.1 set to be updated
---> Package apr-util.i386 0:1.2.7-7.el5_3.2 set to be updated
---> Package glibc.x86_64 0:2.5-34.el5_3.1 set to be updated
---> Package clamd.x86_64 0:0.97.2-1.el5.rf set to be updated
---> Package audit-libs.x86_64 0:1.7.7-6.el5_3.3 set to be updated
---> Package glibc-devel.x86_64 0:2.5-34.el5_3.1 set to be updated
--> Processing Dependency: libgif.so.4()(64bit) for package: giflib-devel
---> Package cfg2html-linux.noarch 0:1.93-1 set to be updated
---> Package clamav-db.x86_64 0:0.97.2-1.el5.rf set to be updated
---> Package nspr.x86_64 0:4.7.4-1.el5_3.1 set to be updated
---> Package mkinitrd.x86_64 0:5.1.19.6-44.1.0.2 set to be updated
---> Package unzip.x86_64 0:5.52-3.0.1.el5 set to be updated
---> Package xulrunner.x86_64 0:1.9.0.12-1.0.1.el5_3 set to be updated
---> Package nss.i386 0:3.12.3.99.3-1.el5_3.2 set to be updated
---> Package glibc.i686 0:2.5-34.el5_3.1 set to be updated
---> Package nss.x86_64 0:3.12.3.99.3-1.el5_3.2 set to be updated
---> Package tzdata.x86_64 0:2010o-1.el5 set to be updated
---> Package autofs.x86_64 1:5.0.1-0.rc2.102.el5_3.1 set to be updated
---> Package net-snmp-utils.x86_64 1:5.3.2.2-5.el5_3.2 set to be updated
---> Package audit-libs-python.x86_64 0:1.7.7-6.el5_3.3 set to be updated
---> Package kernel-uek-headers.x86_64 0:2.6.32-300.39.2.el5uek set to be updated
---> Package ksh.x86_64 0:20080202-2.el5_3.1 set to be updated
---> Package perl.x86_64 4:5.8.8-18.el5_3.1 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-44.1.0.2 set to be updated
---> Package netpbm.x86_64 0:10.35-6.1.el5_3.1 set to be updated
---> Package chkrootkit.x86_64 0:0.49-1.el5.rf set to be updated
---> Package ipsec-tools.x86_64 0:0.6.5-13.el5_3.1 set to be updated
---> Package libxml2-python.x86_64 0:2.6.26-2.1.2.8.0.1 set to be updated
---> Package bind-utils.x86_64 30:9.3.4-10.P1.el5_3.3 set to be updated
---> Package apr.i386 0:1.2.7-11.el5_3.1 set to be updated
---> Package nss-tools.x86_64 0:3.12.3.99.3-1.el5_3.2 set to be updated
---> Package libungif.x86_64 0:4.1.3-1.el4.2 set to be updated
---> Package nash.x86_64 0:5.1.19.6-44.1.0.2 set to be updated
---> Package file.x86_64 0:4.17-15.el5_3.1 set to be updated
---> Package glibc-common.x86_64 0:2.5-34.el5_3.1 set to be updated
---> Package pango.x86_64 0:1.14.9-5.el5_3 set to be updated
---> Package netpbm-progs.x86_64 0:10.35-6.1.el5_3.1 set to be updated
---> Package clamav.x86_64 0:0.97.2-1.el5.rf set to be updated
---> Package device-mapper-multipath.x86_64 0:0.4.7-23.el5_3.4 set to be updated
---> Package acpid.x86_64 0:1.0.4-7.el5_3.1 set to be updated
---> Package libungif.i386 0:4.1.3-1.el4.2 set to be updated
---> Package udev.x86_64 0:095-14.20.el5_3 set to be updated
---> Package glibc-headers.x86_64 0:2.5-34.el5_3.1 set to be updated
---> Package glibc-devel.i386 0:2.5-34.el5_3.1 set to be updated
---> Package yum.noarch 0:3.2.19-18.el5_3.1 set to be updated
---> Package audit-libs.i386 0:1.7.7-6.el5_3.3 set to be updated
---> Package crash.x86_64 0:4.0-7.2.3.0.1.el5_3.1 set to be updated
---> Package CollabNetSubversion-client.x86_64 0:1.6.17-1 set to be updated
---> Package apr-util.x86_64 0:1.2.7-7.el5_3.2 set to be updated
---> Package kpartx.x86_64 0:0.4.7-23.el5_3.4 set to be updated
---> Package sudo.x86_64 0:1.6.9p17-3.el5_3.1 set to be updated
---> Package sos.noarch 0:1.7-9.16.0.1.el5_3.5 set to be updated
---> Package apr.x86_64 0:1.2.7-11.el5_3.1 set to be updated
---> Package kernel-devel.x86_64 0:2.6.18-128.7.1.0.1.el5 set to be installed
---> Package oracle-validated.x86_64 0:1.0.0-26.el5 set to be updated
---> Package libxml2.i386 0:2.6.26-2.1.2.8.0.1 set to be updated
---> Package libbdevid-python.x86_64 0:5.1.19.6-44.1.0.2 set to be updated
--> Processing Dependency: libgif.so.4 for package: giflib-devel
---> Package glibc-kernheaders.x86_64 0:2.4-9.1.100.EL set to be updated
---> Package libxml2.x86_64 0:2.6.26-2.1.2.8.0.1 set to be updated
---> Package python.x86_64 0:2.4.3-24.el5_3.6 set to be updated
---> Package curl.x86_64 0:7.15.5-2.1.el5_3.5 set to be updated
---> Package ntp.x86_64 0:4.2.2p1-9.el5_3.2 set to be updated
--> Finished Dependency Resolution
giflib-devel-4.1.3-7.1.el5_3.1.i386 from installed has depsolving problems
--> Missing Dependency: libgif.so.4 is needed by package giflib-devel-4.1.3-7.1.el5_3.1.i386 (installed)
giflib-devel-4.1.3-7.1.el5_3.1.x86_64 from installed has depsolving problems
--> Missing Dependency: libgif.so.4()(64bit) is needed by package giflib-devel-4.1.3-7.1.el5_3.1.x86_64 (installed)
Error: Missing Dependency: libgif.so.4()(64bit) is needed by package giflib-devel-4.1.3-7.1.el5_3.1.x86_64 (installed)
Error: Missing Dependency: libgif.so.4 is needed by package giflib-devel-4.1.3-7.1.el5_3.1.i386 (installed)
[root@l1614 yum]#

Last edited by RAJAROOPAN; 01-10-2013 at 02:31 AM. Reason: Updation
 
Old 01-10-2013, 03:40 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
Not an LFS question, this will be moved to a more suitable location shortly.

This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.
 
Old 01-10-2013, 04:58 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154Reputation: 3154
Welcome to LQ.
Quote:
I am not able to sort this out, please suggest
Please contact Oracle. They take care of any support.

But : If you have no license / Oracle subscription :
No packages can be installed or updated.
 
Old 01-11-2013, 02:50 AM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
Also note that you've got several xxx.el5.rf (rpmforge) pkgs mentioned, which means you've mixed repos. This can lead to version clashes.
As above, if this is an OEL box contact Oracle, but in any case you should install the yum-priorities pkg to prevent the repo clash.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to update Packages in Oracle Enterprise Linux(OEL).... kazi9822 Linux - Newbie 4 10-02-2012 11:49 AM
install git 1.7.4.5 on Oracle Enterprise Linux 5 Update 4 Ramdisk 64-bit launeric Linux - Newbie 1 04-23-2011 09:12 AM
I want to reconfigure Yum for Oracle Enterprise Linux 5 999af Linux - Software 3 02-18-2011 11:47 AM
LXer: Oracle and Symantec Certify Veritas Data Center Solutions on Oracle(R) Enterprise Linux LXer Syndicated Linux News 0 07-18-2007 07:31 AM


All times are GMT -5. The time now is 02:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration