LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 06-27-2011, 11:29 PM   #1
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Rep: Reputation: 8
Yum update Errors


This is what I get when I execute yum update

Code:
[root@rubolzz Genocide_Hoax]# yum update
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Adding en_US to language list
Loading mirror speeds from cached hostfile
 * fedora: fedora.iitm.ac.in
 * livna: rpm.livna.org
 * rpmfusion-free: mirror.cse.iitk.ac.in
 * rpmfusion-free-debuginfo: mirror.bjtu.edu.cn
 * rpmfusion-free-rawhide: mirror.bjtu.edu.cn
 * rpmfusion-free-rawhide-debuginfo: mirror.bjtu.edu.cn
 * rpmfusion-free-source: mirror.bjtu.edu.cn
 * rpmfusion-free-updates: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
 * updates: mirror.corbina.net
 * updates-debuginfo: mirror.corbina.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox-4.0.i686 0:4.0.10_72479_fedora14-1 set to be updated
---> Package ffmpeg.i686 0:0.7-0.2.20110612git.fc15 set to be updated
---> Package ffmpeg-libs.i686 0:0.7-0.2.20110612git.fc15 set to be updated
--> Processing Dependency: libopenjpeg.so.3 for package: ffmpeg-libs-0.7-0.2.20110612git.fc15.i686
--> Processing Dependency: libva.so.1 for package: ffmpeg-libs-0.7-0.2.20110612git.fc15.i686
---> Package gstreamer-plugins-bad.i686 0:0.10.21-3.fc15 set to be updated
--> Processing Dependency: gstreamer-plugins-bad-free >= 0.10.21 for package: gstreamer-plugins-bad-0.10.21-3.fc15.i686
---> Package gstreamer-plugins-ugly.i686 0:0.10.18-1.fc15 set to be updated
---> Package libdvbpsi.i686 0:0.2.0-1.fc15 set to be updated
---> Package libquicktime.i686 0:1.2.2-2.fc15 set to be updated
---> Package libva-freeworld.i686 0:1.0.13-2.fc15 set to be updated
--> Processing Dependency: libva(x86-32) >= 1.0.13 for package: libva-freeworld-1.0.13-2.fc15.i686
--> Processing Dependency: libva-x11.so.1 for package: libva-freeworld-1.0.13-2.fc15.i686
--> Processing Dependency: libva.so.1 for package: libva-freeworld-1.0.13-2.fc15.i686
---> Package mplayer.i686 0:1.0-0.123.20110412svn.fc15 set to be updated
--> Processing Dependency: libbluray.so.0 for package: mplayer-1.0-0.123.20110412svn.fc15.i686
---> Package mplayer-common.i686 0:1.0-0.123.20110412svn.fc15 set to be updated
---> Package rpmfusion-free-release.noarch 0:16-0.1 set to be updated
--> Processing Dependency: system-release >= 16 for package: rpmfusion-free-release-16-0.1.noarch
---> Package vlc.i686 0:1.1.10-1.fc15 set to be updated
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-1.1.10-1.fc15.i686
---> Package vlc-core.i686 0:1.1.10-1.fc15 set to be updated
--> Processing Dependency: libva-x11.so.1 for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libva.so.1 for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libebml.so.3 for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libmatroska.so.3 for package: vlc-core-1.1.10-1.fc15.i686
---> Package x264-libs.i686 0:0.0.0-0.29.20110227.fc15 set to be updated
--> Running transaction check
---> Package ffmpeg-libs.i686 0:0.7-0.2.20110612git.fc15 set to be updated
--> Processing Dependency: libopenjpeg.so.3 for package: ffmpeg-libs-0.7-0.2.20110612git.fc15.i686
--> Processing Dependency: libva.so.1 for package: ffmpeg-libs-0.7-0.2.20110612git.fc15.i686
---> Package gstreamer-plugins-bad.i686 0:0.10.21-3.fc15 set to be updated
--> Processing Dependency: gstreamer-plugins-bad-free >= 0.10.21 for package: gstreamer-plugins-bad-0.10.21-3.fc15.i686
---> Package libbluray.i686 0:0.1-0.3.20101028gitc32862b77dea4.fc14 set to be installed
---> Package libva-freeworld.i686 0:1.0.13-2.fc15 set to be updated
--> Processing Dependency: libva(x86-32) >= 1.0.13 for package: libva-freeworld-1.0.13-2.fc15.i686
--> Processing Dependency: libva-x11.so.1 for package: libva-freeworld-1.0.13-2.fc15.i686
--> Processing Dependency: libva.so.1 for package: libva-freeworld-1.0.13-2.fc15.i686
---> Package rpmfusion-free-release.noarch 0:16-0.1 set to be updated
--> Processing Dependency: system-release >= 16 for package: rpmfusion-free-release-16-0.1.noarch
---> Package vlc.i686 0:1.1.10-1.fc15 set to be updated
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-1.1.10-1.fc15.i686
---> Package vlc-core.i686 0:1.1.10-1.fc15 set to be updated
--> Processing Dependency: libva-x11.so.1 for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libva.so.1 for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libebml.so.3 for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.15) for package: vlc-core-1.1.10-1.fc15.i686
--> Processing Dependency: libmatroska.so.3 for package: vlc-core-1.1.10-1.fc15.i686
--> Finished Dependency Resolution
Error: Package: gstreamer-plugins-bad-0.10.21-3.fc15.i686 (rpmfusion-free-rawhide)
           Requires: gstreamer-plugins-bad-free >= 0.10.21
           Installed: gstreamer-plugins-bad-free-0.10.20-3.fc14.1.i686 (@updates)
               gstreamer-plugins-bad-free = 0.10.20-3.fc14.1
           Available: gstreamer-plugins-bad-free-0.10.20-3.fc14.i686 (fedora)
               gstreamer-plugins-bad-free = 0.10.20-3.fc14
Error: Package: vlc-core-1.1.10-1.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libebml.so.3
Error: Package: vlc-core-1.1.10-1.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libva-x11.so.1
Error: Package: ffmpeg-libs-0.7-0.2.20110612git.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libva.so.1
Error: Package: libva-freeworld-1.0.13-2.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libva.so.1
Error: Package: vlc-1.1.10-1.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)
Error: Package: vlc-core-1.1.10-1.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libmatroska.so.3
Error: Package: rpmfusion-free-release-16-0.1.noarch (rpmfusion-free-rawhide)
           Requires: system-release >= 16
           Installed: fedora-release-14-1.noarch (@fedora/$releasever)
               system-release = 14-1
           Available: generic-release-14-0.2.noarch (fedora)
               system-release = 14-0.2
           Available: generic-release-14-1.noarch (updates)
               system-release = 14-1
Error: Package: vlc-core-1.1.10-1.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libstdc++.so.6(GLIBCXX_3.4.15)
Error: Package: vlc-core-1.1.10-1.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libva.so.1
Error: Package: libva-freeworld-1.0.13-2.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libva-x11.so.1
Error: Package: libva-freeworld-1.0.13-2.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libva(x86-32) >= 1.0.13
Error: Package: ffmpeg-libs-0.7-0.2.20110612git.fc15.i686 (rpmfusion-free-rawhide)
           Requires: libopenjpeg.so.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Kindly help me resolve this.

Thanking You

Regards
 
Old 06-27-2011, 11:32 PM   #2
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Original Poster
Rep: Reputation: 8
Why am I getting F15 Updates in F14 ?
 
Old 06-28-2011, 02:06 AM   #3
divyashree
Senior Member
 
Registered: Apr 2007
Location: bbsr,orissa,India
Distribution: RHEL5 ,RHEL4,CENT OS5,FEDORA,UBUNTU
Posts: 1,356

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by Genocide_Hoax View Post
Why am I getting F15 Updates in F14 ?
You have added external repository on your Fedora Box .

So it seems there are conflicts among the packages.

You just try to update using a sngle repo , with --enablerepo option.
 
Old 06-28-2011, 04:30 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,284

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
* rpmfusion-free-debuginfo: mirror.bjtu.edu.cn
* rpmfusion-free-rawhide: mirror.bjtu.edu.cn
* rpmfusion-free-rawhide-debuginfo: mirror.bjtu.edu.cn
* rpmfusion-free-source: mirror.bjtu.edu.cn


Solution : Change "enable=1" to "enable=0" for at least all ***-rawhide,
in /etc/yum.repos.d/rpmfusion-***

"rawhide" is not supposed to be used. Is for Fedora 15 (or 16)

( You may not be using **-debuginfo, **-source either.)
 
Old 06-30-2011, 11:20 PM   #5
Genocide_Hoax
Member
 
Registered: Apr 2011
Distribution: OpenSuse 12.3 , Slackware 13.1 ; Centos 6.2 ; Fedora 14
Posts: 90

Original Poster
Rep: Reputation: 8
Thanks a lot knudlf that did the trick for me..

---------- Post added 07-01-11 at 08:50 AM ----------

Thanks for your response Divya
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update transaction check errors & mirror errors tonycunn Linux - Software 2 11-29-2010 09:16 AM
[SOLVED] yum update errors faizlo Fedora 10 10-26-2010 04:09 AM
yum update errors in Fedora 9 maalamaal Linux - Newbie 3 02-14-2009 02:43 AM
Yum update errors gnjunior Fedora 4 01-17-2006 07:55 PM
yum update and up2date errors djljjm Linux - Newbie 1 02-12-2005 02:59 PM


All times are GMT -5. The time now is 08:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration