LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2012, 05:15 PM   #1
dmz1213
Member
 
Registered: Aug 2012
Posts: 40

Rep: Reputation: Disabled
yum stops working


Hello:
Any yum command shows the following errors:
# yum clean all
Loaded plugins: fastestmirror, refresh-packagekit, security, verify
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/yummain.py", line 254, in user_main
errcode = main(args)
File "/usr/share/yum-cli/yummain.py", line 88, in main
base.getOptionsConfig(args)
File "/usr/share/yum-cli/cli.py", line 192, in getOptionsConfig
self.conf
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 778, in <lambda>
conf = property(fget=lambda self: self._getConfig(),
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 283, in _getConfig
startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 466, in doPluginSetup
plugin_types, confpath, disabled_plugins, enabled_plugins)
File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 162, in __init__
self.run('config')
File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 179, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/verify.py", line 427, in config_hook
verify_callback=conduit._base.verify_plugins_cb))
AttributeError: 'YumBaseCli' object has no attribute 'verify_plugins_cb'

Environment:
CentOS Linux release 6.0 (Final)
2.6.32-71.el6.x86_64 #1 SMP Fri May 20 03:51:51 BST 2011 x86_64 x86_64 x86_64

Thanks
DMz
 
Old 12-18-2012, 08:46 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,354
Blog Entries: 55

Rep: Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541
What did you remove, install, update, configure before this error happened?
I'd download the original Yum and related packages and install with 'rpm' (note you may need to use some --force).
BTW you're missing 3 updates as Centos is at 6.3 now.
 
Old 12-19-2012, 01:09 AM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,107

Rep: Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478Reputation: 2478
this is looking like a python mis-match
Did you by chance "manually" install a DIFFERENT python than WAS installed

Also for the NOW VERY DEAD ( yes in caps) Centos 6.0
ALL and i do mean ALL of the repos were moved a long time ago to the archives

yum will not work on centos6.0 !!!!!!!!
That is
Unless YOU manually reconfigure the repo files to point to the archival "vault"

PLEASE stay current and install CentOS 6.3
 
1 members found this post helpful.
Old 12-20-2012, 01:16 PM   #4
dmz1213
Member
 
Registered: Aug 2012
Posts: 40

Original Poster
Rep: Reputation: Disabled
[SOLVED] yum does not work

I review /var/log.yum.log file, removed last few packages that i installed recently.
libmng-1.0.10-4.1.el6.x86_64
qt3-3.3.8b-30.el6.x86_64
pinentry-0.7.6-6.el6.x86_64
pinentry-qt-0.7.6-6.el6.x86_64
yum-plugin-verify-1.1.30-14.el6.noarch

yum is back to normal.
 
Old 12-20-2012, 01:51 PM   #5
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,354
Blog Entries: 55

Rep: Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541
AFAIK your libmng, qt and pinentry packages don't contain anything that could influence Python or Yum.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Feisty - Sound was working, but mysteriously stops working after reboot. woodsy934 Linux - Software 7 07-04-2011 06:39 PM
yum stops working z99 Linux - Newbie 1 12-06-2009 02:48 PM
__attribute__ ((weak)) suddenly stops working / starts working ta0kira Programming 3 08-15-2007 11:31 AM
"USB device stops working after a time" 'fix' stops cdrom device mount/readability adamben Slackware 6 04-18-2007 01:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration