LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-04-2009, 03:56 AM   #1
vkr0704
LQ Newbie
 
Registered: Feb 2009
Location: India
Posts: 25

Rep: Reputation: 15
yum server error


I configure my own YUM server on my home PC but when i try to install pakages from yum server i have rcved following error. (i can remove pakages but i cant install it.)

Pls help me

why this happning ?
Attached Thumbnails
Click image for larger version

Name:	YUM error.JPG
Views:	4
Size:	79.4 KB
ID:	100  
 
Old 02-04-2009, 04:10 AM   #2
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
The media url type is not supported, that is why. I think you can use ftp,http and file.

Last edited by datopdog; 02-04-2009 at 04:11 AM.
 
Old 02-04-2009, 04:36 AM   #3
vkr0704
LQ Newbie
 
Registered: Feb 2009
Location: India
Posts: 25

Original Poster
Rep: Reputation: 15
i create repository in /etc/yum.repos.d/base.repo

[Server]
name=server repository
baseurl=ftp://<ipaddress>/pub/Server
gpgcheck=0
enebled=1

[VT]
name=virtulasition repository
baseurl=ftp://<ipaddress>/pub/Server
gpgcheck=0
enebled=1

then i ON vsftpd using chkconfig
then restart vsftpd service

then i use createrepo command

any thing wrong in above code
also i try file & http but same error is comming
 
Old 02-04-2009, 04:43 AM   #4
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
Quote:
Originally Posted by vkr0704 View Post
i create repository in /etc/yum.repos.d/base.repo

[Server]
name=server repository
baseurl=ftp://<ipaddress>/pub/Server
gpgcheck=0
enebled=1

[VT]
name=virtulasition repository
baseurl=ftp://<ipaddress>/pub/Server
gpgcheck=0
enebled=1

then i ON vsftpd using chkconfig
then restart vsftpd service

then i use createrepo command

any thing wrong in above code
also i try file & http but same error is comming
Yes,
Code:
enebled=1
should be
Code:
enabled=1
and your ftp should point to where your repo is, and the web server should point to that as well.
 
Old 02-04-2009, 05:20 AM   #5
vkr0704
LQ Newbie
 
Registered: Feb 2009
Location: India
Posts: 25

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by datopdog View Post
Yes,
Code:
enebled=1
should be
Code:
enabled=1
and your ftp should point to where your repo is, and the web server should point to that as well.
i correct above but same error is comming
and also i succefully create yum server on other
machine using same (above) code
 
Old 02-04-2009, 05:41 AM   #6
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
what is the output of
Code:
grep -rn media /etc/yum*
 
Old 02-04-2009, 06:09 AM   #7
vkr0704
LQ Newbie
 
Registered: Feb 2009
Location: India
Posts: 25

Original Poster
Rep: Reputation: 15
Sorry
2day i m leaving
there is IMP work for me
2morro i will tell u
 
Old 02-04-2009, 06:12 AM   #8
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 216Reputation: 216Reputation: 216
Try going to /etc/yum.repos.d/media.repo and ensure enabled is set to 0 "enabled=0", if this is not the case then set it as such.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum server error vkr0704 Linux - Server 6 02-10-2009 05:50 AM
private yum server error vkr0704 Linux - General 1 02-04-2009 04:41 AM
Private YUM Server error vkr0704 Linux - Networking 1 02-04-2009 04:40 AM
yum config error parsing file failed - yum won't run emuub Linux - Software 9 11-04-2008 05:48 AM
Yum on FC6. 'yum update' error. mufy Fedora 8 06-14-2007 02:03 AM


All times are GMT -5. The time now is 04:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration