LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2014, 09:52 PM   #1
byran cheung
Member
 
Registered: Sep 2013
Posts: 321

Rep: Reputation: Disabled
yum package error


I use the command yum groupinstall "Development Tools" , it can install package successfully , but when I use yum groupinstall "phpmyadmin" , the error is as below , I would like to ask the error is due to the "Credentials" not register or phpmyadmin package is not specify ? how to install phpmyadmin ? thanks

<code>
==================================================================
Loaded plugins: downloadonly, fastestmirror, rhnplugin, security
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.
Error communicating with server. The message was:

Error Message:
Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.

Loading mirror speeds from cached hostfile
* CentOS-Base: centos.01link.hk
* CentOS-Plus: centos.01link.hk
* CentOS-Updates: centos.01link.hk
* base: centos.01link.hk
* epel: mirrors.ustc.edu.cn
* extras: centos.01link.hk
* updates: centos.01link.hk
Setting up Group Process
Checking for new repos for mirrors
Warning: Group phpmyadmin does not exist.
No packages in any requested group available to install or update
==================================================================
<\code>

When use the command yum install "phpmyadmin" , the error is as below .
<code>
==================================================================
Loaded plugins: downloadonly, fastestmirror, rhnplugin, security
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.
Error communicating with server. The message was:

Error Message:
Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.

Loading mirror speeds from cached hostfile
* CentOS-Base: centos.01link.hk
* CentOS-Plus: centos.01link.hk
* CentOS-Updates: centos.01link.hk
* base: centos.01link.hk
* epel: mirrors.ustc.edu.cn
* extras: centos.01link.hk
* updates: centos.01link.hk
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package phpMyAdmin3.noarch 0:3.5.8.1-1.el5 set to be updated
--> Processing Dependency: php53-php-gettext for package: phpMyAdmin3
--> Processing Dependency: php53-mysql for package: phpMyAdmin3
--> Processing Dependency: php53-mcrypt for package: phpMyAdmin3
--> Processing Dependency: php53-mbstring for package: phpMyAdmin3
--> Processing Dependency: php53-gd for package: phpMyAdmin3
--> Processing Dependency: php53 for package: phpMyAdmin3
--> Running transaction check
---> Package php53.x86_64 0:5.3.3-24.el5 set to be updated
--> Processing Dependency: php53-common = 5.3.3-24.el5 for package: php53
--> Processing Dependency: php53-cli = 5.3.3-24.el5 for package: php53
---> Package php53-gd.x86_64 0:5.3.3-24.el5 set to be updated
---> Package php53-mbstring.x86_64 0:5.3.3-24.el5 set to be updated
---> Package php53-mcrypt.x86_64 0:5.3.3-1.el5 set to be updated
---> Package php53-mysql.x86_64 0:5.3.3-24.el5 set to be updated
--> Processing Dependency: php53-pdo for package: php53-mysql
---> Package php53-php-gettext.noarch 0:1.0.11-3.el5 set to be updated
--> Running transaction check
---> Package php53-cli.x86_64 0:5.3.3-24.el5 set to be updated
---> Package php53-common.x86_64 0:5.3.3-24.el5 set to be updated
---> Package php53-pdo.x86_64 0:5.3.3-24.el5 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-24.el5.x86_64 from CentOS-Updates has depsolving problems
--> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
==================================================================
<\code>

Last edited by byran cheung; 10-09-2014 at 10:04 PM.
 
Old 10-10-2014, 01:00 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,371
Blog Entries: 6

Rep: Reputation: Disabled
Hi:

Try running this in the terminal as "root":-
Code:
Please run rhn_register as root on this client
I think if your not registered the repo's by default are disabled.

I could be wrong but it looks like the connection to the RHN or Satellite isn't establishing a connection.

On May 20th 2014, a new version of phpMyAdmin 4.2.2 has been released and comes with a minor crucial fixes and few important changes.
http://www.tecmint.com/install-phpmy...-fedora-17-12/

This article might help-
http://tecadmin.net/how-to-install-p...tos-using-yum/

Did trying these commands help?
Quote:
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
If that doesn't help you might want to call Red Hat Support directly-
http://www.redhat.com/en/services/support

Last edited by Ztcoracat; 10-10-2014 at 01:05 AM.
 
1 members found this post helpful.
Old 10-10-2014, 01:43 AM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Did you pay for subscription?
Redhat isn't free.
If you have a valid subscription, you also have support.

If you haven't paid for it you won't get updates.
Also you can try CentOS as it's free.
 
Old 10-10-2014, 02:39 AM   #4
byran cheung
Member
 
Registered: Sep 2013
Posts: 321

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by EDDY1 View Post
Did you pay for subscription?
Redhat isn't free.
If you have a valid subscription, you also have support.

If you haven't paid for it you won't get updates.
Also you can try CentOS as it's free.
Yes , I have pay for the valid subscription
 
Old 10-10-2014, 02:52 AM   #5
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,371
Blog Entries: 6

Rep: Reputation: Disabled
Red Hat Enterprise Linux versions before RHEL 7 will allow registration with RHN Classic, though RHEL 7 registration requires the newer subscription-manager (RHSM) method of registration.
Subscription manager and how to register Red Hat-
https://access.redhat.com/solutions/253273

https://access.redhat.com/solutions/8036

Last edited by Ztcoracat; 10-10-2014 at 02:54 AM. Reason: Link for RHN
 
1 members found this post helpful.
Old 10-10-2014, 02:56 AM   #6
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Is this a new OS?
It says you have to register it thats why you got the error.
Please run rhn_register as root on this client
https://access.redhat.com/documentat...-register.html
 
Old 10-10-2014, 04:09 AM   #7
byran cheung
Member
 
Registered: Sep 2013
Posts: 321

Original Poster
Rep: Reputation: Disabled
thanks reply ,

I will try https://access.redhat.com/documentat...-register.html , but I would like to confirm if this is error of RHN registration other caused by other reason ? thanks
 
Old 10-10-2014, 04:12 AM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Originally Posted by byran cheung View Post
thanks reply ,

I will try https://access.redhat.com/documentat...-register.html , but I would like to confirm if this is error of RHN registration other caused by other reason ? thanks
Which means you probably need to contact redhat to get it sorted out.
 
Old 10-10-2014, 02:59 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
one of the problems is the command you used
Quote:
yum groupinstall "phpmyadmin"
phpmyadnin IS NOT a "software group"

it is Nowhere in the group list of bulk groups to install
SEE:
Code:
su -
yum grouplist
do a normal everyday search to doublecheck spelling
then install it
Code:
su -
yum search php
-------- then from that long list - copy/paste 
yum install phpMyAdmin

also the OTHER big and might be by now UNFIXABLE
Quote:

Loading mirror speeds from cached hostfile
* CentOS-Base: centos.01link.hk
* CentOS-Plus: centos.01link.hk
* CentOS-Updates: centos.01link.hk
* base: centos.01link.hk
* epel: mirrors.ustc.edu.cn
* extras: centos.01link.hk
* updates: centos.01link.hk
you can NOT !!!!!!
not use the cent updates and base repos on RHEL!!!!!!!!!!!!
they WILL 100% WILL replace the redhat versions
cent makes the version numbers just a bit LARGER
so that MIGRATING is no issue

if you have mixed cent updates with RHN base
you have a problem


reinstalling would be the fastest fix

Last edited by John VV; 10-10-2014 at 03:05 PM.
 
Old 10-10-2014, 08:47 PM   #10
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,371
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
reinstalling would be the fastest fix
Thanks John VV!-


@byran cheung:
Did you add or otherwise modify your /etc/yum.repos.d/redhat.reo file? Or did you use the yum-config-manager to enable another repo? (trying to understand "how" this happened)
 
Old 10-13-2014, 06:25 AM   #11
byran cheung
Member
 
Registered: Sep 2013
Posts: 321

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
one of the problems is the command you used


phpmyadnin IS NOT a "software group"

it is Nowhere in the group list of bulk groups to install
SEE:
Code:
su -
yum grouplist
do a normal everyday search to doublecheck spelling
then install it
Code:
su -
yum search php
-------- then from that long list - copy/paste 
yum install phpMyAdmin

also the OTHER big and might be by now UNFIXABLE

you can NOT !!!!!!
not use the cent updates and base repos on RHEL!!!!!!!!!!!!
they WILL 100% WILL replace the redhat versions
cent makes the version numbers just a bit LARGER
so that MIGRATING is no issue

if you have mixed cent updates with RHN base
you have a problem


reinstalling would be the fastest fix
thanks reply ,

When run yum install phpMyAdmin , it pops the below error , would advise what is possible reason ? thanks

bash-3.2# yum install phpMyAdmin
Loaded plugins: downloadonly, fastestmirror, rhnplugin, security
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.
Error communicating with server. The message was:

Error Message:
Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.

Loading mirror speeds from cached hostfile
* CentOS-Base: centos.01link.hk
* CentOS-Plus: centos.01link.hk
* CentOS-Updates: centos.01link.hk
* base: centos.01link.hk
* epel: mirrors.hustunique.com
* extras: centos.01link.hk
* updates: centos.01link.hk
Setting up Install Process
Package matching phpMyAdmin-2.11.11.3-2.el5.noarch already installed. Checking for update.
Nothing to do
Loaded plugins: downloadonly, fastestmirror, rhnplugin, security
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.
Error communicating with server. The message was:

Error Message:
Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Explanation:
An error has occurred while processing your request. If this problem
persists please enter a bug report at bugzilla.redhat.com.
If you choose to submit the bug report, please be sure to include
details of what you were trying to do when this error occurred and
details on how to reproduce this problem.

Loading mirror speeds from cached hostfile
* CentOS-Base: centos.01link.hk
* CentOS-Plus: centos.01link.hk
* CentOS-Updates: centos.01link.hk
* base: centos.01link.hk
* epel: mirrors.hustunique.com
* extras: centos.01link.hk
* updates: centos.01link.hk
Setting up Install Process
Package matching phpMyAdmin-2.11.11.3-2.el5.noarch already installed. Checking for update.
Nothing to do
 
Old 10-15-2014, 06:16 AM   #12
byran cheung
Member
 
Registered: Sep 2013
Posts: 321

Original Poster
Rep: Reputation: Disabled
would advise what can I do for the above error ? thanks
 
Old 10-15-2014, 01:23 PM   #13
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware
Posts: 6,371
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by byran cheung View Post
would advise what can I do for the above error ? thanks
As John VV said:
Quote:
-:-reinstalling would be the fastest fix-:-
You can't mix CentOS repositories & RHN:-

--phpMyAdmin is already installed--
Quote:
Package matching phpMyAdmin-2.11.11.3-2.el5.noarch already installed.

Last edited by Ztcoracat; 10-15-2014 at 01:26 PM.
 
Old 10-15-2014, 02:23 PM   #14
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Quote:
Originally Posted by byran cheung View Post
would advise what can I do for the above error ? thanks
Please read the output. This isn't Windows where error messages just give you a useless code and some generic message like "General Error". Linux errors tell you what the problem is, so read it.

There are three parts of your output that are of interest:
Code:
There was an error communicating with RHN.
RHN Satellite or RHN Classic support will be disabled.
Error communicating with server. The message was:

Error Message:
Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid System Credentials.
Pretty self-explanatory, and has been answered numerous times earlier in this thread. Your RHEL credentials are invalid, and you need to run rhn_register as root in order to re-register.

Code:
Loading mirror speeds from cached hostfile
* CentOS-Base: centos.01link.hk
* CentOS-Plus: centos.01link.hk
* CentOS-Updates: centos.01link.hk
* base: centos.01link.hk
* epel: mirrors.hustunique.com
* extras: centos.01link.hk
* updates: centos.01link.hk
As you have already been told numerous times, you can't mix RHEL and CentOS repositories. These are two DIFFERENT distributions, you need to pick one. Either pay for RHEL and register it properly, or use CentOS instead, you CANNOT combine them.

Code:
Package matching phpMyAdmin-2.11.11.3-2.el5.noarch already installed. Checking for update.
Nothing to do
phpMyAdmin is clearly already installed on the system.

Last edited by suicidaleggroll; 10-15-2014 at 02:25 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while installing package through YUM sohail14s Linux - Newbie 3 02-21-2014 10:55 AM
error while installing package using yum sam_123 Linux - Server 1 06-27-2013 10:04 AM
yum error when update/download package mosen81 Linux - Newbie 6 06-08-2010 12:29 AM
yum - error on package download emuub Linux - Software 5 06-26-2007 03:21 AM
Yum Error: Transaction Check Error package x(which is newer than package y)... godsk Linux - Newbie 0 06-05-2006 08:13 AM


All times are GMT -5. The time now is 01:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration