LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-12-2011, 01:40 AM   #1
linuxque
LQ Newbie
 
Registered: Dec 2011
Posts: 3

Rep: Reputation: Disabled
Yum on rhel 4


Hi,
When i try to install some package with yum (2.0.8)on RHEL 4, it takes a lot of time and at the end, when I reboot it, well I will be having a new OS (CENTOS), but all the data remains safe.
Whats the reason and how to actually install packages thru yum

Thanks,
linuxque
 
Old 12-12-2011, 03:00 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
yum can't formally run yum on rhel4, it uses up2date instead. Yum was reverse engineered into CentOS 4 though, so you can use their repositories and yum builds, but as you've found, it will convert it to a CentOS system. If you don't use RHN in the first place though, you have no business running RHEL as opposed to CentOS anyway, so IF you want yum, you should be happy allowing it to convert to CentOS.
 
Old 12-12-2011, 04:43 AM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
DO NOT use RHEL4 unless this is on VERY old hardware( a server that has been running for the last 6+ years) that started running 4.0 years ago
RHEL4 is now at 4.9

it is going end of life, and hit the END of "production 2" support LAST FEBRUARY 11 months ago
and in 7 WEEKS it hits END OF NORMAL LIFE

it is time to upgrade the hardware running the server and install the current OS RHEL6.1 ( server support is $1299 per year )


https://access.redhat.com/support/po...pdates/errata/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CRITICAL:yum.cli Config Error yum.conf in RHEL 6.0 chunrima Linux - Software 2 12-09-2010 06:19 PM
how to update rhel 5 using centos yum updater without conflict with yum redhat plugin udayvikram Linux - Software 2 03-30-2010 08:15 AM
how to update rhel 5 using centos yum updater without conflict with yum redhat plugin udayvikram Linux - Newbie 1 03-29-2010 12:56 PM
yum and RHEL 5.1 bic Red Hat 3 06-12-2008 08:39 AM
Yum on RHEL Atmchicago Red Hat 2 07-29-2006 05:12 PM


All times are GMT -5. The time now is 10:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration