LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2011, 04:28 AM   #1
awww
Member
 
Registered: Nov 2010
Posts: 38

Rep: Reputation: Disabled
yum Missing Dependency with mplayer centos 5 server


Code:
Reducing CentOS-5 Testing to included packages only
Finished
2380 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mplayer.x86_64 0:1.0-0.46.svn20100703.el5.rf set to be updated
--> Processing Dependency: mplayer-fonts for package: mplayer
--> Processing Dependency: libtheora.so.0(libtheora.so.1.0)(64bit) for package: mplayer
--> Processing Dependency: libsmbclient.so.0()(64bit) for package: mplayer
--> Processing Dependency: libliveMedia.so.0()(64bit) for package: mplayer
--> Processing Dependency: liblirc_client.so.0()(64bit) for package: mplayer
--> Processing Dependency: libXss.so.1()(64bit) for package: mplayer
--> Processing Dependency: libass.so.4()(64bit) for package: mplayer
--> Processing Dependency: libXvMCW.so.1()(64bit) for package: mplayer
--> Processing Dependency: libtheora.so.0()(64bit) for package: mplayer
--> Processing Dependency: libmpg123.so.0()(64bit) for package: mplayer
--> Processing Dependency: libdca.so.0()(64bit) for package: mplayer
--> Processing Dependency: libXxf86dga.so.1()(64bit) for package: mplayer
--> Processing Dependency: libXvMC.so.1()(64bit) for package: mplayer
--> Processing Dependency: libfribidi.so.0()(64bit) for package: mplayer
--> Processing Dependency: libcdda_paranoia.so.0()(64bit) for package: mplayer
--> Processing Dependency: libaa.so.1()(64bit) for package: mplayer
--> Processing Dependency: libBasicUsageEnvironment.so.0()(64bit) for package: mplayer
--> Processing Dependency: libartsc.so.0()(64bit) for package: mplayer
--> Processing Dependency: libmng.so.1()(64bit) for package: mplayer
--> Processing Dependency: libUsageEnvironment.so.0()(64bit) for package: mplayer
--> Processing Dependency: libcdda_interface.so.0()(64bit) for package: mplayer
--> Processing Dependency: libgroupsock.so.0()(64bit) for package: mplayer
--> Processing Dependency: libcaca.so.0()(64bit) for package: mplayer
--> Processing Dependency: libenca.so.0()(64bit) for package: mplayer
--> Processing Dependency: libvga.so.1()(64bit) for package: mplayer
--> Processing Dependency: liblzo2.so.2()(64bit) for package: mplayer
--> Running transaction check
---> Package aalib.x86_64 0:1.4.0-5.2.el4.rf set to be updated
--> Processing Dependency: libslang-utf8.so.1()(64bit) for package: aalib
---> Package arts.x86_64 8:1.5.4-1 set to be updated
--> Processing Dependency: libqt-mt.so.3()(64bit) for package: arts
---> Package cdparanoia-libs.x86_64 0:alpha9.8-27.2 set to be updated
---> Package enca.x86_64 0:1.10-1.el5.rf set to be updated
---> Package fribidi.x86_64 0:0.10.7-5.1 set to be updated
---> Package libXScrnSaver.x86_64 0:1.1.0-3.1 set to be updated
---> Package libXvMC.x86_64 0:1.0.2-2.1 set to be updated
---> Package libXxf86dga.x86_64 0:1.0.1-3.1 set to be updated
---> Package libass.x86_64 0:0.9.11-1.el5.rf set to be updated
---> Package libcaca.x86_64 0:0.99-0.5.beta16.el5 set to be updated
--> Processing Dependency: libglut.so.3()(64bit) for package: libcaca
---> Package libdca.x86_64 0:0.0.5-1.el5.rf set to be updated
---> Package libmng.x86_64 0:1.0.9-5.1 set to be updated
--> Processing Dependency: liblcms.so.1()(64bit) for package: libmng
---> Package libsmbclient.x86_64 0:3.0.33-3.29.el5_6.2 set to be updated
---> Package libtheora.x86_64 0:1.0alpha7-1 set to be updated
---> Package lirc.x86_64 0:0.6.6-4.2.el4.rf set to be updated
---> Package live555.x86_64 0:0-0.27.2010.04.09.el5.rf set to be updated
---> Package mpg123.x86_64 0:1.13.3-1.el5.rf set to be updated
---> Package mplayer.x86_64 0:1.0-0.46.svn20100703.el5.rf set to be updated
--> Processing Dependency: liblzo2.so.2()(64bit) for package: mplayer
---> Package mplayer-fonts.noarch 0:1.1-3.0.rf set to be updated
---> Package svgalib.x86_64 0:1.9.25-3.el5 set to be updated
--> Running transaction check
---> Package compat-slang.x86_64 0:1.4.9-27.2.2 set to be updated
---> Package freeglut.x86_64 0:2.4.0-7.1.el5 set to be updated
---> Package lcms.x86_64 0:1.18-0.1.beta1.el5_3.2 set to be updated
---> Package mplayer.x86_64 0:1.0-0.46.svn20100703.el5.rf set to be updated
--> Processing Dependency: liblzo2.so.2()(64bit) for package: mplayer
---> Package qt.x86_64 1:3.3.6-23.el5 set to be updated
--> Finished Dependency Resolution
mplayer-1.0-0.46.svn20100703.el5.rf.x86_64 from dag has depsolving problems
  --> Missing Dependency: liblzo2.so.2()(64bit) is needed by package mplayer-1.0-0.46.svn20100703.el5.rf.x86_64 (dag)
Error: Missing Dependency: liblzo2.so.2()(64bit) is needed by package mplayer-1.0-0.46.svn20100703.el5.rf.x86_64 (dag)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
how can i fix this issue please its doing this with both mencoder and mplayer
 
Old 06-29-2011, 04:35 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well lzo is available just fine in rpmforge, but you're just using a dag repository, which would, as I understand it, be included in rpmforge as a whole. Install the rpmforge repo package and try again: http://rpmrepo.org/RPMforge/Using
 
Old 06-29-2011, 04:46 AM   #3
awww
Member
 
Registered: Nov 2010
Posts: 38

Original Poster
Rep: Reputation: Disabled
i have all repositorys installed and its still giving me this error i really don't understand
 
Old 06-29-2011, 04:49 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
"ALL" of them??? lzo is in rpmforge. If you just want to get it installed, just download the rpm directly.
 
Old 06-29-2011, 04:53 AM   #5
awww
Member
 
Registered: Nov 2010
Posts: 38

Original Poster
Rep: Reputation: Disabled
Package lzo-1.08-3.el5.art.x86_64 already installed and latest version
Nothing to do
so that's installed
 
Old 06-29-2011, 04:57 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well that's lzo 1.... try lzo2. Actually, I don't know what it's actually called as a package name. Well it still is called lzo...


[chris@thinkpad ~]$ rpm -qi lzo
Name : lzo
Version : 2.03
Release : 4.fc15
Architecture: x86_64
Install Date: Sun 05 Jun 2011 09:16:27 BST
Group : System Environment/Libraries
Size : 158334
License : GPLv2+
Signature : RSA/SHA256, Wed 09 Feb 2011 11:19:33 GMT, Key ID b4ebf579069c8460
Source RPM : lzo-2.03-4.fc15.src.rpm
Build Date : Tue 08 Feb 2011 15:01:26 GMT
Build Host : x86-05.phx2.fedoraproject.org
Relocations : (not relocatable)
Packager : Fedora Project
Vendor : Fedora Project
URL : http://www.oberhumer.com/opensource/lzo/
Summary : Data compression library with very fast (de)compression
Description :

and it's that version you need, as it's looking for lzo.so.2

http://pkgs.org/download/centos-5-rh...86_64.rpm.html
 
Old 06-29-2011, 05:01 AM   #7
awww
Member
 
Registered: Nov 2010
Posts: 38

Original Poster
Rep: Reputation: Disabled
could you please tell me what commands i should use to install this thanks
 
Old 06-29-2011, 05:12 AM   #8
awww
Member
 
Registered: Nov 2010
Posts: 38

Original Poster
Rep: Reputation: Disabled
nvm i figured it out thanks for your help man
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum update PHP on CentOS - missing dependency php-common AndyMillne Linux - Server 7 05-21-2013 07:34 AM
Missing dependency error with yum arie0008 Red Hat 6 10-30-2010 12:03 PM
Missing Dependency - yum hectorDUQUE Fedora 6 06-29-2008 09:33 PM
How to tell yum missing dependency is actually there decrepit Fedora 2 02-04-2007 06:36 AM
yum missing dependencY puppet Linux - Software 6 10-26-2005 11:20 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration