LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-10-2008, 02:59 AM   #16
Styles
LQ Newbie
 
Registered: Aug 2008
Posts: 15

Original Poster
Rep: Reputation: 0

root@fast [~]# yum repolist
z
Usage: yum [options] <update | upgrade | install | info | remove | list |
clean | provides | search | check-update | groupinstall | groupupdate |
grouplist >

Options:
-c [config file] - specify the config file to use
-e [error level] - set the error logging level
-d [debug level] - set the debugging level
-y answer yes to all questions
-t be tolerant about errors in package commands
-R [time in minutes] - set the max amount of time to randomly run in.
-C run from cache only - do not update the cache
--installroot=[path] - set the install root (default '/')
--version - output the version of yum
--exclude=some_pkg_name - packagename to exclude - you can use
this more than once
--download-only - only download packages - do not run the transaction
-h, --help this screen


No repolist
my Yum is 2.0.7
 
Old 08-10-2008, 03:05 AM   #17
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Asx per post #2, what distro/version are you running?
 
Old 08-10-2008, 03:20 AM   #18
Styles
LQ Newbie
 
Registered: Aug 2008
Posts: 15

Original Poster
Rep: Reputation: 0
CentOS 5.2 / 2.0.7 YUM
 
Old 08-10-2008, 03:21 AM   #19
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,362

Rep: Reputation: 171Reputation: 171
Centos 5 uses yum 3.XXXX. RHEL5 also use 3.xxx. As well as all the other RHEL5 clones. You cannot mix a repo from one distro+version with another distro+version.

So what distro+version are you running?

Edit: IF you are really running Centos5.2 how and why did you downgrade yum?

Last edited by lazlow; 08-10-2008 at 03:23 AM.
 
Old 08-10-2008, 03:55 AM   #20
Styles
LQ Newbie
 
Registered: Aug 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lazlow View Post
Centos 5 uses yum 3.XXXX. RHEL5 also use 3.xxx. As well as all the other RHEL5 clones. You cannot mix a repo from one distro+version with another distro+version.



So what distro+version are you running?

Edit: IF you are really running Centos5.2 how and why did you downgrade yum?
LOL didn't know I did, probably at one point for something I really don't know :P
 
Old 08-10-2008, 04:06 AM   #21
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Are you sure on the release? From one of my earlier posts, the mirror you were looking for was at best a RH9 repo. Can you post

cat /etc/redhat-release

Something seems to be off in the yum parameters to the repo file
 
Old 08-10-2008, 04:34 AM   #22
Styles
LQ Newbie
 
Registered: Aug 2008
Posts: 15

Original Poster
Rep: Reputation: 0
CentOS release 5.2 (Final)
 
Old 08-12-2008, 02:59 AM   #23
Styles
LQ Newbie
 
Registered: Aug 2008
Posts: 15

Original Poster
Rep: Reputation: 0
So.. any ideas on how to fix?
 
Old 08-12-2008, 03:10 AM   #24
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
I'd be trying to re-install yum from the DVD
 
Old 08-12-2008, 03:12 PM   #25
Styles
LQ Newbie
 
Registered: Aug 2008
Posts: 15

Original Poster
Rep: Reputation: 0
omg lol how? Its not sitting next to me.. the box is like 500 miles away.. rofl ...
 
Old 08-12-2008, 04:24 PM   #26
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
http://mirror.centos.org/centos/5/os/i386/CentOS/ or similar (depends on your arch
 
Old 09-20-2011, 12:45 PM   #27
netbaby
LQ Newbie
 
Registered: Sep 2011
Posts: 11

Rep: Reputation: Disabled
Dear all,

I got a similar problem with Styles

I use Fedora Core 3. The error content is:

[root@localhost yum-2.0.7]# yum update
Gathering header information file(s) from server(s)
Server: Red Hat Linux 3 - i386 - Base
retrygrab() failed for:
http://mirror.dulug.duke.edu/pub/yum...rs/header.info
Executing failover method
failover: out of servers to try
Error getting file
http://mirror.dulug.duke.edu/pub/yum...rs/header.info
[Errno 4] IOError: <urlopen error >

[root@localhost yum-2.0.7]# yum repolist
z
Usage: yum [options] <update | upgrade | install | info | remove | list |
clean | provides | search | check-update | groupinstall | groupupdate |
grouplist >

Options:
-c [config file] - specify the config file to use
-e [error level] - set the error logging level
-d [debug level] - set the debugging level
-y answer yes to all questions
-t be tolerant about errors in package commands
-R [time in minutes] - set the max amount of time to randomly run in.
-C run from cache only - do not update the cache
--installroot=[path] - set the install root (default '/')
--version - output the version of yum
--exclude=some_pkg_name - packagename to exclude - you can use
this more than once
--download-only - only download packages - do not run the transaction
-h, --help this screen



Could you tell me why? How to resolve this problem?

Thank you very much
 
Old 09-20-2011, 03:36 PM   #28
John VV
Guru
 
Registered: Aug 2005
Posts: 12,698

Rep: Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687Reputation: 1687
netbaby
PLEASE do not drag up a old thread from 2008

also it is of no surprise that fedora 3 ( YES fedora 3) is not working
it hit it's " End Of Life" in Nov. 2006
there have been NO UPDATES to it since 2006

yum will NEVER work on fedora 3
install the current version
fedora 15 you are 12 versions OUT OF DATE

Quote:
Could you tell me why? How to resolve this problem?
you DO NOT !
There is NO solution .

you install supported version
fedora 15 is current
 
  


Reply

Tags
error, found, http, ioerror, yum


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem after yum yum yum (delicious) alaios Fedora 3 01-14-2009 02:34 AM
Help!! Yum Ioerror? sean_zhang Linux - Software 2 01-12-2009 07:15 PM
yum config error parsing file failed - yum won't run emuub Linux - Software 9 11-04-2008 05:48 AM
Yum Problem - /var/cache/yum/base/primary.xml.gz:1 ice99 Linux - Software 0 12-15-2005 01:08 PM
Yum Errors in parsing, whats wrong here (yum.conf pasted) thejokker Linux - Newbie 1 06-15-2004 02:28 AM


All times are GMT -5. The time now is 01:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration