LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-13-2011, 03:10 AM   #1
Bronta
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Rep: Reputation: Disabled
Yum - installing Zend server - problem with dependencies


Hi everyone,

I am trying to install Zend Server on my VPS, which runs CentOS 6.0 64 bit. I am using guide posted here - http://files.zend.com/help/Zend-Serv...stallation.htm, but both manual and automatic installation methods give me following error during installation:

Code:
Error: Package: php-devel-5.3.8-1.el6.art.x86_64 (@atomic)
           Requires: php(x86-64) = 5.3.8-1.el6.art
           Removing: php-5.3.8-1.el6.art.x86_64 (@atomic)
               php(x86-64) = 5.3.8-1.el6.art
           Obsoleted By: mod-php-5.3-apache2-zend-server-5.3.8-50.x86_64 (Zend)
               Not found
           Available: php-5.2.17-1.el6.art.x86_64 (atomic)
               php(x86-64) = 5.2.17-1.el6.art
           Available: php-5.3.2-6.el6.x86_64 (base)
               php(x86-64) = 5.3.2-6.el6
           Available: php-5.3.2-6.el6_0.1.x86_64 (updates)
               php(x86-64) = 5.3.2-6.el6_0.1
           Available: php-5.3.6-2.el6.art.x86_64 (atomic)
               php(x86-64) = 5.3.6-2.el6.art
           Available: php-5.3.6-3.el6.art.x86_64 (atomic)
               php(x86-64) = 5.3.6-3.el6.art
 You could try using --skip-broken to work around the problem
live555-0-0.27.2010.04.09.el6.rf.x86_64 is a duplicate with live555-0-0.20.2008.07.25.el5.i386
xvidcore-1.2.2-1.el6.rf.x86_64 is a duplicate with xvidcore-1.1.3-4.el5.i386
Zend Server Installation was not completed. See yum output above for detailed error information.
Full log from putty - http://pastebin.com/XVukW3bD

I tried using the --skip-broken option in yum, it skipped the errors but it did not install anything at all.

Any suggestions how to fix this?

Thanks for the help.
 
Old 10-13-2011, 04:07 AM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,093

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
it looks like you are mixing redhat 5 and the very different redhat 6 rpms

read the error
Red Hat 5 = el5
Red Hat 6 = el6

uninstall ALL red hat 5 rpms first before you do anything
also you are mixing the 5 32 bit and the 6 64 bit rpms
not a good idea

also KEEP in mind that "rpmforge-extras" IS INCOMPATIBLE with the base centos6 install
it WILL replace needed system files with different versions .
so be VERY careful with it .

"rpmforge" is fine it is the EXTRAS repo that is not

run this to find any installed 5 rpms on your 6 install
Code:
su -
rpm -qa | grep el5
if a long list and you want a text file of it
Code:
rpm -qa | grep el5 > ~/rh5.txt
will be in your HOME folder
 
Old 10-13-2011, 05:53 AM   #3
Bronta
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks for your answer, the command
Code:
rpm -qa | grep el5
gave me this answer:
Code:
[root@vm1891 ~]# rpm -qa | grep el5
gpac-libs-0.4.5-0.7.20080217cvs.el5.x86_64
mencoder-1.0-0.101.20080903svn.el5.1.x86_64
flvtool2-1.0.6-4.el5.noarch
libdca-0.0.5-3.el5.x86_64
xvidcore-1.1.3-4.el5.i386
live555-0-0.20.2008.07.25.el5.i386
mplayer-1.0-0.101.20080903svn.el5.1.i386
mplayer-1.0-0.101.20080903svn.el5.1.x86_64
libdca-0.0.5-3.el5.i386
faad2-libs-2.6.1-5.el5.x86_64
faad2-libs-2.6.1-5.el5.i386
x264-libs-0.0.0-0.15.20080613.el5.x86_64
I still cannot figure out where the problem why the installation does not proceed is exactly. Is it in the message about the duplicate packages or in the message:

Code:
Error: Package: php-devel-5.3.8-1.el6.art.x86_64 (@atomic)
           Requires: php(x86-64) = 5.3.8-1.el6.art
           Removing: php-5.3.8-1.el6.art.x86_64 (@atomic)
               php(x86-64) = 5.3.8-1.el6.art
I do not get this message, it requires 5.3.8-1.el6.art but php-5.3.8-1.el6.art.x86_64 is installed?
 
Old 10-13-2011, 03:44 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,093

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
Quote:
I still cannot figure out where the problem why the installation does not proceed is exactly. Is it in the message about the duplicate packages or in the message:
because you have programs installed for rhel5 on rhel6 ( cent 6 )

most 99% of el5 programs will not work on el6 ( some will and do work )

at some point YOU installed programs for 5 on a 6 install

you need to uninstall the 5 versions and replace them with the 6 version


it is possible in that blindly fallowing a old "how to" you are installing the 5 versions of programs


but the el5 mostly look related to mplayer - you installed mplayer for the wrong Operating System


- the fix ( should be ) --
uninstall all the el5 rpms
Code:
su -yum remove ??????
fill in the ?????? with the full name
example ( this one you installed BOTH the 32 bit AND the 64 bit -- not good )
Code:
su -
yum remove mplayer-1.0-0.101.20080903svn.el5.1.i386
and do that for ALL the el5's
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem installing Apache, cycles between two dependencies procfs Linux - Newbie 2 12-04-2008 03:39 AM
Installing yum - Endless failed dependencies NinetyFive Linux - Newbie 9 01-26-2008 11:02 AM
failed dependencies when installing telnet server Deosatyakam Linux - Networking 1 10-03-2006 09:59 PM
need help installing xine, dependencies problem=libvorbis g-string 3 Debian 6 05-23-2005 06:06 AM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration