LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-17-2009, 01:24 PM   #1
rajatjpatel
LQ Newbie
 
Registered: Feb 2007
Posts: 7
Blog Entries: 1

Rep: Reputation: 0
yum install vlc


Hello there,

if any one can give solutions for the same i m using a RHEL 5.X on my laptop presario c700 i trying to install vlc player on the same for my training video which work on vlc this wht following error i m getting if any one can help on this

rajat


[root@rajat ~]# su
[root@rajat ~]# uname -r
2.6.18-128.1.1.el5
[root@rajat ~]# uname -a
Linux rajat 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:59:00 EST 2009 i686 i686 i386 GNU/Linux
[root@rajat ~]# yum install vlc
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package vlc.i386 0:0.9.8a-1.el5.rf set to be updated
--> Processing Dependency: libartsc.so.0 for package: vlc
--> Processing Dependency: libfribidi.so.0 for package: vlc
--> Processing Dependency: libml.so.1 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libvgagl.so.1 for package: vlc
--> Processing Dependency: libzvbi.so.0 for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libavcodec.so.51 for package: vlc
--> Processing Dependency: libSDL_image-1.2.so.0 for package: vlc
--> Processing Dependency: libcv.so.1 for package: vlc
--> Processing Dependency: libpostproc.so.51 for package: vlc
--> Processing Dependency: libavformat.so.51 for package: vlc
--> Processing Dependency: libgsm.so.1 for package: vlc
--> Processing Dependency: libdvbpsi.so.4 for package: vlc
--> Processing Dependency: libhighgui.so.1 for package: vlc
--> Processing Dependency: libupnp.so.3 for package: vlc
--> Processing Dependency: libcvaux.so.1 for package: vlc
--> Processing Dependency: libvga.so.1 for package: vlc
--> Processing Dependency: libcddb.so.2 for package: vlc
--> Processing Dependency: libshout.so.3 for package: vlc
--> Processing Dependency: libmatroska.so.0 for package: vlc
--> Processing Dependency: libQtGui.so.4 for package: vlc
--> Processing Dependency: libebml.so.0 for package: vlc
--> Processing Dependency: libixml.so.2 for package: vlc
--> Processing Dependency: libxosd.so.2 for package: vlc
--> Processing Dependency: libdvdnav.so.4 for package: vlc
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libcxcore.so.1 for package: vlc
--> Processing Dependency: libavutil.so.49 for package: vlc
--> Processing Dependency: libx264.so.55 for package: vlc
--> Processing Dependency: liblirc_client.so.0 for package: vlc
--> Processing Dependency: libQtCore.so.4 for package: vlc
--> Running transaction check
---> Package ffmpeg-libpostproc.i386 0:0.4.9-0.9.20070530.el5.rf set to be updated
---> Package libdvdnav.i386 0:0.1.10-3.el5.rf set to be updated
---> Package ffmpeg.i386 0:0.4.9-0.9.20070530.el5.rf set to be updated
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg
--> Processing Dependency: libx264.so.55 for package: ffmpeg
---> Package zvbi.i386 0:0.2.33-1.el5.rf set to be updated
---> Package libupnp.i386 0:1.6.6-1.el5.rf set to be updated
---> Package arts.i386 8:1.5.4-1 set to be updated
---> Package dirac.i386 0:1.0.2-1.el5.rf set to be updated
--> Processing Dependency: libcppunit-1.12.so.0 for package: dirac
---> Package opencv.i386 0:1.0.0-1.el5.rf set to be updated
---> Package xosd.i386 0:2.2.14-1.el5.rf set to be updated
---> Package libmatroska.i386 0:0.8.1-1.el5.rf set to be updated
---> Package libcddb.i386 0:1.3.0-1.el5.rf set to be updated
---> Package gsm.i386 0:1.0.12-1.el5.rf set to be updated
---> Package svgalib.i386 0:1.9.25-1.el5.rf set to be updated
---> Package lirc.i386 0:0.6.6-4.el5.rf set to be updated
---> Package vlc.i386 0:0.9.8a-1.el5.rf set to be updated
--> Processing Dependency: libfribidi.so.0 for package: vlc
--> Processing Dependency: libdvbpsi.so.4 for package: vlc
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libx264.so.55 for package: vlc
---> Package libebml.i386 0:0.7.8-1.el5.rf set to be updated
---> Package libshout.i386 0:2.2.2-1.el5.rf set to be updated
---> Package qt4.i386 0:4.2.1-1 set to be updated
---> Package SDL_image.i386 0:1.2.5-1.el5.rf set to be updated
--> Running transaction check
---> Package ffmpeg.i386 0:0.4.9-0.9.20070530.el5.rf set to be updated
--> Processing Dependency: libx264.so.55 for package: ffmpeg
---> Package cppunit.i386 0:1.12.0-3.el5.rf set to be updated
---> Package imlib2.i386 0:1.4.0-1.el5.rf set to be updated
---> Package vlc.i386 0:0.9.8a-1.el5.rf set to be updated
--> Processing Dependency: libfribidi.so.0 for package: vlc
--> Processing Dependency: libdvbpsi.so.4 for package: vlc
--> Processing Dependency: libcucul.so.0 for package: vlc
--> Processing Dependency: libx264.so.55 for package: vlc
--> Finished Dependency Resolution
vlc-0.9.8a-1.el5.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libx264.so.55 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
vlc-0.9.8a-1.el5.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libfribidi.so.0 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
vlc-0.9.8a-1.el5.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libcucul.so.0 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
vlc-0.9.8a-1.el5.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libdvbpsi.so.4 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
ffmpeg-0.4.9-0.9.20070530.el5.rf.i386 from rpmforge has depsolving problems
--> Missing Dependency: libx264.so.55 is needed by package ffmpeg-0.4.9-0.9.20070530.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libx264.so.55 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libfribidi.so.0 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libcucul.so.0 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libx264.so.55 is needed by package ffmpeg-0.4.9-0.9.20070530.el5.rf.i386 (rpmforge)
Error: Missing Dependency: libdvbpsi.so.4 is needed by package vlc-0.9.8a-1.el5.rf.i386 (rpmforge)
[root@rajat ~]#
 
Old 03-17-2009, 04:48 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,405

Rep: Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529
Quote:
Originally Posted by rajatjpatel View Post
Hello there,

if any one can give solutions for the same i m using a RHEL 5.X on my laptop presario c700 i trying to install vlc player on the same for my training video which work on vlc this wht following error i m getting if any one can help on this

rajat


[root@rajat ~]# su
[root@rajat ~]# uname -r
2.6.18-128.1.1.el5
[root@rajat ~]# uname -a
Linux rajat 2.6.18-128.1.1.el5 #1 SMP Mon Jan 26 13:59:00 EST 2009 i686 i686 i386 GNU/Linux
[root@rajat ~]# yum install vlc
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
Did you not read the error message??? It says quite clearly:

Quote:
There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
Did you run it???
 
Old 03-17-2009, 09:23 PM   #3
JaksoDebr
Member
 
Registered: Mar 2009
Distribution: Fedora, Slackware
Posts: 104

Rep: Reputation: 21
You also have to consider that RedHat does not provide non-free codecs for legal reasons. Check out the missing from another repository, like livna.org, that has specialized in non-free codecs. See their website for details.

JD

Linux Archive

Last edited by JaksoDebr; 04-02-2009 at 05:18 AM.
 
Old 03-18-2009, 12:41 AM   #4
hariarr
LQ Newbie
 
Registered: Mar 2009
Posts: 10

Rep: Reputation: 0
if you'r not using registrd. version of rhel, redhat wont provide you yup repo support (i think so)
so

go to
/etc/yum.repos.d

and add a third party repo ther..

(such as CentOS)

Am not sure that it z d rite solution.... but try it...

Rock On!!
LiNuX RuLeZ
 
Old 03-18-2009, 01:00 AM   #5
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Rep: Reputation: 15
Quote:
Check out the missing from another repository, like livna.org, that has specialized in non-free codecs. See their website for details.
Try adding rpmfusion to you repositories as follows

open terminal

Quote:
sudo -c 'rpm -Uhv http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-2.noarch.rpm'


sudo -c 'rpm -Uvh http://download1.rpmfusion.org/free/el/updates/testing/5/i386/rpmfusion-free-release-5-0.1.noarch.rpm http://download1.rpmfusion.org/nonfree/el/updates/testing/5/i386/rpmfusion-nonfree-release-5-0.1.noarch.rpm'

Now run yum update and yum -y install vlc

Last edited by ps_sabu; 03-18-2009 at 02:00 PM. Reason: typo
 
Old 03-18-2009, 10:27 AM   #6
rajatjpatel
LQ Newbie
 
Registered: Feb 2007
Posts: 7
Blog Entries: 1

Original Poster
Rep: Reputation: 0
Hi there,

I'm using legal copy of RHEL 5.x and all the error i have read 2 time and try to deploy all rpm one by one but still it was give the same error and some of them got install. Rajat
 
Old 03-18-2009, 10:28 AM   #7
rajatjpatel
LQ Newbie
 
Registered: Feb 2007
Posts: 7
Blog Entries: 1

Original Poster
Rep: Reputation: 0
hi ps sabu...

after running a about link this is a following error i m getting
rpm -Uhv http://download.fedora.redhat.com/pu...5-2.noarch.rpm
Retrieving http://download.fedora.redhat.com/pu...5-2.noarch.rpm
error: skipping http://download.fedora.redhat.com/pu...5-2.noarch.rpm - transfer failed - Unknown or unexpected error
warning: u 0x9f64268 ctrl 0xa616ad8 nrefs != 0 (download.fedora.redhat.com http)
[root@rajat ~]#
 
Old 03-18-2009, 12:32 PM   #8
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,405

Rep: Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529Reputation: 2529
Quote:
Originally Posted by rajatjpatel View Post
hi ps sabu...

after running a about link this is a following error i m getting
rpm -Uhv http://download.fedora.redhat.com/pu...5-2.noarch.rpm
Retrieving http://download.fedora.redhat.com/pu...5-2.noarch.rpm
error: skipping http://download.fedora.redhat.com/pu...5-2.noarch.rpm - transfer failed - Unknown or unexpected error
warning: u 0x9f64268 ctrl 0xa616ad8 nrefs != 0 (download.fedora.redhat.com http)
[root@rajat ~]#
I asked in my first post, if you ran this command, as it was said in your error message the first time:

Quote:
There are unfinished transactions remaining. You mightconsider running yum-complete-transaction first to finish them.
DID YOU RUN IT?
 
Old 03-18-2009, 02:10 PM   #9
ps_sabu
Member
 
Registered: Nov 2006
Location: Kerala, South India
Distribution: Ubuntu 12.10, Ultimate Edition 3.5, OZ Unity 3.0 Black Opal
Posts: 117

Rep: Reputation: 15
Quote:
Originally Posted by rajatjpatel View Post
hi ps sabu...

after running a about link this is a following error i m getting
rpm -Uhv http://download.fedora.redhat.com/pu...5-2.noarch.rpm
Retrieving http://download.fedora.redhat.com/pu...5-2.noarch.rpm
error: skipping http://download.fedora.redhat.com/pu...5-2.noarch.rpm - transfer failed - Unknown or unexpected error
warning: u 0x9f64268 ctrl 0xa616ad8 nrefs != 0 (download.fedora.redhat.com http)
[root@rajat ~]#
Hi Rajath,

What you ran were not complete commands. In posting them I forgot to turn of the " Automatically parsing links " Option. Hence What i posted appeared as links instead of full commands. Thats why you got error message.I am now posting full commands. You must copy and paste in the terminal with,


open terminal

sudo -c 'rpm -Uhv http://download.fedora.redhat.com/pub/epel/5/i386/epel-release-5-2.noarch.rpm'


sudo -c 'rpm -Uvh http://download1.rpmfusion.org/free/el/updates/testing/5/i386/rpmfusion-free-release-5-0.1.noarch.rpm'

sudo -c 'rpm -Uvh http://download1.rpmfusion.org/nonfree/el/updates/testing/5/i386/rpmfusion-nonfree-release-5-0.1.noarch.rpm'



Now run yum -y install vlc

Last edited by ps_sabu; 03-18-2009 at 02:19 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to install vlc using yum command av.dubey Linux - Newbie 13 11-12-2009 10:19 PM
VLC yum installed from rpmforge doesn't work ? utw-mephisto Linux - Software 2 02-19-2009 05:42 AM
simple vlc yum install error alabamaman Linux - Software 1 09-11-2007 01:33 PM
vlc yum install failure alabamaman Linux - Newbie 12 07-19-2007 07:31 PM
yum problem while installing vlc in RedHat FC4 g_srinivas Linux - Software 1 07-20-2005 10:18 PM


All times are GMT -5. The time now is 03:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration