LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2014, 02:24 PM   #1
skoda
Member
 
Registered: Jun 2013
Posts: 111

Rep: Reputation: Disabled
Yum Error: File contains no section headers.


Hello,

centos 6.5

i am suddenly getting this error when try to install anything.

Quote:
[root@localhost ~]# yum install vlc
Loaded plugins: fastestmirror, protectbase, refresh-packagekit, security
Error: File contains no section headers.
 
Old 03-10-2014, 02:38 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
can you post the output of
Code:
su -
yum repolist all
vlc1 is in rpmforge
there is a new vlc2 but "protectbase" will lock that out
 
Old 03-10-2014, 03:07 PM   #3
skoda
Member
 
Registered: Jun 2013
Posts: 111

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
can you post the output of
Code:
su -
yum repolist all
vlc1 is in rpmforge
there is a new vlc2 but "protectbase" will lock that out
Hai john,

Quote:
[root@localhost ~]#yum repolist all


Loaded plugins: fastestmirror, protectbase, refresh-packagekit, security
Error: File contains no section headers.
file: file://///etc/yum.repos.d/fedora-cinnamon.repo, line: 1
'<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">\n'
 
Old 03-10-2014, 04:22 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,090

Rep: Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474Reputation: 2474
??? What the heck did you do ??????
Quote:
file://///etc/yum.repos.d/fedora-cinnamon.repo
that is a custom FEDORA20 repo

you can NOT use a fedora repo file on cent !!!!
REMOVE IT ASAP !

that is at least part of the problem

the other is you have ZERO software repos installed
besides the very incompatible thing
that looks like a html document you renamed to .repo

there should NEVER !!! be a php encoded HTML header
Code:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
in a repo file


just HOW ?????
did you manage to do this ?
as in what did you do ?

this is the current cent 6.x repo listing
http://mirrors.arsc.edu/centos/6/upd...1.2.x86_64.rpm
after you remove that think pretending to be a software repo text file
manually install this rpm using rpm

or
in the firefox download dialog there is a option to INSTALL it

install it !

Last edited by John VV; 03-10-2014 at 04:26 PM.
 
Old 03-13-2014, 02:05 PM   #5
skoda
Member
 
Registered: Jun 2013
Posts: 111

Original Poster
Rep: Reputation: Disabled
Deleted

Last edited by skoda; 03-13-2014 at 03:27 PM.
 
Old 03-13-2014, 03:26 PM   #6
skoda
Member
 
Registered: Jun 2013
Posts: 111

Original Poster
Rep: Reputation: Disabled
Thank you john VV,

Finally problem fixed!!! all i did is :

Quote:
sudo gedit /etc/yum.repos.d/fedorautils.repo
Deleted everything in the file and added the following :

Quote:
[fedorautils]
name=Fedora Utils
type=rpm-md
baseurl=http://download.opensuse.org/repositories/home:/satya164:/fedorautils/Fedora_$releasever/
gpgkey=http://download.opensuse.org/repositories/home:/satya164:/fedorautils/Fedora_$releasever/repodata/repomd.xml.key
gpgcheck=1
enabled=1
metadata_expire=1d
skip_if_unavailable=1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] yum problem: section headers missing jarco Linux - Distributions 12 01-29-2013 08:51 PM
Yum headers error message kaplan71 Fedora 2 09-27-2012 05:09 PM
[SOLVED] Section 6.7. Linux-2.6.37 API Headers make error steviebob Linux From Scratch 7 09-30-2011 01:46 PM
yum config error parsing file failed - yum won't run emuub Linux - Software 9 11-04-2008 05:48 AM
yum configuration file headers problems akasantos Fedora 0 12-23-2003 12:03 PM


All times are GMT -5. The time now is 07:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration