LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2009, 07:04 AM   #1
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Rep: Reputation: 15
Talking Yum does not update firefox in terminal.


What do i need to do?

[root@localhost ~]# yum install firefox
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: firefox
Nothing to do
[root@localhost ~]# yum remove firefox
Loading "installonlyn" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package firefox.i386 0:1.5.0.9-10.el5 set to be erased
--> Running transaction check
Setting up repositories
Reading repository metadata in from local files
--> Processing Dependency: libxpcom_core.so for package: yelp
--> Processing Dependency: gecko-libs = 1.8.0.9 for package: yelp
--> Processing Dependency: libgtkembedmoz.so for package: yelp
--> Processing Dependency: libxpcom.so for package: yelp
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package yelp.i386 0:2.16.0-13.el5 set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Removing:
firefox i386 1.5.0.9-10.el5 installed 36 M
Removing for dependencies:
yelp i386 2.16.0-13.el5 installed 1.9 M

Transaction Summary
=============================================================================
Install 0 Package(s)
Update 0 Package(s)
Remove 2 Package(s)

Is this ok [y/N]: n
Exiting on user Command
Complete!
[root@localhost ~]# yum update firefox
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Reading repository metadata in from local files
Could not find update match for firefox
No Packages marked for Update/Obsoletion
[root@localhost ~]#
 
Old 08-05-2009, 07:16 AM   #2
zQUEz
Member
 
Registered: Jun 2007
Distribution: Fedora, RHEL, Centos
Posts: 294

Rep: Reputation: 54
Is this a RHEL5 server per your tag? When you installed it, did you register it with RHN? If not, then you won't have any active yum repositories and thus no packages available for install. You can test this by the following:
Code:
yum clean all
yum list
Did you get a list of any packages available at all?
 
Old 08-05-2009, 07:22 AM   #3
karamarisan
Member
 
Registered: Jul 2009
Location: Illinois, US
Distribution: Fedora 11
Posts: 374

Rep: Reputation: 55
Looks like not - isn't there a plugin we'd see if this was an RHN'd system? OP, can we get `yum repolist`? Highly related to what zQUEz suggested.
 
Old 08-08-2009, 04:24 AM   #4
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
yum list all

returns


tlock.i386 1.4-2.el5 epel
tlock-devel.i386 1.4-2.el5 epel
tmda.noarch 1.1.12-1.el5 epel
tmda-emacs.noarch 1.1.12-1.el5 epel
tmda-ofmipd.noarch 1.1.12-1.el5 epel
tokyocabinet.i386 1.4.9-1.el5 epel
tokyocabinet-devel.i386 1.4.9-1.el5 epel
tomcat-native.i386 1.1.16-1.el5 epel
toped.i386 0.9.2-2.el5 epel
tor.i386 0.2.0.34-5.el5 epel
tor-core.i386 0.2.0.34-5.el5 epel
tor-lsb.i386 0.2.0.34-5.el5 epel
touchcal.i386 0.31-1.el5 epel
towhee.i386 6.2.6-1.el5 epel
towhee-common.i386 6.2.6-1.el5 epel
towhee-doc.i386 6.2.6-1.el5 epel
towhee-examples.i386 6.2.6-1.el5 epel
towhee-mpi.i386 6.2.6-1.el5 epel
trac.noarch 0.10.5-2.el5 epel
trac-bazaar-plugin.noarch 0.2-5.20070829bzr182.e epel
trac-git-plugin.noarch 0.0.1-5.20090628svn336 epel
trac-iniadmin-plugin.noarch 0.1-2.20071126svn2824. epel
trac-mercurial-plugin.noarch 0.10.0.3-1.20080318svn epel
trac-monotone-plugin.noarch 0.0.14-1.20080208mtnb4 epel
trac-peerreview-plugin.noarch 0.10-1.svn5357.el5 epel
trac-privateticketsplugin.noarch 1.1.1-0.2.svn5068.el5 epel
trac-spamfilter-plugin.noarch 0.2.1-0.2.20080603svn6 epel
trac-ticketdelete-plugin.noarch 1.1.4-1.20071126svn282 epel
trac-webadmin.noarch 0.1.2-0.3.dev_r4429.el epel
trac-xmlrpc-plugin.noarch 0.1-0.3.r2892.el5 epel
translate-toolkit.noarch 1.2.0-2.el5 epel
translate-toolkit-devel.noarch 1.2.0-2.el5 epel
transmission.i386 1.34-1.el5 epel
tre.i386 0.7.5-1.el5 epel
tre-devel.i386 0.7.5-1.el5 epel
trickle.i386 1.07-7.el5 epel
tripwire.i386 2.4.1.1-1.el5 epel
trousers.i386 0.3.1-5.el5 epel
trousers-devel.i386 0.3.1-5.el5 epel
trousers-static.i386 0.3.1-5.el5 epel
tryton.noarch 1.0.5-1.el5 epel
trytond.noarch 1.0.5-1.el5 epel
trytond-openoffice.noarch 1.0.5-1.el5 epel
trytond-webdav.noarch 1.0.5-1.el5 epel
ttywatch.i386 0.14-7.el5.1 epel
ttywatch-devel.i386 0.14-7.el5.1 epel
tunctl.i386 1.5-2.el5 epel
turba.noarch 2.2.1-1.el5 epel
twinkle.i386 1.4.2-2.el5 epel
txt2man.noarch 1.5.5-1.el5 epel
txt2tags.noarch 2.5-5.el5 epel
typespeed.i386 0.6.5-1.el5 epel
tzdata-java.noarch 2007k-0.3.el5 epel
ucarp.i386 1.5-1.el5 epel
ucview.i386 0.23-2.el5 epel
udns.i386 0.0.9-3.el5 epel
udns-devel.i386 0.0.9-3.el5 epel
udpcast.i386 20071228-4.el5 epel
udunits.i386 1.12.4-11.el5.1 epel
udunits-devel.i386 1.12.4-11.el5.1 epel
ultimatestunts.i386 0.7.5-2.el5 epel
unbound.i386 1.2.1-1.el5 epel
unbound-devel.i386 1.2.1-1.el5 epel
unbound-libs.i386 1.2.1-1.el5 epel
unbound-munin.i386 1.2.1-1.el5 epel
unclutter.i386 8-2.el5 epel
unicap.i386 0.9.5-1.el5 epel
unicap-devel.i386 0.9.5-1.el5 epel
unison213.i386 2.13.16-9.el5.2 epel
unison227.i386 2.27.57-7.el5.2 epel
unpaper.i386 0.3-1.el5 epel
unshield.i386 0.5-6.el5 epel
unshield-devel.i386 0.5-6.el5 epel
up-imapproxy.i386 1.2.6-1.el5 epel
uread.i386 0-0.19981218.el5 epel
uriparser.i386 0.7.1-6.el5 epel
uriparser-devel.i386 0.7.1-6.el5 epel
ushare.i386 1.0-4.el5 epel
ustr.i386 1.0.4-6.el5 epel
ustr-debug.i386 1.0.4-6.el5 epel
ustr-debug-static.i386 1.0.4-6.el5 epel
ustr-devel.i386 1.0.4-6.el5 epel
ustr-static.i386 1.0.4-6.el5 epel
uuid.i386 1.5.1-3.el5 epel
uuid-c++.i386 1.5.1-3.el5 epel
uuid-c++-devel.i386 1.5.1-3.el5 epel
uuid-dce.i386 1.5.1-3.el5 epel
uuid-dce-devel.i386 1.5.1-3.el5 epel
uuid-devel.i386 1.5.1-3.el5 epel
uuid-perl.i386 1.5.1-3.el5 epel
uuid-pgsql.i386 1.5.1-3.el5 epel
uuid-php.i386 1.5.1-3.el5 epel
uw-imap.i386 2007e-1.el5 epel
uw-imap-devel.i386 2007e-1.el5 epel
uw-imap-static.i386 2007e-1.el5 epel
uw-imap-utils.i386 2007e-1.el5 epel
vala.i386 0.5.2-4.el5 epel
vala-devel.i386 0.5.2-4.el5 epel
vala-doc.i386 0.5.2-4.el5 epel
vala-tools.i386 0.5.2-4.el5 epel
varnish.i386 2.0.4-1.el5 epel
varnish-libs.i386 2.0.4-1.el5 epel
varnish-libs-devel.i386 2.0.4-1.el5 epel
vbindiff.i386 3.0-0.2.beta4.el5 epel
vblade.i386 14-3.el5 epel
vhd2vl.i386 2.0-3.el5 epel
vidalia.i386 0.1.13-2.el5 epel
vidalia-doc.i386 0.1.13-2.el5 epel
viewmtn.noarch 0.10-1.el5 epel
viewvc.noarch 1.0.8-1.el5 epel
virt-top.i386 1.0.1-7.el5 epel
virtaal.noarch 0.2-3.el5 epel
vnc-ltsp-config.noarch 4.0-4.el5 epel
vnstat.i386 1.6-1.el5 epel
vpnc.i386 0.4.0-2.el5 epel
vpnc-consoleuser.i386 0.4.0-2.el5 epel
vttest.i386 20071216-3.el5 epel
vtun.i386 3.0.1-3.el5 epel
vym.i386 1.10.0-4.el5 epel
wannier90.i386 1.1-4.el5 epel
wannier90-devel.i386 1.1-4.el5 epel
wavpack.i386 4.50.1-2.el5 epel
wavpack-devel.i386 4.50.1-2.el5 epel
wcstools.i386 3.7.0-1.el5 epel
websec.noarch 1.9.0-3.5 epel
websvn.noarch 2.2.1-1.el5 epel
weechat.i386 0.2.6-1.el5 epel
wesnoth.i386 1.2.8-3.el5 epel
wesnoth-server.i386 1.2.8-3.el5 epel
wesnoth-tools.i386 1.2.8-3.el5 epel
wgrib.i386 1.8.0.12o-2.el5 epel
wgrib2.i386 1.7.2b-1.el5 epel
whatmask.i386 1.2-4.el5 epel
wiggle.i386 0.6-3.el5 epel
windowlab.i386 1.34-6.el5 epel
wine-devel.i386 1.0.1-1.el5 epel
wine-docs.noarch 1.0-1.el5 epel
wmacpi.i386 2.2-0.2.rc1.el5 epel
wmix.i386 3.1-2.el5 epel
wol.i386 0.7.1-2.el5 epel
wordpress.noarch 2.8.3-1.el5 epel
wordpress-mu.noarch 2.7-5.el5 epel
wordpress-mu-plugin-add-to-any.noarch 0.9.9.2.3-1.el5 epel
wordpress-mu-plugin-add-to-any-subscribe 0.9.6.4.1-1.el5 epel
wordpress-mu-plugin-defaults.noarch 1.2.3-3.el5 epel
wordpress-plugin-add-to-any.noarch 0.9.9.2.3-1.el5 epel
wordpress-plugin-add-to-any-i18n.noarch 0.9.9.2.3-1.el5 epel
wordpress-plugin-add-to-any-subscribe.no 0.9.6.4.1-1.el5 epel
wordpress-plugin-add-to-any-subscribe-i1 0.9.6.4.1-1.el5 epel
wv.i386 1.2.4-4.el5 epel
wv-devel.i386 1.2.4-4.el5 epel
wv2.i386 0.2.3-3.el5 epel
wv2-devel.i386 0.2.3-3.el5 epel
wxBase.i386 2.8.9-2.el5 epel
wxGTK.i386 2.8.9-2.el5 epel
wxGTK-devel.i386 2.8.9-2.el5 epel
wxGTK-gl.i386 2.8.9-2.el5 epel
wxMaxima.i386 0.7.6-1.el5 epel
wxPython.i386 2.8.7.1-2.el5 epel
wxPython-devel.i386 2.8.7.1-2.el5 epel
xa.i386 2.3.5-3.el5 epel
xalan-c.i386 1.10.0-2.el5 epel
xalan-c-devel.i386 1.10.0-2.el5 epel
xalan-c-doc.i386 1.10.0-2.el5 epel
xar.i386 1.5-1.el5 epel
xar-devel.i386 1.5-1.el5 epel
xautolock.i386 2.2-5.el5 epel
xbae.i386 4.60.4-8.el5 epel
xbae-devel.i386 4.60.4-8.el5 epel
xbase.i386 2.0.0-6.el5 epel
xbase-devel.i386 2.0.0-6.el5 epel
xbiso.i386 0.6.1-1.el5 epel
xbsql.i386 0.11-9.el5 epel
xbsql-devel.i386 0.11-9.el5 epel
xchm.i386 1.13-1.el5 epel
xcircuit.i386 3.4.30-1.el5 epel
xclip.i386 0.10-2.el5 epel
xdg-utils.noarch 1.0.2-4.el5 epel
xdialog.i386 2.3.1-3.el5 epel
xdrfile.i386 1.1-2.el5 epel
xdrfile-devel.i386 1.1-2.el5 epel
xenwatch.i386 0.5.3-3.el5 epel
xerces-c.i386 2.7.0-7.el5 epel
xerces-c-devel.i386 2.7.0-7.el5 epel
xerces-c-doc.i386 2.7.0-7.el5 epel
xforms.i386 1.0.90-8.el5 epel
xforms-devel.i386 1.0.90-8.el5 epel
xgnokii.i386 0.6.27-2.el5 epel
xgrep.i386 0.07-1.el5 epel
xgridedit.i386 4.3.1-2.el5 epel
xhtml2ps.noarch 1.0-0.1.b5.el5.1 epel
xine-lib.i386 1.1.16.3-2.el5.1 epel
xine-lib-arts.i386 1.1.16.3-2.el5.1 epel
xine-lib-devel.i386 1.1.16.3-2.el5.1 epel
xine-lib-extras.i386 1.1.16.3-2.el5.1 epel
xkeycaps.i386 2.46-6.el5.1 epel
xl2tpd.i386 1.2.4-2.el5 epel
xlcrack.i386 1.2-2.el5 epel
xloadimage.i386 4.1-2.el5 epel
xml-security-c.i386 1.5.1-1.el5 epel
xml-security-c-devel.i386 1.5.1-1.el5 epel
xmltoman.noarch 0.3-2.el5 epel
xorg-x11-drv-openchrome.i386 0.2.903-1.el5 epel
xorg-x11-drv-openchrome-devel.i386 0.2.903-1.el5 epel
xpa.i386 2.1.8-3.el5 epel
xpa-devel.i386 2.1.8-3.el5 epel
xpa-libs.i386 2.1.8-3.el5 epel
xpa-tcl.i386 2.1.8-3.el5 epel
xpdf.i386 1:3.02-13.el5 epel
xprobe2.i386 0.3-8.el5.1 epel
xqilla.i386 2.0.0-1.1.el5 epel
xqilla-devel.i386 2.0.0-1.1.el5 epel
xqilla-doc.i386 2.0.0-1.1.el5 epel
xsettings-kde.i386 0.6-3.el5 epel
xsupplicant.i386 1.2.8-3.el5 epel
xsupplicant-devel.i386 1.2.8-3.el5 epel
xteddy.i386 2.0.1-2.el5.1 epel
xvarstar.i386 0.9-4.el5 epel
xwota.i386 0.4-6.el5 epel
xz.i386 4.999.8-0.7.beta.el5.1 epel
xz-devel.i386 4.999.8-0.7.beta.el5.1 epel
xz-libs.i386 4.999.8-0.7.beta.el5.1 epel
xz-lzma-compat.i386 4.999.8-0.7.beta.el5.1 epel
yafc.i386 1.1.1-6.el5 epel
yasm.i386 0.7.1-1.el5 epel
yasm-devel.i386 0.7.1-1.el5 epel
yaz.i386 2.1.54-1.el5.1 epel
ykclient.i386 2.2-1.el5 epel
ykclient-devel.i386 2.2-1.el5 epel
yum-arch.noarch 2.2.2-2.el5 epel
yum-cron.noarch 0.6-1.el5 epel
yumex.noarch 2.0.5-3.el5 epel
zabbix.i386 1.4.6-1.el5 epel
zabbix-agent.i386 1.4.6-1.el5 epel
zabbix-web.i386 1.4.6-1.el5 epel
zaptel.i386 1.4.12.1-1.el5 epel
zaptel-devel.i386 1.4.12.1-1.el5 epel
zaptel-lib.i386 1.4.12.1-1.el5 epel
zaptel-utils.i386 1.4.12.1-1.el5 epel
zerofree.i386 1.0.1-5.el5 epel
zeroinstall-injector.noarch 0.38-2.el5 epel
zikula-module-MultiHook.noarch 5.0-4.el5 epel
zikula-module-crpTag.noarch 0.1.3-3.el5 epel
znc.i386 0.072-3.el5 epel
znc-devel.i386 0.072-3.el5 epel
zope.i386 2.10.7-1.el5 epel
zziplib.i386 0.13.49-1.el5.1 epel
zziplib-devel.i386 0.13.49-1.el5.1 epel
zziplib-utils.i386 0.13.49-1.el5.1 epel


My system is not registered with RHN.

But, i wish to upgrade my firefox using yum, is there any such repository which offers firefox updates

or if configutring yum for CENTOS will do the thinghs as i wish, because i have read somewhere on web that CENTOS repo is a good substitute for RHN?
 
Old 08-10-2009, 06:14 AM   #5
zQUEz
Member
 
Registered: Jun 2007
Distribution: Fedora, RHEL, Centos
Posts: 294

Rep: Reputation: 54
Centos is the Red Hat packages just rebranded. So yes, Centos would be a good substitute. I have read recently on this board of a way to point your Red Hat server to a Centos repository so it can get Yum updates. Do a search on this forum. Personally, I would just reinstall Centos than try and play yum-repo-games. If you aren't going to buy a Red Hat license, then don't use their package.
 
Old 08-10-2009, 07:11 AM   #6
jeromeNP7
Member
 
Registered: Jun 2009
Posts: 101

Rep: Reputation: 19
The quick solution would be to download the RPM file from the Mozilla site and install it with 'rpm' directly.

Linux

Last edited by jeromeNP7; 09-04-2009 at 10:28 PM.
 
Old 08-10-2009, 07:17 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Yeah you could enable CentOS repositories and install FF. Another way to do would be download the tarball from website and unpack it and use it.
 
Old 08-10-2009, 12:25 PM   #8
redhat5
Member
 
Registered: Jul 2009
Posts: 50

Original Poster
Rep: Reputation: 15
I downloaded the .tar.bz2 file and unpacked it, but could not use it further.

I did not find the further instructions. There is no configure file or makefile.
 
Old 08-10-2009, 12:27 PM   #9
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Arch
Posts: 8,527

Rep: Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898Reputation: 898
in the directory where you untarred the file, you need to execute firefox to start it
Code:
$ firefox/firefox
In general you untar the file to opt
to start firefox
Code:
$ /opt/firefox/firefox

Last edited by repo; 08-10-2009 at 12:29 PM.
 
Old 08-10-2009, 02:06 PM   #10
fpmurphy
Member
 
Registered: Jan 2009
Location: /dev/ph
Distribution: Fedora, Ubuntu, Redhat, Centos
Posts: 297

Rep: Reputation: 62
Quote:
Originally Posted by karamarisan View Post
Looks like not - isn't there a plugin we'd see if this was an RHN'd system?
You could try running /usr/sbin/rhn_check. If you are registered it will access RHN and retieve any updates that are scheduled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum question: How to update from backed up yum cache? Arodef Linux - Software 2 02-03-2010 12:42 AM
installing and try to update firefox with yum kashif2131971 Linux - Software 1 07-18-2009 05:11 PM
installing and try to update firefox with yum kashif2131971 Linux - Software 4 07-09-2009 03:26 PM
erased yum.conf by forced yum-update in RHEL5.3, need help curiocurio Red Hat 3 04-21-2009 04:33 AM
FC4: yum update firefox - missing deps dtmax Linux - Software 2 02-25-2006 01:52 PM


All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration