LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-15-2012, 07:56 AM   #1
veeruk101
Member
 
Registered: Mar 2005
Distribution: Ubuntu 12.04 LTS
Posts: 249

Rep: Reputation: 16
Yum conflicts for 32 and 64 bit versions of a package


I'm trying to run Skype, which is 32 bit, on my 64 bit Fedora system where it came preinstalled. I try to run it and get "bash: /usr/bin/skype: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory". So I look into it and realize I need to install some 32 bit dependencies, and end up getting the following error when I run "sudo yum install alsa-lib.i686 libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686":

Code:
Error: Package: glibc-2.15-35.fc17.i686 (fedora)
           Requires: glibc-common = 2.15-35.fc17
           Installed: glibc-common-2.15-37.fc17.x86_64 (@updates-testing)
               glibc-common = 2.15-37.fc17
           Available: glibc-common-2.15-35.fc17.x86_64 (fedora)
               glibc-common = 2.15-35.fc17
I don't know much about what's going on here, but it looks like it won't let me install the 32 bit version of glibc-common, which is needed by Skype, because the 64 bit version already exists. So that confuses me, any ideas how I could solve this issue? Thanks.
 
Old 05-15-2012, 08:03 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
it's not that it's already installed, more likely that it's a different version. I would downgrade that package back to the -35 version - why did you enable updates-testing? - and then the i686 package should also install fine.
 
1 members found this post helpful.
Old 05-15-2012, 08:09 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,632

Rep: Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267
The is no glibc-common.i686 for the 64bits OS.

Suggest : # yum install glibc.i686

... And then reboot, to make sure that everything is in place.

Considerations :
It can be an OS error / package error, that it asks for glibc-common.
Fedora 17 is not yet quite up to release standard.
EDIT : Beaten by acid_kewpie : The testing repo is a No No.

.

Last edited by knudfl; 05-15-2012 at 08:10 AM.
 
1 members found this post helpful.
Old 05-15-2012, 08:18 AM   #4
veeruk101
Member
 
Registered: Mar 2005
Distribution: Ubuntu 12.04 LTS
Posts: 249

Original Poster
Rep: Reputation: 16
I'm not sure how updates-testing was enabled, as I didn't do it manually. I just installed this OS, maybe it was part of the installation as this is a beta. So I tried downgrading both glibc and glibc-common, and got the following:

Code:
$ sudo yum downgrade glibc-common
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package glibc-common.x86_64 0:2.15-35.fc17 will be a downgrade
--> Processing Dependency: glibc = 2.15-35.fc17 for package: glibc-common-2.15-35.fc17.x86_64
---> Package glibc-common.x86_64 0:2.15-37.fc17 will be erased
--> Running transaction check
---> Package glibc.i686 0:2.15-35.fc17 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.15-35.fc17.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.15-35.fc17.i686
---> Package glibc-common.x86_64 0:2.15-37.fc17 will be erased
--> Running transaction check
---> Package glibc-common.x86_64 0:2.15-37.fc17 will be erased
---> Package nss-softokn-freebl.i686 0:3.13.4-2.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.15-37.fc17.x86_64 (@updates-testing)
           Requires: glibc-common = 2.15-37.fc17
           Removing: glibc-common-2.15-37.fc17.x86_64 (@updates-testing)
               glibc-common = 2.15-37.fc17
           Downgraded By: glibc-common-2.15-35.fc17.x86_64 (fedora)
               glibc-common = 2.15-35.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Code:
$ sudo yum downgrade glibc
Loaded plugins: langpacks, presto, refresh-packagekit

Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.15-35.fc17 will be a downgrade
--> Processing Dependency: glibc-common = 2.15-35.fc17 for package: glibc-2.15-35.fc17.x86_64
---> Package glibc.x86_64 0:2.15-37.fc17 will be erased
--> Finished Dependency Resolution
Error: Package: glibc-common-2.15-37.fc17.x86_64 (@updates-testing)
           Requires: glibc = 2.15-37.fc17
           Removing: glibc-2.15-37.fc17.x86_64 (@updates-testing)
               glibc = 2.15-37.fc17
           Downgraded By: glibc-2.15-35.fc17.x86_64 (fedora)
               glibc = 2.15-35.fc17
Error: Package: glibc-2.15-35.fc17.x86_64 (fedora)
           Requires: glibc-common = 2.15-35.fc17
           Installed: glibc-common-2.15-37.fc17.x86_64 (@updates-testing)
               glibc-common = 2.15-37.fc17
           Available: glibc-common-2.15-35.fc17.x86_64 (fedora)
               glibc-common = 2.15-35.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I also tried "yum install glibc.i686" and got the following:

Code:
$ sudo yum install glibc.i686
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.15-35.fc17 will be installed
--> Processing Dependency: glibc-common = 2.15-35.fc17 for package: glibc-2.15-35.fc17.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.15-35.fc17.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.15-35.fc17.i686
--> Running transaction check
---> Package glibc.i686 0:2.15-35.fc17 will be installed
--> Processing Dependency: glibc-common = 2.15-35.fc17 for package: glibc-2.15-35.fc17.i686
---> Package nss-softokn-freebl.i686 0:3.13.4-2.fc17 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.15-35.fc17.i686 (fedora)
           Requires: glibc-common = 2.15-35.fc17
           Installed: glibc-common-2.15-37.fc17.x86_64 (@updates-testing)
               glibc-common = 2.15-37.fc17
           Available: glibc-common-2.15-35.fc17.x86_64 (fedora)
               glibc-common = 2.15-35.fc17
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Any other things I could try?
 
Old 05-15-2012, 08:24 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016 CentOS6.9 CentOS7.3 + 50+ other Linux OS, for test only.
Posts: 16,632

Rep: Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267Reputation: 3267
Quote:
Installed: glibc-common-2.15-37.fc17.x86_64 (@updates-testing)
...
Any other things I could try ?
Yes. Disable the "updates-testing.repo" !
 
1 members found this post helpful.
Old 05-15-2012, 08:29 AM   #6
veeruk101
Member
 
Registered: Mar 2005
Distribution: Ubuntu 12.04 LTS
Posts: 249

Original Poster
Rep: Reputation: 16
When I check the /etc/yum.repos.d/fedora-updates-testing.repo file, under "[updates-testing]" enabled is set to 0, so it is already disabled. It was never explicitly enabled with a "--enablerepo=updates-testing", which is why I'm confused how it happened as I just installed the OS. Any way to get rid of the mess that updates-testing has done here?
 
Old 05-15-2012, 08:35 AM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
you're nearly there... put the glibc AND glibc-common packages on the SAME yum command. you can see they depend on each other, so do them together
 
1 members found this post helpful.
Old 05-15-2012, 08:41 AM   #8
veeruk101
Member
 
Registered: Mar 2005
Distribution: Ubuntu 12.04 LTS
Posts: 249

Original Poster
Rep: Reputation: 16
Quote:
you're nearly there... put the glibc AND glibc-common packages on the SAME yum command. you can see they depend on each other, so do them together
That allowed me to downgrade, thanks. Now when I run the original yum command to install Skype's dependencies, I get the following output near the end of it:

Code:
Error: Protected multilib versions: libstdc++-4.7.0-4.fc17.i686 != libstdc++-4.7.0-5.fc17.x86_64
Error: Protected multilib versions: libpciaccess-0.13-2.fc17.i686 != libpciaccess-0.13.1-1.fc17.x86_64
Error: Protected multilib versions: libgcc-4.7.0-4.fc17.i686 != libgcc-4.7.0-5.fc17.x86_64
Error: Protected multilib versions: libxcb-1.8-2.fc17.i686 != libxcb-1.8.1-1.fc17.x86_64
Error: Protected multilib versions: libdrm-2.4.33-1.fc17.i686 != libdrm-2.4.33-3.fc17.x86_64
Error: Protected multilib versions: mesa-libGL-8.0.2-2.fc17.i686 != mesa-libGL-8.0.2-7.fc17.x86_64
Error: Protected multilib versions: mesa-libglapi-8.0.2-2.fc17.i686 != mesa-libglapi-8.0.2-7.fc17.x86_64
Error: Protected multilib versions: krb5-libs-1.10-5.fc17.i686 != krb5-libs-1.10-6.fc17.x86_64
Should I do the same downgrade command for all of the above? So that for example with libstdc++ being 4.7.0.4 vs 4.7.0.5, they'll both be 4.7.0.4 but one will be i686 and the other x86_64? Thanks.
 
Old 05-15-2012, 08:45 AM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
well those appear to be from updates-testing again. so *I* would suggest downgrading again. this guy enabled testing on the other side of the fence though - http://www.leenukes.co.uk/?p=455
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Installing 32 bit RPMs on 64 bit Linux conflicts with 64 bit packages gheibia Linux - Server 1 08-18-2011 01:33 AM
having yum dependency conflicts on centos 5.5 with 32bit vs 64 bit humpy Linux - Newbie 3 03-06-2011 07:04 AM
yum - Package Conflicts revof11 Fedora 5 04-24-2007 06:28 AM
FC3, 64-bit multilib, with many yum update conflicts sgl Fedora 2 06-04-2005 09:42 PM
yum conflicts ezy Linux - Newbie 6 04-18-2005 06:57 AM


All times are GMT -5. The time now is 02:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration