LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2012, 08:39 AM   #1
mohitvad
Member
 
Registered: Feb 2010
Posts: 34

Rep: Reputation: 0
yum client error


Hi,

I am getting an error while running the yum list command. Below is the error and my repo file.

[root@localhost ~]# yum list all
Loaded plugins: fastestmirror
Determining fastest mirrors
local | 1.3 kB 00:00
local/primary | 922 B 00:00
http://172.20.3.32/centos/5/i386/rep...rimary.xml.gz: [Errno -3] Error performing checksum
Trying other mirror.
local/primary | 922 B 00:00
http://172.20.3.32/centos/5/i386/rep...rimary.xml.gz: [Errno -3] Error performing checksum
Trying other mirror.
Error: failure: repodata/primary.xml.gz from local: [Errno 256] No more mirrors to try.



my yum repo file

[root@localhost ~]# cat /etc/yum.repos.d/local_repo.repo
[local]
name=CentOS-$releasever - local packages for $basearch
baseurl=http://172.20.3.32/centos/$releasever/$basearch
gpgcheck=0
enable=1



Thanks,
M

Last edited by mohitvad; 11-19-2012 at 08:58 AM.
 
Old 11-19-2012, 08:42 AM   #2
freelinuxtutorials
Member
 
Registered: Oct 2009
Posts: 70

Rep: Reputation: 21
is the box have internet access? can ping outside domains? are you using proxy server? pls. put more details so we can help you troubleshoot further.
 
Old 11-19-2012, 08:45 AM   #3
mohitvad
Member
 
Registered: Feb 2010
Posts: 34

Original Poster
Rep: Reputation: 0
Hi,

The box has internet access and can ping the yum server. below are the ping results.

[root@localhost ~]# ping 172.20.3.32
PING 172.20.3.32 (172.20.3.32) 56(84) bytes of data.
64 bytes from 172.20.3.32: icmp_seq=1 ttl=128 time=287 ms
64 bytes from 172.20.3.32: icmp_seq=2 ttl=128 time=344 ms

--- 172.20.3.32 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 287.519/316.225/344.932/28.712 ms


Thanks,
M
 
Old 11-19-2012, 09:16 AM   #4
mohitvad
Member
 
Registered: Feb 2010
Posts: 34

Original Poster
Rep: Reputation: 0
The error is fixed. just want to share results. After google i got below results and it feels its done.

The server is on centos 6 and createrepo is using a hash that centos 5 does not understand by default. I fixed the problem now (createrepo -d -s sha1). If you still have an error try: “yum clean all"



Thanks,
Mohit Vadhera
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] YUM not working on the client - [Errno 14] PYCURL ERROR 7 - "" infinite_scale Red Hat 3 04-25-2012 10:13 AM
yum update error on client: Cannot retrieve repository metadata (repomd.xml) yogesh29sharma Linux - Newbie 2 05-30-2011 09:30 AM
CRITICAL:yum.cli Config Error yum.conf in RHEL 6.0 chunrima Linux - Software 2 12-09-2010 07:19 PM
Yum client package/updates installation and updates through local Yum Server gautamnarayan Linux - Server 1 03-11-2010 02:51 AM
yum config error parsing file failed - yum won't run emuub Linux - Software 9 11-04-2008 06:48 AM


All times are GMT -5. The time now is 08:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration