LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-28-2014, 10:37 PM   #1
srijivdimri
Member
 
Registered: Jun 2013
Location: India.
Posts: 35

Rep: Reputation: Disabled
Yum and other Python dependencies not working.


Hi Experts,

Once of my collegue messed up with Python completely and now its effecting all of the applications dependent on it. I tried to re-install the 2.7 version of Python but still applications like Yum, GDB are not working.

# cat /etc/redhat-release
Red Hat 6.2

#python -V
Python 2.7.6

# which python
/usr/local/bin/python

When I do '# yum clean all', I get :-
Could not find platform independent libraries <prefix>
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
'import site' failed; use -v for traceback
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

No module named yum

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6.9 (unknown, Feb 13 2014, 12:11:39)
[GCC 4.4.6 20110731 (Red Hat 4.4.6-3)]


I am not sure why is it saying the current version of Python as 2.6.9.

Appreciate all your help.
 
Old 03-01-2014, 01:09 AM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,825

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
you are basically " bleeped up "
yum and parts of Gnome are VERY VERY VERY dependent on the EXACT !!!! version of python that is in the update repo

that version MUST !!! 100% MUST BE INSTALLED AND USED !!!
this is redhat
so you have a support contract
-- YOU WILL NEED IT ---

you need to grab the current python rpm update from the RHN-update repo
or the RHN install repo for 6.5

that and ONLY !!!!!! that version can be used to get yum working

and with this the even OLDER RHEL6.2 and NOT 6.5
you NEED to use the paid for redhat tech support

they are the only ones that can help you

because you need rpm's FROM the RHN repo


PS.
if you are thinking of using the centos repo for 6.2
that rpm will be using a different version number and WILL!!!! cause a unsolvable conflict
and "yum' will still not work do to that conflict

Last edited by John VV; 03-01-2014 at 01:11 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yum remove python (and 630+ dependencies--oops!) griffey Linux - Newbie 6 05-17-2012 07:18 AM
[SOLVED] Dependencies Python vte bindings spiky0011 Linux From Scratch 4 05-15-2011 07:27 AM
Python 2.6 dependencies error installing python-sqlite2-2.5.5-1.1.i586.rpm jmp007 Linux - Newbie 1 02-11-2011 12:05 PM
Pango and Python circles dependencies vivanguarda Slackware 9 04-17-2009 03:02 PM
python and bittorrent dependencies jkassemi Linux - Software 2 05-09-2004 04:39 PM


All times are GMT -5. The time now is 08:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration