LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2005, 07:20 PM   #1
dave`2005
Member
 
Registered: Aug 2005
Distribution: Ubuntu 7.10, Slackware 12
Posts: 270

Rep: Reputation: 30
You passed an undefined mode number & wheel mouse


Hi all, i get the undefined mode number message when slackware 10.1 is booting and i dont know how to fix it. Here is my xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "record"
Load "extmod"
Load "dbe"
Load "dri"
Load "glx"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "resolution" "2000"
EndSection

Section "Monitor"
DisplaySize 300 230 # mm
Identifier "Monitor0"
HorizSync 31.5-50.0
VertRefresh 60-120
VendorName "ACR"
ModelName "3011"
Option "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "NoAccel" # [<bool>]
#Option "SWcursor" # [<bool>]
#Option "ColorKey" # <i>
#Option "CacheLines" # <i>
#Option "Dac6Bit" # [<bool>]
#Option "DRI" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "XvMCSurfaces" # <i>
#Option "PageFlip" # [<bool>]
Identifier "Card0"
Driver "i810"
VendorName "Intel Corp."
BoardName "82815 CGC [Chipset Graphics Controller]"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Pretty sure something in there needs to be changed but dunno what.

While on the xorg.conf subject im using a standard logitech mouse (not optical) USB with a wheel, can anyone tell me a way to change the mouse section to get the wheel working, the last time i installed slackware (had to reinstall) i tried some program called iamwheel and alot of fiddling with the xorg.conf but to no avail.

Any help on either problems very appreciated.
 
Old 08-27-2005, 08:20 PM   #2
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
What's the error message?

for the wheel, this should work:

Option "ZAxisMapping" "4 5"
 
Old 08-27-2005, 09:01 PM   #3
dave`2005
Member
 
Registered: Aug 2005
Distribution: Ubuntu 7.10, Slackware 12
Posts: 270

Original Poster
Rep: Reputation: 30
The error message says "You passed an undefined mode number
Press <RETURN> to see video modes available, <SPACE> to continue or wait 30 seconds.

added Option "ZAxisMapping" "4 5" to the mouse section of the xorg.conf but no luck there.
 
Old 08-27-2005, 09:52 PM   #4
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
OK, then I think you should hit <return> and choose a video mode that suits you and then amend lilo.conf accordingly.

As for the mouse, you could check out this thread from the forums:

http://www.linuxquestions.org/questi...hreadid=108737

You may have to change the protocol in the mouse section of xorg.conf for zaxismapping to work.

Cheers
 
Old 08-28-2005, 08:33 AM   #5
dave`2005
Member
 
Registered: Aug 2005
Distribution: Ubuntu 7.10, Slackware 12
Posts: 270

Original Poster
Rep: Reputation: 30
I pressed <RETURN> to get a list of the modes and have tried them all, the only 2 that work are:

0 0F00 80x25
1 0F01 80x50

I prefer mode 1 as it shows more text.

Quote:
OK, then I think you should hit <return> and choose a video mode that suits you and then amend lilo.conf accordingly.
Had a look at the lilo.conf but not too sure what to amend. Here is my lilo.conf:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda1
label = Linux
read-only
# Linux bootable partition config ends
 
Old 08-28-2005, 09:09 AM   #6
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
This is from the lilo.conf man page

"vga= mode

This specifies the VGA text mode that should be selected when booting. The following values are recognized (case is ignored): normal : select normal 80x25 text mode. extended (or ext ): select 80x50 text mode. ask : stop and ask for user input (at boot time). <number>: use the corresponding text mode. A list of available modes can be obtained by booting with vga=ask and pressing [Enter]. If this variable is omitted, the VGA mode setting contained in the kernel image is used. (And that is set at compile time using the SVGA_MODE variable in the kernel Makefile, and can later be changed with the rdev(8) program.)"

You could change lilo.conf to
vga = 1
instead of vga = 773

80x25 is vga = normal and is the same as vga = 0
80x50 is vga = 1

Last edited by dcdbutler; 08-28-2005 at 09:13 AM.
 
Old 08-28-2005, 11:05 AM   #7
dave`2005
Member
 
Registered: Aug 2005
Distribution: Ubuntu 7.10, Slackware 12
Posts: 270

Original Poster
Rep: Reputation: 30
In the lilo.conf i changed vga = 773 to vga = 1 and then reboot, it still says passed an undefined mode number etc, is there something im missing ?
 
Old 08-28-2005, 11:20 AM   #8
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
how about
vga = normal
does this work?
To be safe, remember to always run lilo after editing. (# lilo)
 
Old 08-28-2005, 11:38 AM   #9
dave`2005
Member
 
Registered: Aug 2005
Distribution: Ubuntu 7.10, Slackware 12
Posts: 270

Original Poster
Rep: Reputation: 30
ran lilo after editing the lilo.conf and its working

Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vesafb "passed an undefined mode number" fatblueduck Linux - Newbie 4 09-16-2005 10:22 PM
You passed an undefined mode number priest_judas Linux - Newbie 12 02-08-2005 05:16 PM
You passed an undefined mode number priest_judas Linux - Hardware 3 12-11-2003 04:19 PM
Slack 9.1 - You passed an undefined mode number priest_judas Slackware 1 12-11-2003 07:56 AM
You have passed an undefined mode number. acidslut Slackware 5 08-17-2003 11:00 PM


All times are GMT -5. The time now is 07:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration