LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-11-2003, 08:30 AM   #1
priest_judas
Member
 
Registered: Dec 2003
Distribution: Slackware 9.0
Posts: 32

Rep: Reputation: 15
Unhappy You passed an undefined mode number


You passed an undefined mode number

Press <RETURN> to see video modes available, <SPACE> to continue or wait
30 secs



sorry for bothering you all with this question again... Iīve already read many threads with this subject and have already done everything I read, but nothing seems to work here with my slackware 9.1 ._.

I tryed pico /etc/lilo.conf

and changed to vga=771, and then to vga=773, and then to vga=788, and then to vga=ask, and then to vga=normal.... but when I try "startx" my monitor gets strange... some green and blue lines appear...

note: with vga=normal the "You passed an ..." didnīt show up, but the startx continued all messed ._.

I donīt really know whatīs happening... red hat and mandrake didnīt give me this error of "undefined mode etc...", so it proves my computer can work well with linux

knoppix gave me this "undefined mode etc..." in the beggining of the boot too, but I chose zero and then everything went well... I checked knoppinxīs lilo.conf and found a vga=normal in there... but in my slack, it doesnīt seem to work

I have an Intel 810 onboard video card... and knoppix detect something like this about my monitor: 30-54 Khz and 50-120 Khz....

what should I do??? óō
 
Old 12-11-2003, 08:51 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Probably got the hsync and vsync modes wrong. I'd suggest getting the exact modes it can handle and either edit your XF86Config file or just reconfiguring with xf86config. Especially since your getting blue and green lines, etc on your screen.

Also, the first problem, I have the same video card using Slackware 9.0 on one of my machines and I can't get the framebuffering to work at all in any mode, have to use vga=normal for some reason myself, nothing else works. I guess the card just really doesn't like framebuffering in the console, etc.
 
Old 12-11-2003, 09:00 AM   #3
priest_judas
Member
 
Registered: Dec 2003
Distribution: Slackware 9.0
Posts: 32

Original Poster
Rep: Reputation: 15
how can i get to know my hsync and vsync modes? and how can I reconfigure using xf86config? Iīm a total newbie ._.
 
Old 12-11-2003, 11:22 AM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Quote:
Originally posted by priest_judas
how can i get to know my hsync and vsync modes? and how can I reconfigure using xf86config? Iīm a total newbie ._.
Check manufacturer specs, manual, online, etc? Then as root just run xf86config and it will prompt for information, etc.
When you get to choose your hsync and vsync, you can select to input your own ranges, etc.

Check this discussion out: http://www.linuxquestions.org/questi...ticle&artid=16
 
Old 01-04-2004, 05:42 PM   #5
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
I don't think the question was answered here, at least not my version of it. At bootup I get the same "undefined mode number" error and I'm given the option to choose one or scan for additional ones. After scanning, I choose 132 columns x 60 lines, or something close to that, and Linux continues to boot and everything else is happy.

Does this indicate a LILO setting and NOT XF86Config?

How can I set the default mode at startup so that this doesn't happen?

Thanks,
Kent
 
Old 01-04-2004, 07:14 PM   #6
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Its a LILO problem. Whatever distro you are using tried to kick on framebuffering by default and your monitor or vid card can't handle the res it was put to. If you just want the problem to go away and don't really care about pretty resolutions on the ttys, then just change whatever the current lilo vga setting is to read:

vga=normal

And then just re-run /sbin/lilo.

It'll boot 80x25, but at least it'll get rid of that prompt so you can auto-boot again.

Cheers,

Finegan
 
Old 10-15-2004, 10:09 AM   #7
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
I am revisiting this after several days of researching and trying to get my computer to boot to 132x60 resolution. This does not appear to be a framebuffer issue since, after trying it both ways, I currently have FB support turned off in the kernel. I have a built-in Intel i810e video system which, as I understand, does not support VESA.

At bootup I get the undefined modes message and then I scan for options and choose "b 0123 132x60," the resolution changes and the boot continues. How do I set this option without having to scan? None of the VGA= options work, I've tried them.

With FB support turned on, I get the same undefined modes message but when I choose 132x60 the resolution is set to 80x30, which I don't want. (Again, the VGA= options don't work.) The line "probe of vesafb0 failed with error -6" appears in dmesg.

I know this is an insignificant problem, but it's annoying that I can't get it to work the way I want and doesn't seem to work the way it should.

Kent

Last edited by oxleyk; 10-15-2004 at 05:39 PM.
 
Old 10-15-2004, 03:33 PM   #8
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
I've got a machine around with an onboard i810 and vesa working on it... if there's a difference between that and an i810e I've not heard of it, but there are a lot of chipsets out there.

I always just compile VESA directly into the kernel, haven't ever bothered with trying it as a module. If you were to, I'm certain you would have to put it in an initrd as it has to load at boot.

Just to check that all the kernel options are the same for vesa:

Quote:
[*] VGA text console x x
x x[*] Video mode selection support x x
x x < > MDA text console (dual-headed) (EXPERIMENTAL) x x
x x Frame-buffer support --->
The important one there being VGA of course, but also Video mode selection support.

Then under Framebuffer:

Quote:
[*] Support for frame buffer devices (EXPERIMENTAL) x x
x x< > nVidia Riva support (EXPERIMENTAL) x x
x x< > Cirrus Logic support (EXPERIMENTAL) x x
x x< > Permedia2 support (EXPERIMENTAL) x x
x x< > Permedia3 support (EXPERIMENTAL) x x
x x< > Cyber2000 support x x
x x[*] VESA VGA graphics console x x
x x< > VGA 16-color graphics console x x
x x< > Hercules mono graphics console (EXPERIMENTAL)
And none of the card specific ones...

I also tend to drop in:
[*] Advanced low level driver options

And the defaults that come with it.

The same is true for 2.6.

Also, apparently lilo supports passing a straight svga video mode to the kernel (or, no kidding, you can compile it in!). I would try to explain it, but really I would just being badly regurgitating what I just read in:

/usr/src/linux/Documentation/svga.txt

It seems that there's a weird mode schema for regular svga modes that's somewhat unlike framebuffer... Regardless, I'm pretty certain you'll need video mode selection in there no matter what.

Cheers,

Finegan
 
Old 10-18-2004, 10:09 AM   #9
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
It's amazing what you can learn by reading the documentation, but I'm new enough to Linux that I don't always know where it is. I found the file intel810fb.txt in /usr/src/linux-2.6.8.1/Documentation/fb which explains how to boot into graphics mode my putting an "append=" line in lilo.conf and now my computer boots into 1024x768!

I'm still trying to find out how to boot in text mode at 132x60 (sigh).

Kent

Last edited by oxleyk; 02-08-2005 at 06:17 PM.
 
Old 10-20-2004, 02:30 PM   #10
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
According to what I've found...

vga=0xA

At least, it seems that should work.

Cheers,

Finegan
 
Old 12-21-2004, 09:58 AM   #11
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
A follow-up---

I recently switched to Fedora Core 3 and I discovered that after scanning for the available modes, I normally choose "a 0123 132x60," the 0123 (hexadecimal) is what I need to use for "vga=xxx" but it must be converted to decimal, in this case vga=291.

KCalc has a converter function.

I don't know why it took so long to find that answer.
 
Old 02-08-2005, 03:42 PM   #12
acop
LQ Newbie
 
Registered: Feb 2005
Location: poland
Distribution: slackware 10
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by oxleyk
It's amazing what you can learn by reading the documentation, but I'm new enough to Linux that I don't always know where it is. I found Inteli810fb.txt in /usr/src/linux-2.6.8.1/Documentation/fb which explains how to boot into graphics mode my putting an "append=" line in lilo.conf and now my computer boots into 1024x768!

I'm still trying to find out how to boot in text mode at 132x60 (sigh).

Kent
I don't have that file.. Could anyone tell me where to find that Inteli810fb.txt?
 
Old 02-08-2005, 06:16 PM   #13
oxleyk
Member
 
Registered: Nov 2003
Distribution: Ubuntu
Posts: 309

Rep: Reputation: 30
Sorry! That's a typo on my part. The file is intel810.txt

Kent
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vesafb "passed an undefined mode number" fatblueduck Linux - Newbie 4 09-16-2005 11:22 PM
You passed an undefined mode number & wheel mouse dave`2005 Linux - Newbie 8 08-28-2005 12:38 PM
You passed an undefined mode number priest_judas Linux - Hardware 3 12-11-2003 05:19 PM
Slack 9.1 - You passed an undefined mode number priest_judas Slackware 1 12-11-2003 08:56 AM
You have passed an undefined mode number. acidslut Slackware 5 08-18-2003 12:00 AM


All times are GMT -5. The time now is 08:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration