LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 08-27-2009, 05:11 PM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 617

Rep: Reputation: 33
You don't have permission to access /phpmyadmin/ on this server.


I am connected via OpenVPN to the server that has PhpMyAdmin installed. The server is 10.10.0.1 and my client is 10.10.0.2.

When I want to access phpmyadmin, the webpage states :
Code:
You don't have permission to access /phpmyadmin/ on this server.
This is my config :
Code:
bash-3.2# cat /etc/httpd/conf.d/phpmyadmin.conf 
<Directory "/usr/share/phpmyadmin">
  Order Deny,Allow
  Deny from all
  Allow from 10.10.0.2
</Directory>
Why don't I have permission ??

Extra info :
Code:
[jonas@jonas ~]$ ifconfig tun0
tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.10.0.2  P-t-P:10.10.0.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:1282 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1145 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:1012756 (989.0 KiB)  TX bytes:113557 (110.8 KiB)
Log states :
Code:
[Fri Aug 28 00:11:56 2009] [error] [client 10.10.0.2] Directory index forbidden by Options directive: /usr/share/phpmyadmin/
[Fri Aug 28 00:11:59 2009] [error] [client 10.10.0.2] Directory index forbidden by Options directive: /usr/share/phpmyadmin/
[Fri Aug 28 00:15:04 2009] [error] [client 10.10.0.2] Directory index forbidden by Options directive: /usr/share/phpmyadmin/

Last edited by jonaskellens; 08-27-2009 at 05:17 PM.
 
Old 08-27-2009, 05:24 PM   #2
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, FreeBSD
Posts: 3,925
Blog Entries: 5

Rep: Reputation: Disabled
Apache is not finding an index page (e.g. .html, .php) to serve, so it's trying to display a directory index. But... you've disabled that (which is probably fine because it's not what you're trying to do anyway).

What have you provided for the DirectoryIndex directive in httpd.conf?
 
Old 08-27-2009, 05:32 PM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 617

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by anomie View Post
What have you provided for the DirectoryIndex directive in httpd.conf?
Code:
DirectoryIndex index.html index.html.var
I left everything default...

I just need httpd for running PhpMyAdmin...
 
Old 08-27-2009, 05:39 PM   #4
anomie
Senior Member
 
Registered: Nov 2004
Location: Texas
Distribution: RHEL, Scientific Linux, Debian, Fedora, FreeBSD
Posts: 3,925
Blog Entries: 5

Rep: Reputation: Disabled
If you haven't already, install mod_php.

And what distro is this? Fedora? CentOS?

-------

edit: On some distros, mod_php is included with the php package.

Last edited by anomie; 08-27-2009 at 05:40 PM.
 
Old 08-27-2009, 05:48 PM   #5
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 617

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by anomie View Post
If you haven't already, install mod_php.

And what distro is this? Fedora? CentOS?

-------

edit: On some distros, mod_php is included with the php package.
This is CentOS 5.3.
Re-installing the php-package made it work.
Thanks for the help !
 
Old 12-19-2009, 02:25 PM   #6
dgreenhouse
LQ Newbie
 
Registered: Nov 2009
Posts: 1

Rep: Reputation: 0
I had this same issue.

I noticed that when I uncompressed the phpMyAdmin archive and moved it to the target location I was getting the permissions error.

I performed a copy (cp) of the uncompressed folder and it worked!
(I downloaded the english only archive)

(Note: I'm running CentOS 5.4 i386)

Steps...

0- After downloading the tar file to /tmp
1- cd /tmp
2- tar -xzvf phpMyAdmin-3.2.4-english.tar.gz
3- cp -Rf phpMyAdmin-3.2.4-english /usr/share/phpmyadmin
4- echo "alias /phpmyadmin /usr/share/phpmyadmin" > /etc/httpd/conf.d/phpmyadmin.conf
4a- You can add <DirectoryIndex ...> ... </DirectoryIndex> to phpmyadmin.conf, but I'm running locally for the moment and didn't need it. The alias command worked just fine.
5- cp /usr/share/phpmyadmin/config.sample.inc.php /usr/share/phpmyadmin/config.inc.php
6- Make the appropriate changes to: config.inc.php
7- service httpd restart or /etc/init.d/httpd restart

After that, it worked just fine...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SVN Server Access Permission??? ajeetraina Linux - Server 2 03-22-2008 12:31 AM
You don't have permission to access /~username on this server. sijolinux Linux - Newbie 5 01-03-2008 05:19 PM
you don't have permission to access / on this server dus3d Linux - Software 5 04-18-2006 11:43 PM
You don't have permission to access / on this server. jkpalmer52 Linux - General 4 01-27-2004 04:05 PM
You don't have permission to access / on this server jaydave Linux - Networking 1 03-15-2003 06:11 AM


All times are GMT -5. The time now is 04:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration