LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-27-2001, 01:39 PM   #1
phek
Member
 
Registered: Jul 2001
Location: California, US
Distribution: Slackware
Posts: 196

Rep: Reputation: 30
XWin desktop is 4x bigger than my monitor


I've finally got my linux box up and running but when I installed xwin my desktop is 4x the size of my monitor screen so, I have to scroll around to see everything. I've checked that it is running the correct video card (s3virge/dx) and it looks like it has to do with my horz./vert. freq. Now my monitor says its 30-85 Horz. and 50-160 Vert. but when I set XF86Config to that it's about 4 times too big. I have a CTX PR705F flat crt monitor if anyone knows any bugs with that, and I suppose I should just keep f'in with the frequency's but has anyone ever heard of the desktop not fitting when givin the monitor specific settings?
 
Old 08-27-2001, 03:32 PM   #2
Runt888
LQ Newbie
 
Registered: Aug 2001
Location: Ft. Collins, CO
Posts: 10

Rep: Reputation: 0
Have you tried changing the resolution? Just type in Xconfigurator at the command prompt (you might have to be logged in as root, I'm not sure). It will have you choose your video card and monitor, then give you a choice of number of colors and resolutions. Choose a higher resolution (ie 1024x768) to make everything smaller.
 
Old 08-27-2001, 03:54 PM   #3
d3funct
Member
 
Registered: Jun 2001
Location: Centralia, WA
Posts: 274

Rep: Reputation: 31
You MAY not have to do even that. Before running "Xconfigurator" again try using the Control+ALT and the + or - keys on the number pad to cycle through the resolutions defined on your system. If your monitor was recognized and setup with more than one resolution this should work. If it was only set at the huge resolution you describe you will probably have to reconfigure X.
 
Old 08-27-2001, 05:38 PM   #4
phek
Member
 
Registered: Jul 2001
Location: California, US
Distribution: Slackware
Posts: 196

Original Poster
Rep: Reputation: 30
OK, the ctrl+alt+- worked, but there's 2 problems...

1. When I reload xwin it goes back to being too big, is there somewhere I can change the default resolution.

2. All the icons and default text are way too small now, I know if i go into the control center I can change the default icon and font size but it still doesnt help with independent applications such as netscape (the default text in the browser is still way to small). Is there some way to change the resolution but keep the screen size?


thanks,
phek
 
Old 08-28-2001, 05:57 AM   #5
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
To change the default resolution, you can edit your /etc/X11/XF86Config file (/etc/XF86Config-4 in versions 4.x.x of X). Under the "screen" section of the file, look for the "device" sub-section which defines your particular video card; the "Modes" line beneath that will list your available resolutions. The first resolution listed will be the default resolution X uses when it fires up. To change that, edit the order in which the resolutions appear. For example, if you see
Code:
Subsection "Display"
Depth  xx   #where xx is the color-depth
Modes "640x480" "800x600" "1024x728"
just edit the values on the "Modes" line such that your desired resolution appears first. As an example of altering the above listing:
Code:
Subsection "Display"
Depth  xx   #where xx is the color-depth
Modes "1024x728" "800x600" "640x480"
If you have multiple color-depths configured, change the "Modes" line under each to suite your order of preference of resolutions.
 
Old 08-28-2001, 06:07 AM   #6
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Also, as far as font sizes and such within certain applications (especially your browser)- no, that isn't a function of X's resolution. Netscape fonts by default look pretty friggin' bad. You should go into the Netscape preferences and try different font settings to see if you can get something more to your liking.
I've also seen instructions on how to make TrueType fonts available to your Linux apps within X, but it was a while ago, and I can't remember how I got it to happen. Maybe a search at www.google.com for a keyphrase such as "TrueType fonts in X" would help.
 
Old 08-28-2001, 05:46 PM   #7
weblion
Member
 
Registered: Jun 2001
Location: Antarctica.
Distribution: Slackware
Posts: 78

Rep: Reputation: 15
When you configure X, it asks you if you want to make the resolution bigger than the physical screen. I'm not sure what it's called, but when you set the resolutions, it asks you if you want it to fill the screen or make it bigger. You can answer no to the question. To reconfigure it run xf86config.
 
Old 08-28-2001, 05:56 PM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally posted by weblion
When you configure X, it asks you if you want to make the resolution bigger than the physical screen. I'm not sure what it's called, but when you set the resolutions, it asks you if you want it to fill the screen or make it bigger. You can answer no to the question. To reconfigure it run xf86config.
I think it is called along the lines of a virtual screen or virtual desktop, making the actual desktop larger than the screen, where you have to scroll around to get everywhere.
 
Old 08-28-2001, 08:38 PM   #9
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Quote:
Originally posted by trickykid
I think it is called along the lines of a virtual screen or virtual desktop, making the actual desktop larger than the screen, where you have to scroll around to get everywhere.
Right, forgot about that part. If you have the virtual desktop happening, directly below the "Modes" line in XF86Config will be a "virtual" line, the format of which will be something like: "virtual 640 480". To disable it, either delete the line or comment it out with a #.
The format of the XF86Config-4 file may be slightly diffent, but I'm not at my Linux box right now so I can't check.
 
Old 08-29-2001, 12:16 PM   #10
phek
Member
 
Registered: Jul 2001
Location: California, US
Distribution: Slackware
Posts: 196

Original Poster
Rep: Reputation: 30
i don't have a line under modes that says
"Virtual 640 480"
but I do have a line under there that says
ViewPort 0 0
I'm kinda curious as to what that is.

thanks for the help,
phek
 
Old 08-29-2001, 12:31 PM   #11
phek
Member
 
Registered: Jul 2001
Location: California, US
Distribution: Slackware
Posts: 196

Original Poster
Rep: Reputation: 30
while I'm on the subject of video and xwin I'm having another problem too, I can only go into XWin with a Depth of 8, if i try 16 or 24 there's lines through the screen and its pretty garbled. I have a 4MB video card, and in ms win i can do 24-bit fine. I'm just wonderin why this is, does xwin use more video ram than ms win?
 
Old 08-29-2001, 05:25 PM   #12
weblion
Member
 
Registered: Jun 2001
Location: Antarctica.
Distribution: Slackware
Posts: 78

Rep: Reputation: 15
For the virtual desktop problem, try running xf86config. If that doesn't work try XF86Setup, or any of the to with different cases. Because out of what I am seeing, it seems like you're all talking about the config file.
 
Old 08-29-2001, 06:46 PM   #13
phek
Member
 
Registered: Jul 2001
Location: California, US
Distribution: Slackware
Posts: 196

Original Poster
Rep: Reputation: 30
I've tried it with both in xf86config, answering yes and no to virtual desktop and it gives me nearly the same results...
Whether or not I choose virtual desktop, the desktop is too big for my screen and I have to scroll (thought you wouldn't be able to scroll without virtual desktop but i was wrong). The only difference I noticed was that with virtual desktop enabled, not even 1280x1024 would fit on the screen.

I mean this just doesn't seem right, you shouldn't need a 50" monitor to view a resolution of 640x480 should you?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Make kde bigger ( desktop) Master Fox Linux - Software 4 08-19-2004 03:49 PM
Desktop bigger than screen, I don't like that. lectraplayer Linux - Hardware 4 03-11-2004 06:43 PM
Gentoo + Xfree86 4.3.0 = bigger then monitor jasghar Linux - Software 3 11-18-2003 08:46 PM
Sampling bits of information in bigger and bigger pieces lugoteehalt General 0 10-29-2003 06:38 AM
Desktop bigger than monitor. pjs2550 Linux - Newbie 2 05-21-2002 04:45 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration