LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-18-2008, 05:31 PM   #1
batfastad
Member
 
Registered: Nov 2004
Location: London, UK
Distribution: CentOS, RHEL, Debian, IPCop, PS2Linux
Posts: 95

Rep: Reputation: 23
Question Xubuntu, prevent xfce loading on startup


Hi everyone
I'm trying to build a sort of test-server using Xubuntu to mess around and get used to Linux.

How can I stop the window manager (xfce in Xubuntu) loading on startup?
I just want Linux to start with the user/pass prompt. Then to manually type the command to start up the Xubuntu GUI.
I'm guessing it's a config script I need to edit somewhere, but where can I find it in Xubuntu?

Thanks, B
 
Old 06-18-2008, 05:45 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Jessie, Linux Mint 17
Posts: 7,751

Rep: Reputation: 272Reputation: 272Reputation: 272
Change the default runlevel in /etc/inittab.

--------------------
Steve Stites
 
Old 06-18-2008, 06:04 PM   #3
madcowjim
LQ Newbie
 
Registered: Jan 2005
Location: Happy Valley, USA
Distribution: Ubuntu 8.04
Posts: 9

Rep: Reputation: 0
Quote:
Originally Posted by jailbait View Post
Change the default runlevel in /etc/inittab.

--------------------
Steve Stites
I thought Ubuntu got rid of the inittab? I'm running Hardy Huron and I know I don't have it. There is more about it being gone here: http://www.linuxquestions.org/questi...nittab-506281/

Besides, even if you change the default runlevel, all runlevels in Ubuntu have the GUI enabled by default (other than single user mode), so changing the runlevel wouldn't disable it either.

The best fix I could find quickly was here: https://lists.ubuntu.com/archives/ub...ly/087620.html.

Basically if you change the file /etc/X11/default-display-manager to say "false" instead of "/usr/sbin/gdm" (or whatever it is you are using), it will disable the GUI on startup. This fix is for ubuntu, so it should be pretty similar for xubuntu.

- James
 
Old 06-25-2008, 05:50 PM   #4
batfastad
Member
 
Registered: Nov 2004
Location: London, UK
Distribution: CentOS, RHEL, Debian, IPCop, PS2Linux
Posts: 95

Original Poster
Rep: Reputation: 23
Found the best way for Ubuntu...
Code:
sudo update-rc.d -f gdm remove
Removes the gdm graphical login manager from all run levels. Then quitting from xfce just drops me straight back to the logged-in shell

Hope this helps someone out.

Cheers, B
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
REALLY Locking Down XFCE 4.4 (Xubuntu) Codegen Linux - Desktop 1 03-21-2008 02:06 PM
Questions on XFCE and Xubuntu.....help please. Coffee1970 Linux - Newbie 1 02-12-2008 09:02 PM
Missing panels - Xubuntu 6.06 (XFCE 4.2 or 4.4) Jorophose Linux - Software 0 04-04-2007 07:44 PM
Does Xfce have a Display Manager? What are the ones in Xubuntu and Zenwalk? Mr_Shameless Linux - Desktop 4 03-10-2007 06:19 AM
Xubuntu - xfce is constantly disabled pjo Ubuntu 3 12-31-2006 03:50 PM


All times are GMT -5. The time now is 12:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration