LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-28-2008, 03:57 PM   #1
catholiclibertarian
LQ Newbie
 
Registered: Feb 2008
Location: Detroit, MI, USA
Distribution: Xubuntu 8.10; DSL 4.2.5
Posts: 17

Rep: Reputation: 0
Xubuntu doesn't shut down completley


I tired posting this on the Ubunutu forums first with no useful response

I've recently installed Xubuntu 8.04 after liking the live CD of Ubunut and I heard that XFCE was "lighter."

Well I'm having one fairly large problem. When I shutdown the computer it never actually shuts down. It shows a few lines of text, nothing that at least appears to be an error to me, then a flash screen shows up that just says XUBUNTU with a mouse, similar to that that at the loading screen, and that is as far as it gets, it never finishes the shut down. When I eventually power it down manually I don't feel as though I'm loosing any saved information, though it seems like its running a bit slower. I have no problem using the RESTART option nor the LOG OUT option.

How can i fix this?

After a while I stopped worrying about it and just went about like normal, shutting the PC down manually whenever this "lock out" happened. My first thought was "perhaps this is like the 'your computer is now safe to shut down' screen from the windoze 95 days"

now the problem has gotten way worse, anytime i don't do anything for a while, like if i wonder away from my PC while its running Opera or Firefox, the computer just feezes, I can't get it to respond to an keyboard commands like CTRL-ALT-ESC or CTRL-ALT-BACKSPACE.

What's the best way to fix this, I can exit X and run from the command line with little troule
 
Old 10-28-2008, 06:19 PM   #2
izaakrach
Member
 
Registered: Jun 2006
Location: Reno, NV USA
Distribution: Ubuntu
Posts: 32

Rep: Reputation: 16
My first thought would be that either you don't have ACPI enabled or that it's not working right. I don't use Ubuntu or any of it's cousins so I don't know where to tell you to look but if you search for ACPI you should be able to figure it out. As far as using the command line to turn off or restart your computer the answer is yes you can. All you have to do is type either "poweroff" or "reboot" and you are all set.
I would also check the BIOS to see if you have your ACPI settings set up right.

My other thought comes from you saying that now applications freeze. I've seen this many times in laptops that are either old or have been mis-treated. Sometimes you get bad sectors on the hard drive and you will need to run some sort of physical check to see if there are any bad areas. If you are still running the live CD which I was unclear if you were or not, your CD may just be dirty or scratched. You could also try cleaning the drive. Did you verify the MD5 sum before you burned the .iso? Your installation may have been corrupted.

cheers
 
Old 10-28-2008, 06:20 PM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,297

Rep: Reputation: 126Reputation: 126
Has the date been changing on you, as well, by any chance?
 
Old 10-29-2008, 10:14 PM   #4
catholiclibertarian
LQ Newbie
 
Registered: Feb 2008
Location: Detroit, MI, USA
Distribution: Xubuntu 8.10; DSL 4.2.5
Posts: 17

Original Poster
Rep: Reputation: 0
TO answer a couple of your questions.

1.) I am no longer running the Live CD. This problem is occurring on a fresh install.

2.) I do have ACPI installed, I don't see anything inadvertently wrong with its configuration right now, but I may not know what I'm looking for.

3.) My time & date is adjusting appropriately.

4.) As far as when X "freezes" it seems to work fine as long as i'm "doing something" but anytime i wander away for more than a minute or so it just locks up
 
Old 10-30-2008, 12:00 AM   #5
izaakrach
Member
 
Registered: Jun 2006
Location: Reno, NV USA
Distribution: Ubuntu
Posts: 32

Rep: Reputation: 16
Forgive me for my from the beginning approach here but I am an old school hardware guy. If it were my computer I would first disable ACPI just for fun to see if anything changes. If it continues then I would re-enable ACPI and move on to removing all expansion cards and things like printers. I might even remove a fancy video card and go back to the on-board video. At this point I would try to re-create the problem. If it's fixed, then I would start adding a single piece of hardware at a time until I found the one that caused the problem. If none of that worked, I would most likely re-install the OS. I think I would also try resetting the optimized defaults in your BIOS and maybe even looking for an upgrade to your BIOS.

good luck!
 
Old 11-01-2008, 06:17 AM   #6
tomslick
LQ Newbie
 
Registered: May 2003
Posts: 25

Rep: Reputation: 18
this is a off the wall shoot in the dark, but,

in hardy a package called keytouch would stop the system from shutting down, just as you described
 
Old 11-16-2008, 02:15 PM   #7
catholiclibertarian
LQ Newbie
 
Registered: Feb 2008
Location: Detroit, MI, USA
Distribution: Xubuntu 8.10; DSL 4.2.5
Posts: 17

Original Poster
Rep: Reputation: 0
All good ideas.

OK, here's how I ended up fixing the issue.
I used the comand stopx. Then when I got to just the command it gave me an option to fixx, so I did. And sure enough everything worked right then. I lost the configuration I had done in the Xconfig to make buttons 4 and 5 on my track ball act like a scroll wheel, and X config was back to default. I tried editing just that part again, and sure enough same problem. ( I just copied and pasted some code had I found on this forum).

Tomslick:I actually did have keytouch installed, but since I had gotten quicker results by simply changing the keyboard shortcuts in the XFCE Settings manager, I simply removed that program recently, though that was after I fixed it.

Now I'm back to trying to get those scroll buttons to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
shut down scialom Linux - Hardware 2 03-18-2004 08:14 AM
shut down won't shut system down taoweijia Linux - General 3 03-03-2004 06:05 PM
linux completley freezes suse 8.2 rvn Linux - Newbie 9 10-07-2003 06:25 PM
X won't shut down palooga Linux - Newbie 2 09-21-2002 08:06 PM
Mac User Completley: Completley New to Linux! HELP! nelio87 Linux - Newbie 2 06-22-2002 09:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration