LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-27-2008, 12:59 AM   #1
Starius
Member
 
Registered: Jul 2007
Posts: 50

Rep: Reputation: 15
Xubuntu Blacking Out On New Install On Old Laptop


I just did a brand new install of Xubuntu on my old NCS computer Model: NBC105-ts05

Anyways, after the install it said it would restart but after it restarted the bios loaded up like normal and when it got the part where linux should start loading instead of loading it went black screen. I left it on for 3 hours to see if it was just a VERY VERY slow load but still its black screened.
 
Old 11-27-2008, 02:52 AM   #2
jiobo
Member
 
Registered: Nov 2008
Posts: 180

Rep: Reputation: 36
Try some of the other boot up options, such as "safe mode" or console only.
 
Old 11-27-2008, 02:56 AM   #3
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mint-xfce
Posts: 183

Rep: Reputation: 21
I am not familiar with that make of computer, but you can try adding some options to the boot process!
Could first try booting to text mode to see if the problem is with X, this may be available as a menu choice on boot screen!
Or specify a generic video mode by passing vesa (??) to the kernel.

Are you getting anything displayed ie scrolling on the screen before it goes black?
Do you know what video card/chipset you are using? motherboard?
 
Old 11-27-2008, 03:49 AM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,721

Rep: Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120Reputation: 2120
I have a (old) machine that does similar (Ubuntu, zenwalk, mepis)- try the following to see if X isn't handling things properly.
Just hit <ctrl>-<alt>-<bspc> and see if X exits and restarts and gives you the login screen. Try a couple of times in need.

Last edited by syg00; 11-27-2008 at 03:57 AM.
 
Old 11-27-2008, 01:53 PM   #5
Starius
Member
 
Registered: Jul 2007
Posts: 50

Original Poster
Rep: Reputation: 15
So how do I add these other options like safe mode of console only? I have no clue what I'm doing lol.
 
Old 11-27-2008, 02:01 PM   #6
Starius
Member
 
Registered: Jul 2007
Posts: 50

Original Poster
Rep: Reputation: 15
Ok I got some stats of the laptop from the memory tester.

Pentium 3 1194 MHZ
L1 cache: 32k 11703 mb/s
L2 Cache: 256k 5851 MB/s
Memory: 368 269 MB/s

Thats all I saw that seemed useful

Last edited by Starius; 11-27-2008 at 03:00 PM.
 
Old 11-28-2008, 07:11 PM   #7
roy_lt_69
Member
 
Registered: Aug 2006
Location: Vancouver, BC, Canada
Distribution: Slackware, Bodhi, Mint-xfce
Posts: 183

Rep: Reputation: 21
First off you are probably using GRUB, if not disregard everything that follows!

When you boot up your PC (after the POST) you will see a menu screen, quickly press the <down> key to stop the timer for the default boot.
On the screen there is often a menu choice for a text/console/rescue/non-gui/single-user mode, select it using the <up> or <down> cursor keys then press <enter>.
If there is none, then you will need to edit an existing menu choice by passing additional "boot options" to the kernel.
You might want to do a search on this web site for how to do this!
But from memory, I believe what you will need to do is:
1)select the menu choice
2)press <e> to edit that choice
3)select the line that starts with "kernel"
4)press <e> to edit the "kernel" line
5)enter the number 2 or 3 at the end of the line to specify console mode
6)press <enter>
7)press <b> to boot with the changes
You can pass other parameters to Linux at step 5, eg vesa for a generic video mode on some distros.

This should boot Linux into a console mode (ie no GUI or X mode).
If you get the Login prompt then most likely the problem is a video card driver problem or your X config is not correctly configured!
You might be able to try running X manually by entering startx.
Use <ctl-alt-backspace> to abort X.


You may need to determine the video card in your system in order to get it to work properly!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xubuntu GUI not running on old Toshiba laptop mrtumnus Linux - Laptop and Netbook 3 09-04-2008 08:36 AM
xubuntu wired network laptop not seeing my ubuntu box larryfroot Linux - Networking 0 03-17-2008 04:20 PM
Xubuntu too much for Dell Laptop -Alternatives? zambonibutt Linux - Distributions 1 11-21-2007 03:53 PM
No sound, Dell C610 laptop, Xubuntu 7.04 FF Chili.Willy Linux - Hardware 0 07-09-2007 09:04 PM
System keeps blacking out~ xhunter Linux - General 4 10-14-2003 03:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration